Answered

Sonos One unresponsive to Alexa commands

  • 13 November 2018
  • 3 replies
  • 1543 views

I have 2 Sonos One speakers running stereo in one room. All of a sudden they have stopped responding to Alexa commands. The mikes are on and running. I know this because when I say Alexa I get the sound indicating that they are hearing. When I then give a command such as "Play Van Morrison", nothing happens. If I give a command to give the weather, nothing happens. I can control the speakers playback of music from my desktop. I can also get them to play music by giving Alexa commands to Echos and Echo dots in other rooms and asking to play music from the 2 Sonos speakers. Any suggestions would be greatly appreciated as their responsiveness to commands is greatly missed.
icon

Best answer by UKMedia 14 November 2018, 15:47

Hi

This type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +20
Hi

This type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Badge
Same issue here. What fixed it (at least for now) was "In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room'" and then immediately re-enabling it.
Same issue here. What fixed it (at least for now) was "In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room'" and then immediately re-enabling it.

This worked for me. Thanks. When I looked in the Alexa app, under ‘Activity’ it would just list ‘play’, or indeed, nothing. This was despite the actual voice command being ‘play some upbeat pop’ etc. When you listen to the actual recording of the command , it was clipped. Seems sorted now - and playback of commands are clear.