Answered

Sonos One Not Responding to Alexa Comands

  • 30 October 2017
  • 35 replies
  • 52710 views

Userlevel 2
Badge
Just setup the Sonos One. All steps were followed and setup went smoothly, However it is not responding to any commands. It does acknowledge the command where I ask to play music, but doesn't complete the action.

Diag:8022698
icon

Best answer by UKMedia 31 October 2017, 22:58

Hi Gazzstevens

Can you please try these actions:

- In the Alexa app, select 'Skills' and disable the Sonos Skill;
- In the Alexa app (PC version), select 'Smart Home' then 'Devices';
- Select 'Forget All' at the bottom of the screen;
- In the Sonos app, select 'Settings' and for each of the Sonos 1's remove 'Voice Recognition';
- If you have a Connect, please power down and then switch on and wait for it to boot;
- Power down the two Sonos 1's and then switch them back on and wait for them to boot;
- In the Sonos app, Select 'Manage' and then select 'Add a player or sub' and add the two Sonos 1's again. This will complete the set-up process again;
- In the Alexa app, select 'Skills' and ensure the Sonos skill is enabled, if not please 'Enable';
- In the Alexa app (PC version), select 'Smart Home' then 'Devices'
- Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';

Please retest and let me know the result.
View original

35 replies

Userlevel 7
Badge +20
Hi

First step is to disable and then enable the Sonos skill within the Alexa app. Are you seeing the Sonos 1 within the list of devices under Smart Home in the Alexa app?

If the problem still exists, then using the Sonos app on either iOS or Android (Not PC), select the Sonos 1 within settings and disable Voice servces and then re-enable.
Userlevel 2
Badge
Thanks for the response, I’ve accidentally got 2 of the same thread going. Tried the suggested steps and Sonos One is visible in Alexa app and recognising commands
Userlevel 7
Badge +20
Great news ?
Userlevel 2
Badge
Sorry somehow, my message hadn't finished.
- One is visible in Alexa app
- Recognises commands in History
- But doesn't respond and react to them all

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-commands-6793240

This is the other thread with more info
Userlevel 7
Badge +20
Hi Gazzstevens

Can you please try these actions:

- In the Alexa app, select 'Skills' and disable the Sonos Skill;
- In the Alexa app (PC version), select 'Smart Home' then 'Devices';
- Select 'Forget All' at the bottom of the screen;
- In the Sonos app, select 'Settings' and for each of the Sonos 1's remove 'Voice Recognition';
- If you have a Connect, please power down and then switch on and wait for it to boot;
- Power down the two Sonos 1's and then switch them back on and wait for them to boot;
- In the Sonos app, Select 'Manage' and then select 'Add a player or sub' and add the two Sonos 1's again. This will complete the set-up process again;
- In the Alexa app, select 'Skills' and ensure the Sonos skill is enabled, if not please 'Enable';
- In the Alexa app (PC version), select 'Smart Home' then 'Devices'
- Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';

Please retest and let me know the result.
Userlevel 2
Badge
Working a ton better thanks, responded and reacted to all commands successfully. Still thinks it's in Seattle instead of UK, in settings it has retained the location I added manually, but still giving time and weather for Seattle.
Userlevel 7
Badge +20
Are you checking the location within Alexa App>Settings>Sonos 1>Device Location and Device Time Zone?
Userlevel 2
Badge
It allows me to change timezone but not address, it says "unable to save changes".
Userlevel 2
Badge
However my dot has all the right address info. Tried copying exactly what is in the Dot location, but still not working.
Userlevel 2
Badge
If it's any further help, it's setting itself to Seattle, like what has been reported by other users.
Userlevel 7
Badge +20
You may need to factory reset it it re add.
Userlevel 7
Badge +25
Have you tried going into the Amazon website to change the country location instead? alexa.amazon.co.uk would be the site for the UK.
Userlevel 2
Badge
So, the strangest thing. I have been using alexa website all the time. However this time when I went there and I selected country it put the postcode box underneath the country, instead of at the bottom, however the main thing, it saved the changes this time, so time and weather are both working. Who knows....

Thanks for the support
Userlevel 2
Badge
Additional thing to note. When I was having the issues earlier of not being able to save changes, Alexa was also not playing songs when requested, now it seems to be working...
I have attempted the above, however I seem to be getting a very odd result. My Sonos ONE is playing on 'TheKitchen' through Alexa...however weirdly although this name is listed correctly in the Alexa app...there is also 'KitchenOne' which is listed as ONLINE. 'TheKitchen' is not Online. See attached screenshot of both Apps side be side. Any ideas.

(I only have one Sonos One, and one Play:1 called 'Portable')
Each Sonos one will have two Smart device names. One is the Sonos name, which will show up on the Sonos app and handles the Sonos functions, the other is the Alexa name, which handles the Alexa functions.
Thanks jgatie. I assume I need to keep these names distinctly different as mine currently are. In the main it seems to work. Amazon music requests all seem to work fine...im just struggling with Radio. The verbal requests are 'heard' and show in Alexa app...but often its just silence. Think there must be a bug in the system somewhere...
If your device is having trouble playing iTunes stations, I would submit a diagnostic after the problem happens and post the reference number here. This will allow the Sonos techs to diagnose what is happening.
Badge
Thank you so much, UKMedia. These steps worked perfectly for me!
SOMEONE PLEASE PROVIDE INSTRUCTIONS FOR TROUBLESHOOTING ON APPLE DEVICES.
Userlevel 7
Badge +20
SOMEONE PLEASE PROVIDE INSTRUCTIONS FOR TROUBLESHOOTING ON APPLE DEVICES.

You need to raise this on the Amazon Alexa forum, as it was Amazon that removed the 'Forget All' command from the iOS app.
One wonders if Amazon isn't fully enthusiastic about supporting their app on Sonos, as it cannibalizes their Echo sales.
Userlevel 7
Badge +20
One wonders if Amazon isn't fully enthusiastic about supporting their app on Sonos, as it cannibalizes their Echo sales.
I don't think you should view it as a Sonos slight, I suspect it is because Amazon have just released Routines in the Alexa App which whilst it is a great way to reset your Smart Devices, 'Remove All' deletes all actions defined in all Routines.
Thanks UK Media! your solution worked.

Happy Holidays
Thanks for the details above. I tried the steps detailed and it worked...for one time ?
After asking Alexa to pause all. When I came back later that day, the mic light was no longer lit and Alexa was not responding again...any further suggestions? TIA

Reply