Answered

Sonos One not playing Alexa output


Show first post

67 replies

Got it. I didn’t realize that Amazon was limiting these feature uses. Makes it tough for Sonos and consumers.
Userlevel 7
Badge +25
Hi guys, I just wanted to share that Flash Briefing will be available on the Sonos One by November 22nd.
Userlevel 3
Badge +4
Can it be confirmed that the Sonos ONE is NEVER going to be able to be used for Drop In and phone calls, or are those features maybe coming "soon"?
zadi wrote:

I got a solution that worked for me from another forum:

Login to the Alexa portal on a computer (not a mobile device);

alexa.amazon.com
alexa.amazon.co.uk

Pick the one that's correct for your region.

With the 'Smart Home' section, select devices. In this section find any Sonos products and hit the forget button. Then move back to the Smart Home section and select smart home skills which is located at the bottom. Next to Sonos select Disable.

Once this is done, open the Sonos app;

More > Settings > Room Settings > Select the room which contains the ONE > Voice Services (might ask you to login) > Amazon Alexa > A pop up will appear > Remove Amazon Alexa from this room > Once removed select the MORE tab > Voice Services > Follow the install steps again.

Once that's done, move back to the Alexa website portal and select SKILLS. Search for SONOS, enable the skill. Once done search for devices. Check within the Smart Home section under devices that all your Sonos products are showing. Then give the speaker a go.




This worked good people for when Alexa stops playing music (Music library is not yet supported)
zadi wrote:

I got a solution that worked for me from another forum.... ....Then give the speaker a go.



This worked... but only for long enough to accept one instruction!!
It looks like the integration is not quite ready for primetime yet. Hopefully Sonos and Amazon will get this sorted out soon.
zadi wrote:

I got a solution that worked for me from another forum:

Login to the Alexa portal on a computer (not a mobile device);

alexa.amazon.com
alexa.amazon.co.uk

Pick the one that's correct for your region.

With the 'Smart Home' section, select devices. In this section find any Sonos products and hit the forget button. Then move back to the Smart Home section and select smart home skills which is located at the bottom. Next to Sonos select Disable.

Once this is done, open the Sonos app;

More > Settings > Room Settings > Select the room which contains the ONE > Voice Services (might ask you to login) > Amazon Alexa > A pop up will appear > Remove Amazon Alexa from this room > Once removed select the MORE tab > Voice Services > Follow the install steps again.

Once that's done, move back to the Alexa website portal and select SKILLS. Search for SONOS, enable the skill. Once done search for devices. Check within the Smart Home section under devices that all your Sonos products are showing. Then give the speaker a go.



Lots of people are misunderstanding the original point made with things that Alexa currently doesn't provide. I can tell you from having the same experience as the original problem that ^ THIS ABOVE is the solution. It seemed that the Alexa app/account and my Sonos One lost their pairing but were still talking to each other. I asked to play BBC Radio 5 live and Alexa thought it was doing so but no sound came out of the Sonos One. After logging in as suggested above and removing both Alexa and Sonos from each other, reinstalling skills, voice control etc. worked. This problem has nothing to do with flash briefings not being available etc. The misunderstandings/tangents just distract from the solution. Well done this user for cutting through that and providing the actual answer.
Badge
I ran into this same problem as the OP. Alexa.would wake, recognize the command to play music played mayn’t times before, and give the “Now playing XYZ Station from Pandora on Family Room”. This was followed by silence as it sounds like others have experienced I too was able to get it going by disconnecting and reconnecting services.

For me though, it seems to only happen if I start play music or whatever from a device and then use Alexa commands later. In fact, most of the normal Alexa music commands (stop, pause, play this or that) don’t work st all when I’ve started music on a Sonos device, but works great as long as I only use voice commands.

Not sure if that helps anyone, but I find it curious.
Why aren't any of the sleep sounds working ?!?! Makes no sense when they are the most popular skills. Is this going to be fixed?!?! I really wanted this feature the most.
It's DECEMBER 12!!! I bought 4 of the Sonos ONES and like others are complaining, why in the heck will the SLEEP SOUNDS NOT WORK? Seriously??? I value those skills the most and will just return the three SONOS Ones that were purchased for bedrooms if the Sleep sounds won't be enabled. Like others have posted, why even release a product that's being advertised to work with Alexa when the software is still in BETA and extremely buggy?

I certainly hope that the launch of Google Home service on Sono's ONE goes much smoother next year. Please DO NOT release it until it's ready.... You're ONLY pissing off customers.... I want the sleep sounds, when will they work???
I bought this speaker precisely because of its Alexa integration to play sleep sounds. Crazy that it was sold when not ready to perform. I’m going to see if I can return it today.
You certainly can return it if it’s within the return period... HEY SONOS I returned my FOUR speakers yesterday due to the lack of enabled Alexa functionality.... Shame on this company for releasing a product in the holidays when it’s still in beta testing and works poorly......
This fixed my same problem. Thanks for sharing.

zadi wrote:

I got a solution that worked for me from another forum:

Login to the Alexa portal on a computer (not a mobile device);

alexa.amazon.com
alexa.amazon.co.uk

Pick the one that's correct for your region.

With the 'Smart Home' section, select devices. In this section find any Sonos products and hit the forget button. Then move back to the Smart Home section and select smart home skills which is located at the bottom. Next to Sonos select Disable.

Once this is done, open the Sonos app;

More > Settings > Room Settings > Select the room which contains the ONE > Voice Services (might ask you to login) > Amazon Alexa > A pop up will appear > Remove Amazon Alexa from this room > Once removed select the MORE tab > Voice Services > Follow the install steps again.

Once that's done, move back to the Alexa website portal and select SKILLS. Search for SONOS, enable the skill. Once done search for devices. Check within the Smart Home section under devices that all your Sonos products are showing. Then give the speaker a go.

Guys,,, just bought Sonos One and set up,, it worked fine asking Alexa ‘play my music in bedroom’ worked fine but now when I command she says ‘playing your music in bedroom’ but doesn’t actually play anything and can’t hear music,,,
I sent email to Sonos but got really poor reply asking for a dyanostics which have no idea how to do,,
Really disappointed in this speaker now,,,any suggestions before I bin it ??
Kind regards
zadi wrote:

I have the same problem. I ask alexa to play Thriller and it says "Playing Thriller in the Bedroom" and then nothing happens.

Same here, I’m about to give up and bin the speaker or give it away , Alexa won’t play my music and says she is,,,
Rip off if ask me
Userlevel 6
Badge +20
Hi

Can you first disable the Sonos Skill in the Alexa App>Skills>Your Skills>Sonos and then Enable.

If the problem persists then please follow the steps I've listed in the Answer to this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
Does the below work for just music playing problems or also the problems with skills playing like the white noise skills?

pianomanplays wrote:

zadi wrote:

I got a solution that worked for me from another forum:

Login to the Alexa portal on a computer (not a mobile device);

alexa.amazon.com
alexa.amazon.co.uk

Pick the one that's correct for your region.

With the 'Smart Home' section, select devices. In this section find any Sonos products and hit the forget button. Then move back to the Smart Home section and select smart home skills which is located at the bottom. Next to Sonos select Disable.

Once this is done, open the Sonos app;

More > Settings > Room Settings > Select the room which contains the ONE > Voice Services (might ask you to login) > Amazon Alexa > A pop up will appear > Remove Amazon Alexa from this room > Once removed select the MORE tab > Voice Services > Follow the install steps again.

Once that's done, move back to the Alexa website portal and select SKILLS. Search for SONOS, enable the skill. Once done search for devices. Check within the Smart Home section under devices that all your Sonos products are showing. Then give the speaker a go.




This worked good people for when Alexa stops playing music (Music library is not yet supported)

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings