Answered

Sonos One, Echo Dot & Group Ducking


Hello. I’ve been having an issue with my Sonos One and Alexa setup which I think is an error but have discussed with Sonos Support and they say it’s not, but this looks to me to contradict the website. Looking for some more opinions/experiences!

I have an Echo Dot and a Sonos One in my living room. I have added both devices to one Alexa group. I have the Sonos microphone turned off and use the Echo Dot for speech input as I prefer the visual response of the light ring. The Sonos One is the preferred speaker for the group and that aspect of the setup works well. All Alexa devices in my household are in Alexa groups.

The problem I have is that when I’m playing music on the Sonos (via Alexa or via AirPlay), when I speak to the Echo Dot, the music for the group doesn’t duck.

I believe this to be an error for two reasons:
  1. The widely reported whole home ducking issue has been resolved by Sonos and is meant to be fixed by putting your Alexa devices in groups so that only that group ducks. If this is the case, surely my Sonos should duck?
  2. Ryan S (who I believe is from Sonos quoted the below on here):
Volume lowering done smarter using Alexa Groups
We've been listening, and are happy to say that with Alexa Groups, saying "Alexa" to any device with a microphone will only lower the volume of speakers in the same Alexa Group. Every Echo device you have will need to be in an Alexa Group to take advantage of this fully. Echo devices not part of any Alexa Group will still make all Sonos players drop in volume.

This reads to me that the Sonos should deck when I speak to my Echo Dot in the same group.

I had conflicting answers from Sonos originally. To begin with, they said it should duck and I needed to remove the Alexa service from the Sonos and simply add it as a connected speaker. I tried this and it didn’t work. Subsequently they said the Sonos is not designed to duck when speaking to an Echo device within the same group and have reiterated this several times.

So my question is, has anyone had success in getting their Sonos to duck when speaking to their Echo device in the same group?

Appreciate the help!
icon

Best answer by Ryan S 8 October 2019, 01:50

Thanks for checking that.

According to how it should be working, if the Dot is set up in the Alexa app as the input in the group, and the Sonos One is configured in the same group as the preferred speaker, with Alexa disabled on the One in the Sonos app, it should duck in volume when you use the voice command.

It may be worth it to reset Alexa control entirely to make sure it's all configured right. You can remove the Sonos skill, and forget the Sonos One from the Alexa app. Then just make sure not to enable Alexa control on the One in the Sonos app.
View original

13 replies

Userlevel 7
Badge +26
Hi @Luc717, you're correct, I am with Sonos :)

Can you check if in the Sonos app under Settings > Services > Voice that you have Alexa removed from your Sonos One?

Currently, if a Sonos speaker has the built in Alexa enabled as an assistant, even if the microphone is turned off, it won't duck in volume unless it hears you say "Alexa". Removing the service from the room but having the skill enabled will still allow you to control the system with Alexa, you just will need to use a different microphone enabled device.
Hi Ryan, thanks for getting back to me.

Yep just checked and I definitely don’t have Alexa under voice services. I did previously (hence the comment about muting the Sonos) but subsequently removed Alexa. The Sonos is therefore just a connected speaker in my Alexa group and I am able to control it from the Echo as a preferred speaker, but it doesn’t duck

Grateful for any ideas!
Userlevel 7
Badge +26
Thanks for checking that.

According to how it should be working, if the Dot is set up in the Alexa app as the input in the group, and the Sonos One is configured in the same group as the preferred speaker, with Alexa disabled on the One in the Sonos app, it should duck in volume when you use the voice command.

It may be worth it to reset Alexa control entirely to make sure it's all configured right. You can remove the Sonos skill, and forget the Sonos One from the Alexa app. Then just make sure not to enable Alexa control on the One in the Sonos app.
Good news that I’m not going crazy! I was sure it’s meant to duck. Unfortunately still having the issue (accidentally marked your reply as the answer, sorry)

The original advice from Sonos Support (by email) was as your advice above, to ensure Alexa was removed from the Sonos. I tried that at the time to no avail.

I did notice this evening that when I reviewed my Alexa devices in the Alexa app (in the Echo & Alexa section at the top left of the Devices tab), the Sonos was still listed there as an undiscoverable Alexa-enabled device. I selected de-register to ensure my Alexa account was fully removed (I removed it from the Sonos app months ago) which I hoped would correct the issue but sadly not. My guess however is that there’s some kind of hangover in the Alexa system that treats my Sonos as an Alexa-enabled device when it no longer is, even if it’s not displayed that way.

I have also had another go at removing the skill etc as you suggested and unfortunately no luck. I have also tried factory resetting my Sonos, removing all traces of it from the Alexa app, setting up fresh in the Sonos app and adding it as a smart speaker (ie adding the Alexa skill in the app and discovering the device but not adding Alexa as a voice service). Lastly I’ve tried removing the Sonos from Alexa, renaming it within Sonos and re-adding it. Still no luck!

I have created diagnostics several times when speaking to Alexa and the system not ducking:
  • after removing the skill and re-adding as a smart speaker: 92415783
  • after factory resetting the Sonos and adding it to Alexa as a fresh device: 1974502977
Would be grateful if you could review and see if you can spot what could be causing the issue.

Thanks!
Userlevel 7
Badge +26
Thanks for taking those steps! Nothing stands out on the diagnostic as to why it's not ducking as it should. I'll pass the details on over to the team to investigate in case there's something they spot on the back end causing this issue.

A suggestion, you could enable Alexa on the One, and turn off the chime sound. It would duck, and depending on which of the two devices hears you better, that will be the one that responds. If you've tried this before, feel free to ignore the suggestion though :)

Another thing you could try out, it's possible if you have Google Assistant enabled on that One it should duck from the Dot since Alexa still has the room listed.
Badge

Having the same problem, and the solution suggested to the OP did NOT work for me either. 

 

Have an Echo Dot in Kitchen. Added two Sonos One’s WITHOUT Alexa enabled (I like the blue ring confirmation, and I use the Echo Clock regularly). Created a group with the Dot as the input, the speakers as preferred speakers. When I ask to play music it comes through both speakers perfectly, but when I again speak to Alexa while the music is playing, the speakers DO NOT duck, which makes hearing Alexa difficult. 

 

Full disclosure: I had them added previously with the voice assistant enabled. I disabled the Sonos Skill, deleted the devices from the Alexa app, signed out of the Alexa app. I then signed back in, enabled the app and rediscovered the One’s as just speakers this time.

 

Any help or insight would be appreciated. 

Userlevel 7
Badge +20

Hi

 

You need to add the speakers that you want to ‘duck’ to the Alexa Group.  The Preferred Speaker section is to identify which speakers you want to group for the Audio to be output to.

Badge

UKMedia, that’s the way I have it set up, but still no ducking unfortunately. 
 

 

jhcovert,

When speaking your commands to ‘parlour’ only the kitchen and Sitting Room should be ducking their audio, but what is 'parlour' and 'parlour Connect’? Are there any other Alexa enabled devices nearby besides ‘parlour’ that maybe picking up your voice?

Badge

Ken_Griffiths, Parlor is an Echo Dot 3rd Gen, and Parlor Connect is a Sonos Connect. It only shows because it is a potential Preferred Speaker. 

 

There is no other enabled Alexa device within hearing distance. When I speak, the Echo Dot hears me and issues its answers, but I am unable to hear them because neither speaker (Kitchen or Sitting Area) duck when I speak to the Parlor Dot that is in the same group. 

Userlevel 7
Badge +20

I suggest that you Disable then Re-Enable the Sonos Skill in the Alexa App and retest.

Badge

Disabling and re-enabling Sonos skill had no effect on ducking. 
 

Removed speakers from Alexa, added them back through discovery, and no effect on ducking. 
 

Removed speakers from the group, played music through Dot, then re-added them and played music to them - no change in ducking behavior. 
 

This is maddening: I’m so close to having the system behave in the way I want it to! 

Disabling and re-enabling Sonos skill had no effect on ducking. 
 

Removed speakers from Alexa, added them back through discovery, and no effect on ducking. 
 

Removed speakers from the group, played music through Dot, then re-added them and played music to them - no change in ducking behavior. 
 

This is maddening: I’m so close to having the system behave in the way I want it to! 

Perhaps try this...

When removing the Sonos skill from the Amazon App, also remove all your Sonos devices… then login to your Amazon Account online via a web browser and goto “manage content and devices” and ensure the Sonos devices are gone from the devices tab, or remove any remaining Sonos devices manually. 

Then goto your Amazon online account settings and scroll down to the section called ‘other accounts/login to Amazon’. Select that to view your sharing agreements and remove the Sonos/Amazon sharing agreement.

Next, setup your devices again from scratch by adding in the Sonos Skill back in the Amazon App. You will also need to add your devices to the “Downstairs” group again.

 

 

Reply