Answered

Sonos One - Alexa not responding to commands

  • 2 September 2018
  • 22 replies
  • 15986 views

Badge
I have one of my Sonos One speakers not working properly with Alexa commands. It responds ok when I say “Alexa” but does not respond to all commands. It used to work fine, but now it doesn’t. Example - I will ask Alexa to play top hits on pandora and it will fine, but when I say “Alexa STOP or PAUSE” Alexa beeps continues to play. I can only stop or pause if I go into the sonos apps on my IOS device.

I have tried to disable and delete devise and reset and reinstall, but same thing happens. Any advice? I have other Sonos One speakers that are working fine, just having issue with this one.
icon

Best answer by Keith N 11 September 2018, 01:19

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Userlevel 7
Badge +19
Hi there, Duffy135. Thanks for posting and welcome to the Community. Would you mind replicating the problem and shortly after, submitting a diagnostic report? Be sure to reply here with the confirmation number it gives at the end. Thanks again!
Badge
Keith N - Not to sound stupid, but from where do I pull a diagnostic report?
Userlevel 7
Badge +19
No worries, the Community platform doesn't change the color of links :P

https://support.sonos.com/s/article/141
Badge
Your confirmation number is: 210420748
Userlevel 7
Badge +19
Thanks! It seems there are a couple problems regarding connectivity and your Sonos system. Specifically, the Bedroom Sonos One is losing connection to the network and unable to maintain a steady connection. Is this the problematic Sonos One? I can see a command to play but no other commands after.

Have you tried plugging one of your Sonos devices into the main router using an Ethernet cable? This will change how data is passed along to Sonos and should give a more robust and flexible network for Sonos to work on.

If you are still running into trouble after, it might be best to give our support technicians a call to have a closer look at this in real time.
Badge
The Bedroom Sonos One is actually functioning properly. And I have tried to connect direct to router/switch, but the Dining Room is the one that I am having issues with.
Userlevel 7
Badge +20
Problems with a single device can often be caused by duplicate IP addresses. Can you please power down these devices for 5 secs, allowing each to complete the boot sequence before moving to the next device:

- Router
- Any wired network switch
- Any wired Sonos product
- Any other Sonos product
- All other connected network devices - A pain I know!

If this fixes the issue, I suggest that you reserve IP addresses in your Router set-up for your Sonos devices. (I use the range 192.168.0.200 and above for Sonos devices).
Was there ever a solution to this? I have my sonos one for just one week now. It was working perfectly up to yesterday. Now it Stop never works but Pause does. It will always say it will play something asked but only sometimes plays, other times it will continue to play what was originally playing instead of the new item it said it would play. It's not intermediate - if there's an error playing a particular album, there will always be a problem playing that album (even though it played in the past and plays fine when using the sonos or Spotify apps)

Thanks
Userlevel 7
Badge +20
As a first step, please diable then enable the Sonos skill in the Alexa App.
Bingo! Thanks!
Unfortunately it worked for a few minutes and back to the same again. If I say “play Antonio Vivaldi” Alexa replies “shuffling songs from Antonio Vivaldi from Spotify”, and then plays music from Four Seasons (which is correct). Then, If I say “play roger waters”, it says “shuffling songs from Roger Waters on Spotify” and continuous to play four seasons. “Alexa Stop” is now working (prior to disable/enable Spotify skill, it was not). 100% repeatable.
Userlevel 7
Badge +20
Unfortunately it worked for a few minutes and back to the same again. If I say “play Antonio Vivaldi” Alexa replies “shuffling songs from Antonio Vivaldi from Spotify”, and then plays music from Four Seasons (which is correct). Then, If I say “play roger waters”, it says “shuffling songs from Roger Waters on Spotify” and continuous to play four seasons. “Alexa Stop” is now working (prior to disable/enable Spotify skill, it was not). 100% repeatable.

This type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Thanks for your detailed response UKMedia. I think Duplicate device names might have been the problem - I renamed all as some were the same (For example, Kitchen speaker and light had the same name) and I dis/en abled the Spotify skill again and all seems to be working now 24 hours later 🙂 Thanks again!
I’m having the same problem with my Sonos ones. They respond to the name Alexa but not to the selected commands. Diagnostic confirmation number 400298378.
Userlevel 7
Badge +20
I’m having the same problem with my Sonos ones. They respond to the name Alexa but not to the selected commands. Diagnostic confirmation number 400298378.

Did you follow the steps in my post above?