Answered

Sonos One - Alexa not responding

  • 28 November 2017
  • 16 replies
  • 1492 views

The Sonos One is my first Sonos and the experience so far has been frustrating. Finally got Alexa working then one day it stopped responding. I have amazon alexa products that work fine. I noticed that on Alexa App that I had Sonos One listed and 'Foyer'. I deleted 'Sonos One' as I was having streaming issues and I thought there was a conflict. Now it not working at all. I can still operate the sonos with the sonos android app.
icon

Best answer by UKMedia 14 January 2019, 08:51

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
View original

16 replies

Update. Spent hours on this. Uninstalled apps reinstalled apps. No change. Sonos works perfectly if I control sonos via a separate amazon dot but not if I talk to the sonos directly.
I can’t get Alexa to control music on my new Sonos One either
Update. Spent hours on this. Uninstalled apps reinstalled apps. No change. Sonos works perfectly if I control sonos via a separate amazon dot but not if I talk to the sonos directly.

Is the Sonos One 'mic' switched on (small circular mic light on device - not the larger status light) and have you linked 'Alexa' to your Sonos One Room in the Sonos App Settings via 'Voice Services'?

Have you checked the Amazon Alexa App smart-home section to ensure the Sonos Skill is installed and the Sonos One Room is listed on the devices tab.. make sure the speaker is online. If not and it’s shown offline, perhaps remove it and redetect the smart-home devices.
I tried everything . Got the skills loaded , factory reset Sonos , uninstalled and reinstalled both apps . Sonos recognizes me talking and can do things like say the time and give me silly facts but it can not control amazon music . I can only control the amazon music via the Sonos app not with voice
DominicN

So you have reinstalled both the Sonos App and your Alexa app on your mobile controller device.
Presumably you have then also installed the 'Sonos Skill' in the Alexa App and after enabling it you linked your Sonos Account to your Amazon Account and accepted the sharing agreement.. and then at the end of the process have immediately 'scanned for devices'?

Is that correct?... and did all your Sonos 'Rooms' appear in the devices tab of the smart-home section within the Alexa App? Check all your rooms are present in the main tab.

Then have you gone through the 'voice services' option in the Sonos App Settings, where it prompts you to log into your Sonos Account and places Amazon Alexa at the top of your Sonos One Room in the Rooms Settings of the Sonos App. In the course of going through this procedure it will take you back into the Alexa App Settings where you can choose your default Music Service, Amazon Music in your particular case.

These are some of the things you may need to check... also check that your online Sonos Account and your online Amazon Account are each set to the correct country and that the country is one where the voice services are available, like U.S. or U.K. etc.

If you have done/checked all these things, then it should all then be working.
I just tried what you said and I Still can’t pause play and skip songs with Alexa but she will tell me the weather
I don’t know then DominicN, you may have to give Sonos Support a call and speak to them.
Userlevel 7
Badge +20
I tried everything . Got the skills loaded , factory reset Sonos , uninstalled and reinstalled both apps . Sonos recognizes me talking and can do things like say the time and give me silly facts but it can not control amazon music . I can only control the amazon music via the Sonos app not with voice

Hi

Have you added the same music services in both the Sonos and Alexa apps? Can you check the steps I've listed within the Answer to this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-she-is-playing-on-kitchen-but-no-sound-comes-out-6800126
Badge
DominicN

So you have reinstalled both the Sonos App and your Alexa app on your mobile controller device.
Presumably you have then also installed the 'Sonos Skill' in the Alexa App and after enabling it you linked your Sonos Account to your Amazon Account and accepted the sharing agreement.. and then at the end of the process have immediately 'scanned for devices'?

Is that correct?... and did all your Sonos 'Rooms' appear in the devices tab of the smart-home section within the Alexa App? Check all your rooms are present in the main tab.

Then have you gone through the 'voice services' option in the Sonos App Settings, where it prompts you to log into your Sonos Account and places Amazon Alexa at the top of your Sonos One Room in the Rooms Settings of the Sonos App. In the course of going through this procedure it will take you back into the Alexa App Settings where you can choose your default Music Service, Amazon Music in your particular case.

These are some of the things you may need to check... also check that your online Sonos Account and your online Amazon Account are each set to the correct country and that the country is one where the voice services are available, like U.S. or U.K. etc.

If you have done/checked all these things, then it should all then be working.
Badge
Ken_Griffiths I did all that up until the devices tab, when I got to that part of the setup the Sonos one did not appear at any point. Tried disabling/re-enabling Sonos Skill. Disconnecting/re-connecting Sonos app and Amazon. Any suggestions?
I have s Beam and also Alexa stopped working. I'm having trouble understanding right now. :@:@
Userlevel 7
Badge +20
I have s Beam and also Alexa stopped working. I'm having trouble understanding right now. :@:@

This message is normally associated with a loss of internet connection. Have you recently updated the App or booted your Router? This may be down to duplicate IP Addresses. Can you please power down the following devices for 5 secs, allowing each to complete its boot cycle before proceeding to the next device:

- Router
- Any Network wired switch
- Any wired Sonos devices
- All other Sonos devices
- All other attached network devices

If this fixes the problem, I suggest you open the Settings page on your Router and reserve IP addresses for your Sonos devices - I personally use the range 192.168.0.240 and above for my Sonos devices.
Did the power down of everything, removed the App, removed the skills, restart everything and no change. Just about to give up and send back teh Beam
my Sonos speakers stopped responding on Saturday... I tried to disable the Skill and it again...Now I get an error trying to add the skill....anypne else seeing this problem? I am in Canada and have a Sonos one and a Connect. Was working well and hoping for access to my iTunes in Canada......now I just want it to work.
Userlevel 7
Badge +20
Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Thank you....either the software or hardware but was fixed overnight or changing the name of my Sonos made the difference....it looked like I had 2 devices or rooms named family room.....excellent advice.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings