Answered

Sonos not playing Alexa music

  • 18 November 2017
  • 44 replies
  • 18941 views

I've had the Sonos One for a couple of weeks and it was working fine up until yesterday. The music plays fine through sonos app but is not playing correctly through the speaker upon command. For example, if I ask Alexa "to play Lithium on SiriusXM" she responds "Lithium from SiriusXM playing on Office" but then nothing happens. Any suggestions?
icon

Best answer by Edward R 27 June 2019, 17:30

We have noticed this thread gaining a lot of traction of late, with most visitors to this thread opting not to actively engage in troubleshooting. The information in this post will be marked as the best answer to assist those reading along.

We have an article that talks about how to resolve the majority of issues with Alexa on Sonos. If you are experiencing the problems details in this thread, please have a look there.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

44 replies

Okay, can you check that the device is not shown as off-line in the Alexa app Smart Home>Devices? If this doesn't work I suggest that your reset voice control by following the actions I've listed in the answer within this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239


The device is online in the Alexa app, and as I've said, Alexa works for everything else other than initiating the play of music, and pausing or stopping music. This is an issue with their latest update that Sonos needs to resolve. I appreciate your input though!
I basically removed the Sonos skill from Alexa and removed Alexa from my Sonos Play1 and reinstalled everything. It worked...tho I’m frustrated I had to do that. Was the fix tho.
I basically removed the Sonos skill from Alexa and removed Alexa from my Sonos Play1 and reinstalled everything. It worked...tho I’m frustrated I had to do that. Was the fix tho.

This worked! Thank you! I am disappointed in Sonos' customer service though. They say they respond within 30 minutes if you tweet them 24/7 and Facebook says "typically responds instantly." Did both this morning and got no response.
I'm having the same problem as of this morning. It was working fine last night, but as of this morning all the streaming audio has stopped working. That includes Pandora, Amazon Music, and Tuned In. Alexa responses seem normal. I can even get a joke. When I started a streaming music, for example by saying Alexa Play Music, I get the normal response, no music audio, and when I ask what song is playing I'm told "No music is playing".

UPDATE: Disabling the Sonos skill using the Alexa app then re-enabling it cleared the problem. I wish the company had been a little more proactive in helping us out.
Userlevel 7
Badge +20
Okay, can you check that the device is not shown as off-line in the Alexa app Smart Home>Devices? If this doesn't work I suggest that your reset voice control by following the actions I've listed in the answer within this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239


The device is online in the Alexa app, and as I've said, Alexa works for everything else other than initiating the play of music, and pausing or stopping music. This is an issue with their latest update that Sonos needs to resolve. I appreciate your input though!


I would still recommend that you follow those actions as it resets the setup for Voice.
Userlevel 7
Badge +26
It looks like most of you were able to get this resolved already. If you find that, after a reboot or update, that your Alexa skill loses track of players. We've found that the best way to bring it back if that happens is to disable the skill and re-enable it, those steps UKMedia suggests are a great way to go to clean things up.

If you're still having trouble, I'd suggest that you give us a call on our support line.
I uninstalled both Alexa and Sonos apps from my android, re-installed them and still have the same issue. This sucks. Is there going to be a proper fix for this? If not i'm returning it.
Userlevel 7
Badge +20
I uninstalled both Alexa and Sonos apps from my android, re-installed them and still have the same issue. This sucks. Is there going to be a proper fix for this? If not i'm returning it.

It's not normally an app issue. The most common is an Amazon account conflict or the Voice control needs re-setting as I've described above. If these don't solve your issue, then as @Ryan suggests, best to call technical support.
So another data point. unistalling the apps on my android device didn't work. but I also have an iphone and when i uninstalled an reinstalled both sonos and alexa apps now it's working again. go figure!
I had similar issues - couldn't play music, said it was playing music when it wasn't, couldn't pause music when it was playing etc. I removed the Sonos skill from the Alexa App and then added it back - it will then look to reconnect to devices and you will need to pair etc as it connects back with Sonos. In my case, I have not had the need to uninstall the alexa or sonos apps. Please note, Alexa does not like when you change the name of the Sonos device or the Alexa device after you have added the skill. It causes it to pause again. Make any device name change within the Sonos settings first, then resync the names through the skills addition process. I was editing the name within Alexa,and I was getting the same issues as I had previously. I again removed the skill and followed the prompts to add the sonos skill via Alexa App. Within Sonos - I do display one device name for my sonos one, but within Alexa, it appears twice - as sonos name and as the name when it set up within Alexa originally. I am leaving it alone for now... I would put these issues down to relatively software versioning.
Userlevel 7
Badge +20
I had similar issues - couldn't play music, said it was playing music when it wasn't, couldn't pause music when it was playing etc. I removed the Sonos skill from the Alexa App and then added it back - it will then look to reconnect to devices and you will need to pair etc as it connects back with Sonos. In my case, I have not had the need to uninstall the alexa or sonos apps. Please note, Alexa does not like when you change the name of the Sonos device or the Alexa device after you have added the skill. It causes it to pause again. Make any device name change within the Sonos settings first, then resync the names through the skills addition process. I was editing the name within Alexa,and I was getting the same issues as I had previously. I again removed the skill and followed the prompts to add the sonos skill via Alexa App. Within Sonos - I do display one device name for my sonos one, but within Alexa, it appears twice - as sonos name and as the name when it set up within Alexa originally. I am leaving it alone for now... I would put these issues down to relatively software versioning.

If you change the name of a Sonos item, selecting 'Discover' within the Alexa app>Smart Home>Devices should be enough without removing the skill.
Hi everyone, I did another update just last night, and this has fixed the issue. She even has access to my iTunes now, so even better.
I had exact same problem, clearly hearts and responds to my commands, just does not actually play the music she claims she will. Uninstalling and reinstalling Alexa app didn't help either. HOWEVER simply disabling and reenabling the Sonos skill in Alexa app FIXED!!
After the recent Sonos update I had this same problem with Alexa but in addition had a problem where my Sonos One speakers were not all showing up in the app. The process detailed up above by UKMedia worked to fix the Alexa problem. However, to fix the other problem with sonos one speakers not being found by the app I realized my Asus router had delivered a firmware update on the same day as the sonos update. And they had since provided a fix (a new firmware update) that i had to manually download and update. after that - all is fixed for me.
I've had a similar problem. It seems the Sonos gets stuck on whatever it was playing last. If I tell Alexa to resume playing on x, then do the command I actually want, it works.
I had this problem after changing my wireless network. I took a guess thinking it was sending it to the old network, so i disconnected alexa skill and the reenabled it and it started working. Very frustrating but now working.
Userlevel 2
Badge +1
Well, well, well.
After today’s update Sonos will play Spotify through Sonos again.
I thought I was going mad, it used to work, then it didn’t. But Amazon music worked, a conspiracy?
Happy I don’t need to type anything anymore....until the next update????
Badge
I too have the problem. Sometimes it worked ok - maybe 2% of the time. Also, I found out if I hit the play button on the top it starts playing. I'm going to try disabling the skill and restarting it.
Userlevel 7
Badge +20
We have noticed this thread gaining a lot of traction of late, with most visitors to this thread opting not to actively engage in troubleshooting. The information in this post will be marked as the best answer to assist those reading along.

We have an article that talks about how to resolve the majority of issues with Alexa on Sonos. If you are experiencing the problems details in this thread, please have a look there.