Answered

Sonos Move Alexa Voice Control not working

  • 25 September 2019
  • 22 replies
  • 25069 views

My new Sonos Move arrived this morning. It's set up and playing music from the Sonos App however, Alexa Voice Control isn't working. Microphone on Sonos Move is on (light on), speaker has been discovered by the Alexa App, and I've disabled and re-enabled the Alexa Sonos Skill. Still not responding to voice control.
icon

Best answer by jgatie 25 September 2019, 21:28

If this is your first Alexa enabled Sonos speaker, you need to add the Alexa Voice Control service to the Sonos app. See this link for details:



https://support.sonos.com/s/article/3517?language=en_US
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Alexa is only available in WiFi mode, and not when the Move is in Bluetooth mode.
Thanks @Smilja. Alexa wasn't working when in Wi Fi mode however, it is now after another Sonos skill disable and re-enable.
Same exact problem as OP. White light on at top signaling it's connected via wifi and not a blue light (Bluetooth connection).
Mind you, Alexa DOES work for my other sonos speakers, just not the Move. So I disabled sonos skill in Alexa app and reconnected. Confirmed the Move is visible and connected to Alexa in the Alexa app.
Same exact problem as OP. White light on at top signaling it's connected via wifi and not a blue light (Bluetooth connection).

Is the light on the top indicating that the microphone is on lit? It's quite possible to accidentally turn off the mic when you pickup the Move by the handle. Your palm and thumb are right there. I've done it a few times myself.

Same exact problem as OP. White light on at top signaling it's connected via wifi and not a blue light (Bluetooth connection).
Is the light on the top indicating that the microphone is on lit? It's quite possible to accidentally turn off the mic when you pickup the Move by the handle. Your palm and thumb are right there. I've done it a few times myself.

The microphone white light is lit. So the mic should be ready and working.
Exactly the same issue here. Enabled and disabled multiple times. Other Alexa-enabled speakers are working just fine. Amazon App says all is exactly the same as the other devices, as does Sonos app. Removed device and added again several times. Voice Control still not working.
Within the Alexa app, do you see the Move listed as an Alexa device? If you do not, then I would go int the Sonos app, voice control settings and make sure the Move is specifically add as an Alexa enabled device. i don't have the exact steps in front of me, but I believe it's rather intuitive.

I don't think it's automatically assumed you want to use it with Alexa since Google is also now an option for the speaker.
Within the Alexa app, do you see the Move listed as an Alexa device? If you do not, then I would go int the Sonos app, voice control settings and make sure the Move is specifically add as an Alexa enabled device. i don't have the exact steps in front of me, but I believe it's rather intuitive.

I don't think it's automatically assumed you want to use it with Alexa since Google is also now an option for the speaker.

Within the Alexa app, it just tells you to add it as a Sonos speaker and then select 'Discover Devices', which is I guess what everyone here is doing? My other Sonos speakers are listed as Sonos devices and they work just fine?! 🤔
Same issue, disabled and re-enabled the skill several times. My Play One isn’t listed as an Alexa device, just a speaker, but it is set up as a group in the Alexa app, and it does show as both an Alexa device and speaker, but the move doesn’t. Are we just awaiting a software patch for it?
If this is your first Alexa enabled Sonos speaker, you need to add the Alexa Voice Control service to the Sonos app. See this link for details:

https://support.sonos.com/s/article/3517?language=en_US
@jgatie link is close to what I was referring to. After you have the voice service setup, you'll want to click on the Alexa service and you should see a list of all your Sonos speakers that have built in mics, but not all of them will be setup. For me personally, some are setup with GA, not Alexa. With the Move, I had to specifically say that I wanted to set it up with Alexa here to use the mics.
Userlevel 2
I had the same problem but solved it this way. Go to Settings in the Sonos app and click on Services. Under Voice click on Amazon Alexa. Under Sonos Product you should see Move. Click on it and then add to Alexa.
If this is your first Alexa enabled Sonos speaker, you need to add the Alexa Voice Control service to the Sonos app. See this link for details:

https://support.sonos.com/s/article/3517?language=en_US

This specifically corrected my issue. Voice services now working on Sonos Move. Thanx
Within the Alexa app, do you see the Move listed as an Alexa device? If you do not, then I would go int the Sonos app, voice control settings and make sure the Move is specifically add as an Alexa enabled device. i don't have the exact steps in front of me, but I believe it's rather intuitive.

I don't think it's automatically assumed you want to use it with Alexa since Google is also now an option for the speaker.

This
This worked perfectly. Under Settings, services, voice control, check Move and it walks you through it!
If this is your first Alexa enabled Sonos speaker, you need to add the Alexa Voice Control service to the Sonos app. See this link for details:

https://support.sonos.com/s/article/3517?language=en_US

Genius - this worked perfectly! Thanks for your help...

Cheers, Lee
Within the Alexa app, do you see the Move listed as an Alexa device? If you do not, then I would go int the Sonos app, voice control settings and make sure the Move is specifically add as an Alexa enabled device. i don't have the exact steps in front of me, but I believe it's rather intuitive.

I don't think it's automatically assumed you want to use it with Alexa since Google is also now an option for the speaker.

Thanks for the suggestion, this worked for me!

Ok I got the new Move for Christmas and ran into the same issue (all lights on etc but no voice assistance) but figured it out. I use Alexa and the Move showed up separately from my TV Group (Playbar, Sub and 2 Sonos Ones) in the Alexa app. The Move was automatically enabled and listed. So I went to the Sonos app --> Settings --> Services --> Voice Section --> Alexa --> and in the Sonos Product Section I saw the TV Group and NOT the Move. I saw an add product button and clicked it. My TV Group was checked but not the Move. Once Checked The Move now works with Alexa :) Hope this helps someone else too.

This worked perfectly. Under Settings, services, voice control, check Move and it walks you through it!

*****THIS IS HOW TO FIX IT if you already have all your other Sonos speakers working***** you start by going through this on your Sonos app.  Thanks Prime Steezl

I had the same problem but solved it this way. Go to Settings in the Sonos app and click on Services. Under Voice click on Amazon Alexa. Under Sonos Product you should see Move. Click on it and then add to Alexa.

 

 

Thank you PhilW1956!!  Worked like a charm.  This most likely is the resolution for most.

Userlevel 7
Badge +17

There must be something wrong with Sonos’ explication on how to install Alexa, when so many people miss this step in the proceedings…....

Userlevel 3
Badge +3

There must be something wrong with Sonos’ explication on how to install Alexa, when so many people miss this step in the proceedings…....

Agree.  I went a few months and didn’t realize that I didn’t have this enabled.