Answered

Pairing Port With Alexa

  • 23 March 2021
  • 8 replies
  • 47 views

I have a Sonos Port that I’m trying to control all of my speakers downstairs. I created a group called downstairs in the Alexa app and my Sonos Port shows up. However when I go to the Sonos App it doesn’t show up. When I tell Alexa to play music down stairs it says “Playing music on downstairs. Sorry I cannot play music on downstairs. Sorry something went wrong” and that’s it. I have already removed all products from Sonos and Alexa apps and also removed the Sonos skill from the Alexa app and then reconnected all of my devices and still nothing. In different rooms upstairs I have a few Sonos ones and they all work with the Alexa and show up in my Sonos App. Any thoughts on how I can get Alexa to control my port? Or could it be an issue with the port itself?

icon

Best answer by Ken_Griffiths 23 March 2021, 21:42

Yes I’m not seeing the port listed as a room in the Sonos app. I appreciate the suggestions the next time I am able to take a look at the port I will see if any of these help. Thank you!

It’s not showing in the Sonos App? ...In that case, perhaps use the ”Settings/Support/Find Missing Players” option to see if that gets the device to reappear and back up and running for you.

View original

8 replies

Hi. The issue with the Port is that it is does not have Alexa built in. 

You can still control it by voice via an Alexa enabled device to 

I’m trying to control it with an echo dot

You may need to perhaps set the echo dot in the first section of the ‘Downstairs’ group as the enabling device for the group.

The second section of the group is for audio ducking and the third section is for the speakers themselves that you wish to auto-group and play.

By setting things up in that way you don’t need to add the name of the group into the Alexa instruction. If you prefer to always add the ‘group name’ to control the downstairs group with your instruction, then simply remove the echo dot from the first ‘enabling’ section of the group.

If that still doesn’t work ensure your Sonos devices are not duplicated in the Amazon App device list and remove, reinstall the Sonos Skill and rescan for devices, check the group is still setup correctly and then try again to see if that resolves the issue.

I have attached a screenshot of an example of an Amazon Group, just to show the various sections, as mentioned.

I have a Sonos Port that I’m trying to control all of my speakers downstairs. I created a group called downstairs in the Alexa app and my Sonos Port shows up. However when I go to the Sonos App it doesn’t show up.

 

 

Are you saying that you don’t see your Sonos Port listed as a room in the Sonos app? Are you able to play audio to the Port using the Sonos app?   If you’re looking to see a ‘downstairs’ group in the Sonos app, you won’t see it as Alexa groups are for Alexa only.

 

 

 

 

RhysKnight,
Yes that’s a good point made by @melvimbe - you need to use the correct type of Alexa group for Sonos, as there are different groups for Amazon echo products only - the group should look similar to the image I posted earlier.

Note: You can’t mix and match Amazon and Sonos devices so that they group and play together. It’s either Sonos or Echo devices, not both, but echo devices can control/enable a grouped set of Sonos products.

Yes I’m not seeing the port listed as a room in the Sonos app. I appreciate the suggestions the next time I am able to take a look at the port I will see if any of these help. Thank you!

Yes I’m not seeing the port listed as a room in the Sonos app. I appreciate the suggestions the next time I am able to take a look at the port I will see if any of these help. Thank you!

It’s not showing in the Sonos App? ...In that case, perhaps use the ”Settings/Support/Find Missing Players” option to see if that gets the device to reappear and back up and running for you.

Yes I’m not seeing the port listed as a room in the Sonos app. I appreciate the suggestions the next time I am able to take a look at the port I will see if any of these help. Thank you!

It’s not showing in the Sonos App? ...In that case, perhaps use the ”Settings/Support/Find Missing Players” option to see if that gets the device to reappear and back up and running for you.

 

Definitely get this up and running with using the Sonos app for control before trying to get voice control through Alexa.

Reply