No Music!

  • 17 February 2021
  • 12 replies
  • 82 views

  • Anonymous
  • 0 replies

After 2 sessions with Apple and 3 sessions (3 hours) with Sonos Support each one sending me the other way I still can’t play my Library from my iMac to Sonos Playbar in the Lounge. It has worked ok for 5 years. Basically I get an error message when trying to load the Music Folder. They’ve checked Privacy and sharing options ad infinitum, no joy

Any help greatly appreciated, I’m reasonable at Techo but not great

 

Many Thanks

 

Roger UK


12 replies

Userlevel 6
Badge +17

What specific error message are you getting? What Mac OS version are you running? What is the file path for your music folder? Are you setting up the music library through the Sonos Mac controller or Sonos iOS app?

Thanks

Access to the shared folder “//Macintosh-3/Music2” is denied check username & password

 

Using Sonos on the iMac, I’m running latest BigSur

 

Roger

Userlevel 6
Badge +17

Did the problem begin when you updated to Big Sur?

No I updated to see if it would work on the latest software as Sonos suggested

Not sure i can remember how to see the path but found this

Computers on your local network can access your computer at:
Macintosh-3.local

When i access a song this is the path I get

/Users/rogerwilloughby 1 2/Music/iTunes/iTunes Music/Adele/21/05 Set Fire To The Rain.m4a

Userlevel 6
Badge +17

Your shared music folder path seems to be correct.

Do you have anything checked under Sharing in your System Preferences? Have added your “Music2” folder in your Shared Folders?

Userlevel 6
Badge +17

Do you actually have a “Music2” folder? Have you tried the path //Macintosh-3/Music instead and make sure the “Music” folder is added in the Shared Folders under Sharing in your System Preferences?

Apologies for late reply, shared folder is ok, don’t know how to change path from what i can see it’s ok.

Now escalated with Sonos they might want me to wipe my Mac system and start from scratch which I don’t want to do. If he can’t fix it then it’s goodbye Sonos. Any other system I could use to play my library on Mac through my playbar in another room. I don’t want to use spotify unless I have to, all my old CDs are on the Mac

 

Thanks

Roger

Userlevel 6
Badge +17

You can manually change the shared folder path in the Music Library setting in the iOS Sonos app.

If you don’t mind, can you post a photo of your settings under Sharing in your System Preferences?

 

Userlevel 6
Badge +17

I notice you have four music folders in the “Shared Folders” box. Are the “iTunes Music”, “iTunes Music-1”, and “rogerwilloughby 1 2” folders inside of the main “Music” folder or are they in a separate location?

 

Try these solutions:
 

Solution 1

  1. Uncheck “File Sharing”.
  2. In the Sonos iOS app, under Settings > System > Music Library > Music Library Setup, remove any library you currently have listed and tap on “Add Shared Music Folder”. Type: \\Macintosh-3\Music (and username and password if needed).

Solution 2

  1. Change your Computer Name to RogerWilloughbysiMac.
  2. Uncheck “File Sharing”.
  3. In the Sonos iOS app, under Settings > System > Music Library > Music Library Setup, remove any library you currently have listed and tap on “Add Shared Music Folder”. Type: \\RogerWilloughbysiMac\Music (and username and password if needed).

Solution 3

  1. Change your Computer Name to RogerWilloughbysiMac.
  2. Keep “File Sharing” checked
  3. In the Sonos iOS app, under Settings > System > Music Library > Music Library Setup, remove any library you currently have listed and tap on “Add Shared Music Folder”. Type: \\RogerWilloughbysiMac\Music (and username and password if needed).

 

I’ve just had an hour with my 4th Sonos guy, this one an expert I believe. This makes 4 sessions with Sonos, 2 with Apple and I’ve had enough. Sonos say it’s a problem with the Mac Apple say it’s Sonos. Spotify it is playing through the Sonos Playbar, not ideal but pretty good

 

Thank you for staying with me I really appreciate it

 

Roger

UK

 

Reply