Answered

No, I don’t want to hear Maroon Five after I asked for Stevie Wonder!

  • 9 January 2024
  • 5 replies
  • 71 views

This auto-play feature is making me crazy.
 

Please let me toggle it off!

We spent more time at home over the holidays & myself, my wife & my kids all resented this feature more & more every day we were home. 

When I use voice to request a track, I NEVER want another track to auto-play afterwards. No no no.

There isn’t a single music service on the planet that knows how to auto-recommend songs without absolutely destroying the vibe after 2-3 suggested tracks. Apple Music ruins it in 1 song almost every time! Genius, you are not, Siri. 

Maybe if Pandora worked in Canada & I could use voice to like & dislike songs, this wouldn’t be so egregious. But in no way to I want my 10,000+$ worth of smart speakers blasting Maroon Five in my house without my permission. Nope nope nope no thank you. 
 

PLEASE let me toggle back to the way this used to work. I understand people have been begging for Spotify-like auto-play. But it’s terrible. I hate it. Please just let me toggle it off permanently. 
 

Call it “Continuity Mode”. 

Want your Sonos speakers to keep the party going? Toggle Continuity Mode on, and when you or your party guests use voice control to request a song, Sonos will automagically tap into your chosen music service’s suggestion algorithm to keep the vibes going!
Prefer to curate your own track list? Turn Continuity off & Sonos will simply stop playing after you use voice to request a single song.”

^See how clear & easy that could be??

I would absolutely LOVE to get dunked on by someone telling me I’m an idiot because this feature actually already exists. Please: enlighten me! 

icon

Best answer by melvimbe 9 January 2024, 14:37

View original

5 replies

I don’t think there is an setting for this in the Sonos app, but I would look at the settings in your Apple music app, as it should carry over to when you use the Apple music through Sonos.  I’m primarily using Amazon music, and I do have autoplayed off in my music app and do not get autoplay through Sonos.

Userlevel 7
Badge +18

Hi @ThePeej 

Welcome to the Sonos Community!

Thank you - I've marked this thread as a feature request and it will be seen by the relevant teams for consideration. Keep the ideas coming!

I do think @melvimbe might be on to something there, but it may be worth looking at settings in the Alexa app too, if you don’t find any relevant settings in the Apple Music app.

I hope this helps.

Hi @ThePeej 

Welcome to the Sonos Community!

Thank you - I've marked this thread as a feature request and it will be seen by the relevant teams for consideration. Keep the ideas coming!

I do think @melvimbe might be on to something there, but it may be worth looking at settings in the Alexa app too, if you don’t find any relevant settings in the Apple Music app.

I hope this helps.

 

Thanks for much for replying.

This is a relatively new development. We’ve been using Alexa to play music for years on multiple speakers with no auto-playing unwanted songs. I haven’t trusted the Apple recommendation algorithm since back when they had the nerve to call it « Genius » 😝🤣 But just in case, I went & checked and I did NOT have auto-play turned on for Apple Music. I’ll check the rest of the family accounts, just in case. 

 

 

 

I don’t think there is an setting for this in the Sonos app, but I would look at the settings in your Apple music app, as it should carry over to when you use the Apple music through Sonos.  I’m primarily using Amazon music, and I do have autoplayed off in my music app and do not get autoplay through Sonos.

It’s definitely off on my Apple Music account across all devices. Going to go hunt through the Alexa app to see if that’s the culprit. Thanks for letting me know that you’ve got it running so that this doesn’t happen. Gives me some hope! 
 

So far this new development has been as bad as when lock-screen controls on iOS stopped working & I could no longer control the volume of a movie through the pocket of my jeans without even pulling the phone out. Or control on Apple Watch! Those were magical times… 

I don’t think there is an setting for this in the Sonos app, but I would look at the settings in your Apple music app, as it should carry over to when you use the Apple music through Sonos.  I’m primarily using Amazon music, and I do have autoplayed off in my music app and do not get autoplay through Sonos.

YOU BEAUTIFUL STRANGER!! It was that damned Alexa app that decided to override our Apple Music & Spotify settings. Just turned this off & will hope for the best! 

 

Reply