Question

No Beatles!


Badge

Here’s a strange one! I have a pair of Sonos Play 3 speakers linked to an Alexa-controlled Amazon Dot. The system has worked perfectly for 2 years. This week I upgraded my Amazon Music account to HD. Since then the system will play any music I choose but when I ask for any Beatles music I get silence. I have tested the Dot by isolating it and it will play Beatles just fine but as soon as I link it back to the Sonos speakers I get silence and Alexa says ‘Sorry there is a problem.’ I have contacted Amazon Customer Services and after re-setting and re-starting the Dot they can find nothing wrong with it. Any ideas? Thank you.


23 replies

Userlevel 7
Badge +20

Hi

Are you able to play the track via the Sonos App?

Badge

Yes just tried the Sonos App. Plays Beatles perfectly. That’s a step forward….so how do I now get Alexa/Dot to play it when linked to Sonos?

Thank you for your help.

Userlevel 7
Badge +20

What happens if you ask the same command twice? Some users are experiencing issues where the first command fails but a repeat of the same command is successful.

Badge

Same. No Beatles! Any idea why it’s just the Beatles? All other artists play just fine. And Alexa now speaks with an American accent! Very strange!

Userlevel 7
Badge +20

Same. No Beatles! Any idea why it’s just the Beatles? All other artists play just fine. And Alexa now speaks with an American accent! Very strange!

I wonder if this is a location issue or audio format issue. 

Please open the Alexa App>Device Settings and select your Echo device. Is the Device Location correctly set? And is the Language set to English (United Kingdom)?

Can you try a different command e.g. ‘Alexa. Play the white album’.

Badge

Location correct but you were right about the Language setting. Don’t know how it got changed but I’ve now changed it back.Thanks.

Still no Beatles!

Userlevel 7
Badge +20

Location correct but you were right about the Language setting. Don’t know how it got changed but I’ve now changed it back.Thanks.

Still no Beatles!

Did you try a different command e.g. ‘Alexa. Play the white album’?

Badge

Yes I did. I have been told that when there are several versions of the same album (remastered/special editions,etc) as there are for much of the Beatles catalogue on Amazon Alexa is unable to choose and so gives up. Don’t know whether Amazon is aware of this problem but it will only get more common in future for many artists.

Does anyone have any idea on this one? I have the exact same problem. I'm in the UK, have Alexa set up on a Sonos One and have Amazon Music linked. Everything works perfectly but as soon as you ask to play anything by the Beatles she repeats the command twice and then says sorry this cannot be played. I have an Echo Dot in the bedroom and that works fine. 

 

Userlevel 7
Badge +20

Just a thought but can you open the Alexa App-Settings-Account Settings-History and check that Alexa heard you correctly.

Badge

Alexa hears the commands ok just seems unable to choose from all the different issues of the same album or song.

Userlevel 7
Badge +20

It's strange as I don't have any issue asking the same command but my source is Spotify.

Badge

Had a two-hour telephone conversation with Amazon. We tried everything over those two hours. Eventually it was conceded that there is definitely a problem with trying to play Beatles music through Alexa since upgrading to HD. The details of the problem were referred up to the technical department last week but I’ve heard nothing since. In the meantime I was advised to cancel the HD upgrade and just use the standard quality Amazon music which has no problem accessing Beatles tracks. When I hear more from Amazon I will post their response/solution here.

I live in the U.K. and subscribe to Amazon Music HD. I just checked and The Beatles (White Album) is working here, using Alexa on my Sonos Ones (stereo paired).
 

I’m listening to ‘Back in the USSR’ as I type this post. There was an Amazon App iOS update this morning so just wondering if Amazon may have fixed this already?

Badge

That’s interesting. Have you tried accessing Abbey Road, Sgt Pepper and Let It Be albums? If they’re all ok I’ll try upgrading to HD again! Thanks for the response.

Abbey Road doesn’t work for some reason, but the other two albums (‘Sgt Pepper‘ and ‘Let it be’) are working fine here so not all fixed perhaps… any more you would like me to try?

Badge

I couldn’t get it to play Penny Lane or Strawberry Fields or any of the early albums. Interesting that you got Let it Be and Sgt Pepper to work but not Abbey Road. Last week I couldn’t get any of them to play.

Strawberry fields works .. just checking others for you. See screenshots.

Abbey Road ...no joy

Penny Lane … no joy

The rest you mentioned are all working okay… so perhaps wait a week or so and see if they get it all fixed. If you remind me next week, I will test those two again for you.
 

Badge

Many thanks. Sounds like progress. I’m very grateful for the time you have spent on this. 

Still not working for Penny Lane or Abbey Road - will test again after next round of updates.

Badge

This is bizarre. Contacted Amazon again on Monday as I had heard nothing from them. They said they needed more information (!) and asked me to temporarily upgrade again to HD which I did. We took each Beatles album in turn and I asked Alexa to play them. The only 2 that worked were White Album and Abbey Road. All of the others could not be accessed. They took forever to note down the results, told me they would pass it back to their technical department and promised to call me within 48 hours. Needless to say I have heard nothing from them. I again cancelled the HD upgrade and reverted to standard sound quality. I can access every Beatles album and track! Aaaaargh!!!

Abbey Road / Penny Lane are still not working here @CW172 - just thought I would test it again for you.

Reply