Can't control LG tv anymore


Badge
All working well for months. Today, Alexa was not able to switch off the TV anymore (connected to the beam with HDMI ARC). I tried to remove the TV from the device list and perform a device discovery on alexa app, but now it doesn't find the TV anymore. What can I do? I've already tried to disable and re-enable sonos skill

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Badge +1
I'm seeing problems with Alexa even discovering my devices. May I ask: does your beam show up as an Alexa smart home device?
Badge
Yeas. Beam shows as a device in Alexa list, but the tv is not listed (as it was)
Badge +1
What’s the icon next to the beam? Does it look like a WiFi symbol in a circle or a speaker?

If it’s a WiFi symbol in a circle and there’s no speaker then we may be in the same boat sadly.

I’m waiting on support and will definitely post when I know something, because all the helpful posts on this community have not managed to fix my issue (https://en.community.sonos.com/amazon-alexa-and-sonos-229102/starting-yesterday-alexa-cannot-discover-any-sonos-devices-as-speakers-but-sonos-devices-accept-voice-input-6819621)
Badge
The symbol is the one you describe, but i’ve not had any problem in the past: th tv connected via hdmi to the beam was visible in Alexa device list
Badge +1
I wish I could say more than “me too”. I’m wondering if something about the sonos-output half of the Alexa integration died in the last day or two somehow. Good luck, and if I find anything I can imagine would help I’ll speak up.

You could try the guide that UKMedia has posted a few times (it’s quite good), but if your issue is mine it won’t fix the issue. I’d still be curious.
Allot of us are having trouble with the same issue. The beam is showing only as an Echo or Dot and not as a Sonos Speaker + TV like it did prior.
Badge
Did you report the problem to sonos?
Badge +1
Yes, emailed a few hours ago. I’ll call them tomorrow when they’re open. Will absolutely update you all, of course. I can’t tell if your issue is the same of course.
Wrote them a tweet as well. Hoping that will be a little more visible. Between gdgib's email case and my public message hopefully we'll find a resolve quickly.
Badge +1
We seem to be back in business. I, and a few others, have been able to discover our devices properly again.
You beat me to it! I'm back in action again as well!