Audio actions in routines are currently not supported on this device

  • 5 December 2018
  • 44 replies
  • 19804 views


Show first post

44 replies

I'm with the others above that think this is a new problem. I've had a Sonos One in my system for about 7 months using quite a few routines and I don't think I've heard this till I added a new one today - which brought me to this thread.

The routines all apear to work... even any configured dialogue where Alexa responds but this new incorrect error message gets added in.

Per this chap having the same issue with his EchoBee: https://youtu.be/p4U7X3zq0bA the behavior seems inconsistent and some routines work without adding the message. It is as if Amazon have configured some whitelist of expressions/grammar intending to capture things that don't work (I have a strange feeling that some things used to fail silently). Unfortunately it would seem they forgot to handle the case of free form routine triggers. Given the same happens on other Alexa-enabled products that does suggest Amazon are the source of the problem. You'd think Sonos would be following up with them however as it is Sonos that lose out here.

I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.
“I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.”

This I think sums up the experience of many users lured into this by the unclear marketing (to not say deceiving). What indeed is the point of the Sonos One when the best solution was clearly Sonos Play + Dot?

As a person new to both Alexa and Sonos, I don’t get it.
This is an Alexa problem for some class of devices (undetermined). This isn't limited to Sonos, Eco Bee has the same issue reported as does the Alexa app on the iPhone. Try using the Alexa app to run the routine with your voice. Then run the same routine on the Alexa app using the play button next to the routine. Only voice activation gets the annoying message.
Badge +1
I think this issue might've been resolved as of tonight. We have a "good night" voice routine that we use from the Beam in our bedroom. Wed got used to sarcastically chanting "Audio routines are not supported..." and then suddenly tonight, the routine just ran without a fuss.
Badge
I think this issue might've been resolved as of tonight. We have a "good night" voice routine that we use from the Beam in our bedroom. Wed got used to sarcastically chanting "Audio routines are not supported..." and then suddenly tonight, the routine just ran without a fuss.
Could you please add an audio action to your routine and see if the error message comes back again or not? It seems that the error message happens only if you add an audio action to your routine.
Userlevel 2
Badge +1
I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.

Just FYI, Alexa-enabled speakers can now be assigned as the "preferred speaker" in a room, and also, more recently, the Alexa app was updated to allow these devices to be assigned to a specific room and therefore make Alexa room-aware. So, for example, I can say to the Sonos Beam in my living room, "Alexa, turn on the lights," and Alexa knows to only turn on the lights in my living room. Likewise I can say to the Sonos One in my bedroom, "Alexa, turn off the lights" and Alexa knows to only turn off the lights in the bedroom. This functionality was previously only available to actual Echo products, but was added to Alexa-enabled speakers... eventually. Yes, these devices are still missing some functionality when compared to actual Echo products (like drop-in and messaging) but I just wanted to chime in that there has been SOME progress on this front, and I'm happy to see it.
Userlevel 2
Badge +1
I think this issue might've been resolved as of tonight. We have a "good night" voice routine that we use from the Beam in our bedroom. Wed got used to sarcastically chanting "Audio routines are not supported..." and then suddenly tonight, the routine just ran without a fuss.
Could you please add an audio action to your routine and see if the error message comes back again or not? It seems that the error message happens only if you add an audio action to your routine.


This is such an annoying issue, especially because the "error" Alexa says isn't even true! The audio action in my routine was just successfully executed, so why does Alexa need to tell me (every time?!?!?!) that audio actions in routines aren't currently supported?

Anyway, up until recently she would say that after any routine I gave my Sonos Beam, regardless of whether or not the routine actually had an audio action (which was even MORE annoying!) The routine worked fine otherwise, and also worked fine (with the audio action of Alexa wishing me a good night) from my Echo speakers in other rooms.

Just tonight I tried it again, but removed that audio action first, and lo and behold, Alexa didn't say "Audio routines are not supported..." at the end. Alexa didn't wish me good night at the end either (obviously) but that's a sacrifice I am willing to make so I can avoid hearing that "error" again. And again and again.

I really do hope Amazon fixes this. It's disappointing this bug has lasted as long as it has.
Hi. (Apologies if this has been mentioned or noticed or discussed already.) I noticed something odd while looking at Alexa Routines involving Audio Actions.

Currently I have a Beam connected to two ones for home theatre, (I also have several Philips Hue bulbs)

Prior to having the Hue bulbs I could say “Alexa, GoodNight” to which she would reply using a random phrase. Exploring the Alexa iOS app I found the Routines page.

There I noticed, listed under ‘Featured’ was the default preprogrammed Goodnight Routine... WHEN: Alexa, Goodnight,
ALEXA: Say A Random Phrase From Good Night FROM: The Device You Speak To.


Everything was fine and worked.
UNTIL, I got the Hue bulbs and connected everything up.

I thought I’d be clever and edit the original default preprogrammed Goodnight routine from the featured routines page. So all I did was in the action All Hue Lights - Turn Off.
Suddenly Alexa found the cursed “Audio Actions In Routines Not Supported” message!
Aha! I thought, in my amended routine, the audio action was listed before the lights off action, swap them and save the day.... but no. No matter the order of the actions Alexa gives an Audio reply saying she can’t give audio replies.

I realise that so far this is nothing new to this thread and conversation.

However, it strikes me as VERY VERY odd that the Alexa app comes with a featured preprogrammed routine, AND that routine is specifically an Audio Action routine. THAT WORKS with Sonos!!

To me this makes no sense. Pre-existing Audio Action Routine ~ works with Sonos. Add to that Routine ~ Audio Action doesn’t work but added action does??
Was the featured Goodnight routine, that comes with the app, not a true routine and just a command? Or does integrating more smart devices cause the problem? What’s the logic here?
For Alexa routines to be properly supported. Sonos needs to implement the “InteractionModel interface of the Alexa Voice Service (AVS)”.

I recently had a Bose Soundbar 700 from their smart speaker range. I eventually returned it due to numerous problems, but this was one issue they did manage to resolve for me. Since then I moved to Sonos, and am extremely pleased I did!

So this is probably the only issue I have with the Sonos system, it would be great if Sonos could resolve it.

Details are here:
https://developer.amazon.com/blogs/alexa/post/a1470f4c-8aaf-4d12-b3bc-5cf38820ff82/alexa-it-s-bedtime-routines-for-avs
I have smart plugs from different companies and apps. In each I had a scene called good night. The Alexa routine turned each scene on, and gave the error. I renamed one of the scenes to bed time 1, and now the Goid Night Alexa routine does not give the message any longer.

My good morning routine included similar goid morning routines, I renamed one. I still got the message. My good morning routine included play weather on the device I speak to. I changed the weather to output to an Alexa device and my messages have now cleared.
Userlevel 2
Badge +3
This is a really annoying bug. So far as a new Sonos user I'm extremely unimpressed with the product. My experience with the Sonis One has been a series of unexpected limitations and bugs, with Sonos dismissing most of them in this forum with an attitude of "that's just how it works".
So, I’m not crazy. This is a problem other people are still facing with no solution? Because I’m experiencing it with my brand new Sonos Ones (Gen 2) and it’s annoying AF.
amadeoplaza,

Sonos does not (yet) officially support Alexa Routines with their devices as part of the routine itself, though you can launch some routines for light/plug control etc. We will have to wait and see if “the powers that be” decide to go onto to do this, but presumably Sonos have higher priorities with Google Voice Assistant being announced for next week in the U.S.
I tried Google Assistant on Sonos and the results aren't any better than Alexa (it's actually worse in most cases). Asking Google Assistant to change TV volume takes like 10-15 seconds to complete (no joke). Google Assistant can turn off my TV, but it can't turn it on. But hey, at least I can change Google Assistant's voice to British or Australian, which is fun but hardly a selling point. Routines and other Google Assistant functionality simply doesn't work at all. Alexa is the better option on Sonos, even though it's seriously hobbled. Maybe Polk or Bose or Visio will figure this out and force Sonos to play catch-up (or I'll just upgrade to the inevitable Amazon-branded soundbar, probably coming out this holiday season!)
Badge
I have set up a Routine in the Alexa app which is a set of commands for the phrase "Alexa, Goodnight" in which two lights are switched off in the same room. I have also tried to add a command to siwtch the audio off from a Sonos One to which the command is issued in the same room but unfortunately, the device does not show up in the list of Smart Home devices. A Sonos Beam in another room does appear in the list.

Is there any reason why the Sonos One doesn't appear and the Beam does? After all the Beam and One are just "Alexa Enabled" devices....
The fact that it’s been one year with this issue is what blows my mind.

such a big company and have no regard for their community.

It either has Alexa or not. They need to stop marketing that it does because it doesn’t.

i can’t market a whole house for sale and sell you half a house.

Luckily i I bought one, I’ll return it tomorrow because waiting for the “brilliant” engineers to fix it has already taken a year.

I feel for anyone whos spent a lot of money with Sonos.
Userlevel 7
Badge +20
The fact that it’s been one year with this issue is what blows my mind.

such a big company and have no regard for their community.

It either has Alexa or not. They need to stop marketing that it does because it doesn’t.

i can’t market a whole house for sale and sell you half a house.

Luckily i I bought one, I’ll return it tomorrow because waiting for the “brilliant” engineers to fix it has already taken a year.

I feel for anyone whos spent a lot of money with Sonos.

I'm not aware of any marketing information from Sonos that states they will support all Alexa functionality. The stated primary goal of Sonos is to enable the control of music via Voice Control. All reviews that I have read by 3rd party organisations state that Alexa functionality is not 100%.
Userlevel 2
Badge +3
Have you tried looking at the audio routines subset and deleted or erase whatever is there (it could be a hit of the space bar or simply Alexa "thinks" something is there) doesnt hurt to try.

I have the opposite problem... I did place an audio routine - and it executes it - after saying "this device does not support audio..." lol..bugs in the system... I love the sound, though
+1.

I have sank over 2k into my SONOS system. I've had this problem from the beginning. I only get the message when there's an audio action as part of the routine. Alexa still executes the routine and even does the audio action after she tells you it's not supported. I researched this issue when I first started 2 years ago and I'm disappointed that this thread is exactly where I left it with more people complaining of the problem that's still unresolved.

I have well over 100 connected smart home devices in my home and this issue is the most persistent (because there's a SONOS in every room talking back to me telling me it's not going to do something). Just remove that response! Literally, the speaker saying nothing is preferable.

Reply