An Overview and Explanation of the new support for Alexa Grouping


Userlevel 7
Badge +20
When initiating music via voice control, the behavior of the Sonos Grouping of Rooms is now driven by the Preferred Speaker within the Alexa App Group - Please see:

https://en.community.sonos.com/announcements-228985/sonos-now-playing-with-alexa-groups-6817588

Sorry for the long post but I've tried to explain some process, as well as some of the terminology for those first setting these up:

Alexa Group Set-up

Ques 1 – What is your Controlling Alexa Device?

1.1 – From your list of Alexa devices, both Sonos and others, choose the Controlling Device;
1.2 – Create an Alexa Group, named after the room that the Controlling Device is located in and select the chosen Alexa device. (If you select a Sonos device as the controlling device, this device can only be included as the Controlling Device in one Alexa Group);

Ques 2 – What Sonos devices do you want to reduce their volume on when Alexa is triggered (Ducking), so that the command can be heard by Alexa more easily?

2.1 – From your list of Sonos Rooms/Devices choose those that you want to duck when an Alexa Command is being given;
2.2 – Include all of these Sonos devices by adding them to the Alexa Group.

Ques 3 - What Sonos ‘Rooms’ do you want the requested music to be output on for Multi-Room Music?

3.1 – Within the Alexa Group set-up, select ‘Preferred Speakers’ and select all of the Sonos Rooms that you want to be grouped together for Multi-Room music.
3.2 – Save the Group

Please repeat for all other rooms which contain an Alexa Device that you want to control Sonos players.

Notes:

1 - It is still advisable to create Groups, Devices and Routines with unique names.
2 - It is also possible to create an ’Uncontrolled Alexa Group’. In this case, an Alexa Group is created but with no Controlling Alexa Device (Ques 1) or Grouped Rooms (Ques 2) defined. These must be referenced with the Group name included within the command – See Scenario 2

Scenarios

Scenario 1 – Auto Group Sonos Players

Controlling Device: Echo Dot in Kitchen (Alexa Device name: Kitchen Echo Dot)
Grouped Sonos devices to be ducked: Kitchen Playbar + two Play:1’s as surrounds (Alexa Device Name: Kitchen Sonos), and Dining Room Stereo pair of Play:1’s (Alexa Device Name: Diner Sonos)
Preferred Speakers: All Sonos Rooms
Group Name: Kitchen

Start state: Only Kitchen Sonos playing music

Command to Kitchen Echo Dot: ‘Alexa, Play Soft Jazz’

Result:
1. Kitchen Sonos & Diner Sonos volume reduced on the trigger of hearing ‘Alexa…..’
2. Current music to Kitchen Sonos stops;
2. All Sonos Rooms group together and shown as such in the Sonos App;
3. Soft Jazz output to all Sonos Rooms

Scenario 2 – Play Music to a subset of Sonos Speakers from any Alexa Device

Controlling Device: N/A
Grouped Sonos devices to be ducked: N/A
Preferred Speakers: All Sonos Rooms Downstairs
Group Name: Downstairs

Start State: No music playing

Command: ‘Alexa, Play Soft Jazz on Downstairs’

Result:
1. All downstairs Sonos Rooms group together and shown as such in the Sonos App;
2. Soft Jazz output to all Downstairs Sonos Rooms.

Commands

Ques 1 – How do I play music to a single room?
Command – ‘Alexa, Play Soft Jazz on [Sonos Room Name]’
Ques 2 – How do I play music to my standard multi-room group of Sonos Players?
Command – ‘Alexa, Play Soft Jazz’
Ques 3 – How do I stop music being output to a single room (e.g. to answer the phone) but continue to play music in the other rooms?
Command – ‘Alexa, Mute’

This explanation is still in draft form, so please let me know if you have any questions.

19 replies

Userlevel 2
Badge +5
So is this it ?

the golden ducking bullet ?

I setup my system again last night and was asked for preffered speakers and noted that I nolonger have to command my dot to play in a specific room, it just plays on the preffered speaker.

Not tested ducking yet, but this is moving in the right direction 🙂
Userlevel 7
Badge +20
27/12/2018 16:08 GMT - I'm not sure why but Grouping wasn't working, so I Disabled then Enabled the Sonos skill in the Alexa App and it's all back working again.
27/12/2018 16:08 GMT - I'm not sure why but Grouping wasn't working, so I Disabled then Enabled the Sonos skill in the Alexa App and it's all back working again.Did you perhaps rename some of your Alexa groups? My thoughts here are that it may take some time for changes to filter through the system and start working, but removing/reinstalling the Skill might update things far quicker.

Just as a thought !
Userlevel 7
Badge +20
27/12/2018 16:08 GMT - I'm not sure why but Grouping wasn't working, so I Disabled then Enabled the Sonos skill in the Alexa App and it's all back working again.Did you perhaps rename some of your Alexa groups? My thoughts here are that it may take some time for changes to filter through the system and start working, but removing/reinstalling the Skill might update things far quicker.

Just as a thought !


Hi Ken

Nope, just suddenly stopped working. I also did 'Alexa, discover devices' before in case that had an impact but no.
Hi Ken

Nope, just suddenly stopped working. I also did 'Alexa, discover devices' before in case that had an impact but no.
Hmmm...that was the only thing I could think of Simon, unless perhaps there was some 'temporary' behind the scenes service outage. At least it’s all sorted now.?
Userlevel 2
Badge +5
Web setup doesnt have the new grouping 😞
Userlevel 7
Badge +20
Web setup doesnt have the new grouping :(

Sorry, what platform are you using the Alexa App on?
Web setup doesnt have the new grouping :(

Yes, the web based Alexa app often lags behind in features.
Userlevel 2
Badge +5
PC app doesnt seem to have it either. Works on the Ipad though
I have 2 echo dots (downstairs & upstairs), 2 Play 1's and 1 amp. I created one group with Downstairs echo as Alexa-enabled device and all Sonos speakers. I tried and tried to get the Downstairs echo to "play music" and have the single group I made play. Alexa replied "could not play to this group yet." Telling Alexa to play in whatever room still worked fine, but not the group. Just fiddling, I created another group with the Upstairs echo dot as Alexa-enabled device controlling and all speakers in the group. THAT one works as expected. "Alexa play music" played on all speakers! Yay! Run downstairs and try there. Crap, same thing, "could not play to this group yet." I deleted downstairs and recreated, same issue.

Any idea why one group with the upstairs dot as controlling device works fine and the same setup in another group with downstairs dot controlling device does not? Thanks!
I have 2 echo dots (downstairs & upstairs), 2 Play 1's and 1 amp. I created one group with Downstairs echo as Alexa-enabled device and all Sonos speakers. I tried and tried to get the Downstairs echo to "play music" and have the single group I made play. Alexa replied "could not play to this group yet." Telling Alexa to play in whatever room still worked fine, but not the group. Just fiddling, I created another group with the Upstairs echo dot as Alexa-enabled device controlling and all speakers in the group. THAT one works as expected. "Alexa play music" played on all speakers! Yay! Run downstairs and try there. Crap, same thing, "could not play to this group yet." I deleted downstairs and recreated, same issue.

Any idea why one group with the upstairs dot as controlling device works fine and the same setup in another group with downstairs dot controlling device does not? Thanks!
When you create the Group for 'Downstairs', perhaps try this instead... call the created group 'Ground Floor'.

Add the 'downstairs echo dot' as the 'Alexa Enabled' (controlling) device for the 'Ground Floor' Group. (This is the first section of the Alexa Group).

Then add your Sonos speakers/devices to the 2nd middle section of the group ... you can also add any available/relevant smarthome 'lights' and 'plugs' to this section too.

Finally in the 'preferred speaker' (3rd) section of the group choose the Sonos speaker/device or multiple Sonos speakers/devices you wish to play your music to.

Save the settings and give things a minute, or two, to update....

Then goto the downstairs echo device and say 'Alexa Play some Music' ..Assuming no rooms were grouped to begin with, the 'preferred' speakers you chose should group themselves together automatically in the Sonos App and begin playing.

The reason I have suggested you call the Alexa Group 'Ground Floor' is it needs a unique name and I suspect for some reason that your group was not working with the name 'Downstairs’ as its name was perhaps clashing with one of your echo or Sonos devices.

Anyhow see if that works for you ... you can always rename devices and the groups later, if you prefer to change the name of the Alexa Group... but let’s get it working for you to begin with.
I have 2 echo dots (downstairs & upstairs), 2 Play 1's and 1 amp. I created one group with Downstairs echo as Alexa-enabled device and all Sonos speakers. I tried and tried to get the Downstairs echo to "play music" and have the single group I made play. Alexa replied "could not play to this group yet." Telling Alexa to play in whatever room still worked fine, but not the group. Just fiddling, I created another group with the Upstairs echo dot as Alexa-enabled device controlling and all speakers in the group. THAT one works as expected. "Alexa play music" played on all speakers! Yay! Run downstairs and try there. Crap, same thing, "could not play to this group yet." I deleted downstairs and recreated, same issue.

Any idea why one group with the upstairs dot as controlling device works fine and the same setup in another group with downstairs dot controlling device does not? Thanks!
When you create the Group for 'Downstairs', perhaps try this instead... call the created group 'Ground Floor'.

Add the 'downstairs echo dot' as the 'Alexa Enabled' (controlling) device for the 'Ground Floor' Group. (This is the first section of the Alexa Group).

Then add your Sonos speakers/devices to the 2nd middle section of the group ... you can also add any available/relevant smarthome 'lights' and 'plugs' to this section too.

Finally in the 'preferred speaker' (3rd) section of the group choose the Sonos speaker/device or multiple Sonos speakers/devices you wish to play your music to.

Save the settings and give things a minute, or two, to update....

Then goto the downstairs echo device and say 'Alexa Play some Music' ..Assuming no rooms were grouped to begin with, the 'preferred' speakers you chose should group themselves together automatically in the Sonos App and begin playing.

The reason I have suggested you call the Alexa Group 'Ground Floor' is it needs a unique name and I suspect for some reason that your group was not working with the name 'Downstairs’ as its name was perhaps clashing with one of your echo or Sonos devices.

Anyhow see if that works for you ... you can always rename devices and the groups later, if you prefer to change the name of the Alexa Group... but let’s get it working for you to begin with.


Thank you, Ken. I guess I should have added I named the first, non-working group "First Level" so it is completely unique. The second, working group is called "Second floor" - also very unique.

But you know what? The group name shouldn't matter since we no longer need to tell Alexa the group. Just "Alexa, play music" and the dot you speak to should then fire up the group is controls. Perplexing.
Chipper62,

Yes, I have numerous groups with 15 speakers and a multitude of hue lights and plugs working here at my home, across several floors, but the the group name is important for some tasks ... none of which I have mentioned to you yet.

For example, you will need Group Names in your Alexa instruction to break out of larger groups. For now though, I’m just trying to keep things extremely simple for you.

So a unique name for all devices and groups may become important, even though you are not using it in the rather simple instruction I mentioned in my original post.

Just to say too, you don’t need to add the Speaker to the 2nd part of the group either, in some instances... you can just set devices as 'preferred' in section 3 for playing purposes. The second section is there for 'audio ducking' purposes when it comes to Sonos.

There are lots more you can do with groups, (even when no speakers are added or 'preferred') within a group, which we can perhaps discuss later once we have resolved your initial problem here.

Also remember that whilst a controlling Alexa device can only be used once per set of groups, you can actually enable any group with multiple devices.

So did you try the setup I suggested and did you set the preferred devices and did it work?

Note you cannot set the preferred speaker/device via the web version, or desktop version, of the Alexa App ... you will need to set these in the mobile App.

I’m assuming you are seeing the 'preferred' speaker section for music in your Alexa setup ... see screenshot of one of my groups attached.

Hope that helps ?
This is great and works pretty good! I do have problems "handing over" music back and forth between controlled and uncontrolled groups it seems, though.

I have three Sonos Ones set up: two in the living room, one in the kitchen. I created two controlled groups (kitchen, living room) that have the individual Sonos speakers set up as their controlling device respectively. I also selected these speakers as the preferred speakers for their respective groups, which lets me do things like "Play Spotify in the living room". Now i added another (uncontrolled) group, "everywhere", and added all the speakers as preferred speakers. This lets me say "Play Spotify everywhere" and the music starts playing on all my speakers, nice!

However: when the music is playing in either of the rooms, or "everywhere", Alexa won't handle my commands as I'd expect it to. If audio is playing "everywhere" (Sonos speakers are auto-grouped in the Sonos app) and I tell Alexa to "Play the music just in the living room", it announces the music for the living room but it keeps on playing everywhere. If I have something playing in the living room and tell Alexa to play something else (e.g. playing Spotify, switching to TuneIn) everywhere, it will only play it in the room that is already playing. So playing anything "everywhere" (group) will only ever work if I stop any previous music beforehand and start the new command "fresh".

Anybody having the same problem or a heads up where my setup is wrong?
Userlevel 7
Badge +20
This is working as intended I believe. If you have music playing on a different or wider group than your preferred speakers then the preferred speakers are added rather overriding the existing audio group.
Userlevel 7
Badge +20
As of a few days ago, Amazon have rolled out an Alexa update which will result in Alexa Groups being created automatically for all Sonos devices. While you'll still be able to make groups the same as before, Alexa is going to default to creating automatic groups for your Sonos speakers that aren't in an Alexa Group. The auto-group creation applies only for people with existing Echo devices linked to Sonos systems. Alexa will put each Sonos speaker not already in an Alexa Group into an Alexa Group and set it as the "Preferred Speaker." These groups will not be created for people who don't own any Echo devices.
I recently set up an Amazon Fire Stick to control my VIZIO smart TV. I have two questions: 1) Can I now use the TVs built-in speakers as streaming music audio output in an Amazon group containing Sonos speakers, and 2) Can I make my Sonos speakers play surround sound audio for this TV without a 5.1 speaker system?
I recently set up an Amazon Fire Stick to control my VIZIO smart TV. I have two questions: 1) Can I now use the TVs built-in speakers as streaming music audio output in an Amazon group containing Sonos speakers, and 2) Can I make my Sonos speakers play surround sound audio for this TV without a 5.1 speaker system?The fire stick is not supported by Amazon Alexa Enabled Groups and so the TV Speakers cannot be used in conjunction with Sonos devices in a group setup... and the answer to your second question is 'no' you will not be able to use it in conjunction with your Sonos speakers to output 5.0/5.1 surround sound. You can however ask the built in assistant to play streaming music audio on your Sonos speakers from your default Alexa MSP (Amazon Music, Spotify, Deezer, Apple Music, TuneIn etc.), if you have setup the Sonos skill within the Amazon App.
Userlevel 2
Badge
Thank you so much for this. I'd just set up groups for all my Alexa devices setting the Sonos in that room as the preferred speaker and it worked, but it was killing me that it would duck the Sonos when talking to Alexa. Turn out you have to add the the Sonos as an Alexa enabled device as well as preferred speaker and then the ducking works. Not exactly intuitive. But thanks to your guide it now works and the kids will no longer duck the entire house by asking Alexa jokes.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings