Amazon Dot and Play 5 line in going quiet when replying from Alexa

  • 5 October 2017
  • 72 replies
  • 14182 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

72 replies

Userlevel 7
Badge +26
sjsvitenko, there are a couple things I'd like to pin down here. First off, the Sonos One is in the same room as the PLAYBAR and SUB if they're all bonded together as a surround sound setup, so if you're in that room and you say "Alexa" it should all duck down with the current design.

Secondly, when the Dot upstairs hears Alexa, the PLAYBAR will duck (and so will the other players bonded in that room), because the PLAYBAR doesn't know that it has a Sonos One in the room.

One big however though, if you're playing the TV audio on the PLAYBAR, it shouldn't duck at all. If it's playing music or any other source, it would.

Finally, in answer to your question, if you turn off the Alexa Skill for Sonos, the Sonos One will still be able to use skills and basic features, but not control what's playing on Sonos devices. It'd be one of those things where we don't recommend it, and it may have some funny quarks since it's not an intended use. But you're welcome to give it a shot and see what you think.
Thanks Ryan—I appreciate the reply! You are correct on the One’s being bound to the Playbase and Sub all in the same room. I have no issues with all Sonos in the same room ducking—that would be the right behavior. It is the ducking in a downstairs room when anyone talks to Alex upstairs that really needs to change. I know it’s being worked on, so I’ll let that work itself out and stay tuned here for developments. For the last part, using the Sonos Ones without the Alexa is certainly not what I want long term either, but if the Sonos Ones can essentially replace my Echo downstairs for a while, while ducking gets sorted out, I’m okay waiting a bit for that. Thanks again!
Ryan S - To confirm I have a Sonos One (love it so far) and echo dots some with line in. If I disable the alexa skill my line in will work (and no ducking problem) and I can still use Alexa with the Sonos One? With the skill disabled how does the One know its my Alexa account?

I like having the Dot on my Play 5 as I have a big room the One won't cut it but I want the flash briefings etc to come out the Play 5. In another room I have the One.

The ducking thing is driving the family mad as we use Alexa a lot and also have Sonos in most rooms.

Will play around today.


sjsvitenko, there are a couple things I'd like to pin down here. First off, the Sonos One is in the same room as the PLAYBAR and SUB if they're all bonded together as a surround sound setup, so if you're in that room and you say "Alexa" it should all duck down with the current design.

Secondly, when the Dot upstairs hears Alexa, the PLAYBAR will duck (and so will the other players bonded in that room), because the PLAYBAR doesn't know that it has a Sonos One in the room.

One big however though, if you're playing the TV audio on the PLAYBAR, it shouldn't duck at all. If it's playing music or any other source, it would.

Finally, in answer to your question, if you turn off the Alexa Skill for Sonos, the Sonos One will still be able to use skills and basic features, but not control what's playing on Sonos devices. It'd be one of those things where we don't recommend it, and it may have some funny quarks since it's not an intended use. But you're welcome to give it a shot and see what you think.
Started happening to me today after installing Sonos One. Must be related to the required software update. How has this not been solved 21 days later? And the Sonos One installation is terribly complicated and doesn't support Spotify. WTF
Userlevel 7
Badge +26
Ryan S - To confirm I have a Sonos One (love it so far) and echo dots some with line in. If I disable the alexa skill my line in will work (and no ducking problem) and I can still use Alexa with the Sonos One? With the skill disabled how does the One know its my Alexa account?
With the skill disabled, the Sonos One still knows that it's an Alexa device, and therefore should be able to keep on playing music to itself and perform basic functions. I will say that this isn't an intended use so there could be issues performance wise. It may work great for you, but I can't promise that.
So I have my Dots set up with no physical connection to the Sonos. The Sonos skills are active. When anyone talks to the Dot, any Sonos playing will duck.
The ability to turn this off would be appreciated.
To resolve it for now, I’ve had to turn off the skill. Alexa still knows that the Sonos devices are there, but won’t communicate with them.
I just enabled this new skill today and am generally very pleased with the features. The ducking issue is a disappointment. I suggest giving users the ability to disable ducking. My Dots don't really have much trouble hearing me with the music up anyway. I'd be very happy with the ducking feature disabled as a user choice, or just gone if making it optional isn't as easy as I assume it is.

I'd agree -ducking as a user option would be the best thing. I can see why it's implemented, and it's a good feature, but not everyone wants that behaviour - I don't.
It drives me nuts that Sonos engineers refer to the audio jack on the Amazon Echo as a "Line In". It is no such thing. It is a audio line OUT - meaning the Echo is the source of audio and instead of audio playing through it's built-in speaker, it goes OUT to whatever speaker is attached to the LINE OUT!
It drives me nuts that Sonos engineers refer to the audio jack on the Amazon Echo as a "Line In". It is no such thing. It is a audio line OUT - meaning the Echo is the source of audio and instead of audio playing through it's built-in speaker, it goes OUT to whatever speaker is attached to the LINE OUT!

Could you point to an instance of this? I've only seen the line-in on the Sonos device referred to as a line-in, because that is what it is. Being Sonos representatives, they are Sonos centric, and therefore refer to the method of connecting the line-out on a Dot to the line-in on a Sonos device as "the line-in method".
Badge
Likewise. I have the exact same problem on both my CONNECT:AMPs. Is there a fix for this?
Userlevel 7
Badge +26
Likewise. I have the exact same problem on both my CONNECT:AMPs. Is there a fix for this?
There isn't really a fix since it's really performing as intended at the moment. The CONNECT:AMP is supposed to drop its volume and you talk to Alexa so that the microphones can hear you, and you can hear Alexa's reply.

The best workaround would be either to disconnect the line-out on the Dot to your CONNECT:AMP's line-in. Otherwise, you could disable the Alexa skill for Sonos and the ducking would be disabled. However, you wouldn't be able to control Sonos using Alexa anymore.

We're still doing some work on this feature based on feedback, so there will be some changes coming in the future.
I am having the same problem. I tried disabeling the play 5 speaker from my smart home in the alexa app to see if it would prevent the ducking the ducking. But it didnt... has this been resolved??? It is annoying and limits the isability of your echo dot
Any update on this, it is making some of my Alexas unusable and as you never know which one is going to answer it is a real pain!
I know I make this sound easy, but why can't there be a tick-box setting somewhere that simply says "Hear Alexa responses from this speaker" which when selected would stop the ducking on the Alexa response part (i.e.after it has finished listening, which would still be ducked).
this is THE MOST annoying feature. i disabled the skill. excuse me, it's not a feature - it's a DEAL BREAKER!!!
Just disabled the skill, since it makes the dot hooked to a Sonos unusable... it was also driving me nuts with the music playing on other sonos randomly going quiet for seemingly no reason. Very disappointed with the way this works.
thanks for the work around was driving me nuts when I first tried to hook my dot to my Sonos quick google search found this.
Like others disappointed with the Sonos skill but hard wired and disabled skill does what I want
Adding my vote to allow end users to toggle ducking on/off with the Alexa Sonos Skill. Bought echo dots for the house and enabled the Sonos skill. Every few minutes, Sonos would 'duck' when one of my kids would ask Alexa something in another part of the house. We disabled it and went back to our mobile app to control Sonos. Hopefully this gets resolved soon.
I think more importantly than enabling or disabling for most people if the sticking only happened to the Sonos in the group that the Amazon echo is assigned this would resolve most people's issues with the speaker being ducked down when an activating command is issued in a different room to the Sonos
I had same issue and I removed the Play 5 from the list of Alexa SMART HOME devices (found in the Alexa app). This restored the Alexa voice to its normal volume. Obviously, it means that I can't ask Alexa to play music in the Kitchen (the Sonos name for the room where the Play 5 is located) but Alexa accepts requests to play music in the other Sonos rooms. It is still possible to ask Alexa to play music etc on the Echo Dot which is connected to the Play 5 speaker as I could before this latest update from Sonos/Amazon.

This is by far the best solution for my purposes. I don’t want to disable Alexa skill as that means we can’t use voice capability on Sonos One in another room. No more ducking now. Thanks, Stephen!
Userlevel 2
Badge +4
This issue is so annoying it making the skill useless so I disable the skill, what genius think this is the way it should work ? Have they test this thing with users in home with multiple echo devices and everyone using Elexa in different room listen to different musics then we all go ducking when anyone say Alexa ...

Hello real genius I say -:)
I went mental today in the garden listen to my music then my kids start using Elexa and ducking stop ducking play play ducking arggg hahah
Any updates on Echo Dot responses played thru aux ca le line in and Alexa skills ena led for every Sonos on the network? This is 3 months old. I just got a Dot, and using a hardwired connection disables the Alexa response. Would like to have full voice control of streaming music as well as Alexa responses over the Play5.
Can a room association/pairing between Sonos and Alexa be set up? I have a Sonos device named ‘Kitchen’ and an Alexa device also named ’Kitchen’. When I speak the wake-word I only want an associated Sonos player to duck - not every player. Along the same lines when I ask Alexa to play music I’d like it to assume I mean on the paired Sonos device unless I specify otherwise (but guessing this one at least is an Amazon issue?)