Alexa woes

  • 8 January 2019
  • 17 replies
  • 515 views

Hi, newbie,so be nice..having problems with echo input and sonos5, if i ask it for example to "play radio one to sonos" it works, but if i ask Alexa a question it seems the input is active but i get no sound from it.if i plug it into my Makita radio aux it works fine and i can hear Alexas replies. Any ideas please?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Userlevel 4
Badge +11
We have Echo Dots and the answers from questions we ask come through the dot, not through the Sonos speakers.
Thanks, but the echo input doesnt have a speaker,so i assumed it would use the one it was connected to.
I didnt make it very clear that its connected to the Sonos 5 by cable.
Userlevel 7
Badge +20
Can you 'Disable' the Sonos Skill in the Alexa App as a first and then 'Enable' again. Then please ask 'Alexa, Discover Devices'. Then test with 'Alexa, Play Soft Jazz'
Hi UKMedia, tried that and discovered the Sonos5 went through the connect by cable routine again,tried play soft jazz and nothing. swap cable to makita speaker and its playing soft jazz.
thanks for tring to help.
Userlevel 4
Badge +11
I don't understand. I thought all echo devices contained a speaker.

You have connected the echo to the Play:5 with a 3.5mm jack? If so then you must select Line In on the music source in the Sonos app.
First of all, why would you be using the Line-In when Alexa can play to the Play:5 wirelessly?

Second, if you insist on using it through the Line-In, you must turn on Autoplay for the Line-In. To do this go to More > Settings > Room Settings > (Play:5 room) > Line-In Settings and turn Autoplay to 'On'.
Antevs123

In addition to using and setting the Sonos Play 5 line-in to automatic, like Legnum Nick is suggesting above, as you are using a line-in connection to the DOT, you definitely do not need the Sonos Skill installed, otherwise your speaker will 'duck' it’s audio ... so remove the Skill as its not required when connecting in this manner,
Thanks for all the answers, i thought i would get a better/more reliable connection by using the 3.5mm cable,if there are no advantages i may try it wirelessly.
Ive checked the automatic line in was selected and think it may have been a volume issue as when i asked for volume up a few times i can now hear alexa.(though possible i didnt have line line selected firsthand)
the reason im a bit baffled by this is that i could hear it fine without adjusting volume when the cable was connected to the Makita.all the help is greatly appreciated.
Userlevel 7
Badge +20
I'm not sure but I thought you HAD to have the Echo Input connected to an external speaker via the 3.5mm cable or Bluetooth, as it has no internal speaker. I don't have one so can't test but I'd be interested to know if setting a Preferred Speaker in an Alexa Group is an alternative connection?. Also, on the Amazon web page for the UK it says that Sonos speakers are not currently supported with the Echo Input: https://www.amazon.co.uk/Echo-Input-Black-audio-input-Bluetooth/dp/B07CH6JKW3
Echos have their own internal speaker. It's not high quality, but it is OK for voice replies.
Userlevel 7
Badge +20
Echos have their own internal speaker. It's not high quality, but it is OK for voice replies.

Hi jgatie

The OP has the Echo Input, which has no internal speaker.
Echos have their own internal speaker. It's not high quality, but it is OK for voice replies.

Hi jgatie

The OP has the Echo Input, which has no internal speaker.


Oh! I see now.
UKMedia, that is the impression i was under, 3.5 cable or bluetooth.
Not sure when the info on that Amazon link was uploaded but the input appears to be doing what it should via cable and line-in.
ive done a bit of digging elsewhere and it seems the input will drop the volume for voice if skills is enabled but not for music.
this is where i was struggling.
I feel the solution is that the Sonos needs a bit of a feature upgrade. Something link an 'Echo Input mode' on the 'Line In'. This mode would essentially 'mix' the line in over whatever is playing, rather than a binary 'stream' vs 'input'.

So:
Given an Echo Input plugged into a Play x Line In with the same Sonos unit set as the preferred speaker
And given the Sonos is streaming (regardless of if you initiate this via the Sonos app or the Echo Input)
When the Echo Input outputs to the Sonos Line In (e.g. to talk)
Then the Echo Input is heard over the faded stream

This would mimic the behaviour that the Echo Dot has
I feel the solution is that the Sonos needs a bit of a feature upgrade. Something link an 'Echo Input mode' on the 'Line In'. This mode would essentially 'mix' the line in over whatever is playing, rather than a binary 'stream' vs 'input'.

So:
Given an Echo Input plugged into a Play x Line In with the same Sonos unit set as the preferred speaker
And given the Sonos is streaming (regardless of if you initiate this via the Sonos app or the Echo Input)
When the Echo Input outputs to the Sonos Line In (e.g. to talk)
Then the Echo Input is heard over the faded stream

This would mimic the behaviour that the Echo Dot has
But if you leave echo input cabled to the Sonos speaker line-in and disable the Sonos Skill, it then works exactly like all the other Amazon echo speakers work at the moment... so I can’t see that Sonos would be allowed to make any changes, like you suggest. The answer has to be to simply remove the Sonos Skill from the Alexa App.
I feel the solution is that the Sonos needs a bit of a feature upgrade. Something link an 'Echo Input mode' on the 'Line In'. This mode would essentially 'mix' the line in over whatever is playing, rather than a binary 'stream' vs 'input'.

So:
Given an Echo Input plugged into a Play x Line In with the same Sonos unit set as the preferred speaker
And given the Sonos is streaming (regardless of if you initiate this via the Sonos app or the Echo Input)
When the Echo Input outputs to the Sonos Line In (e.g. to talk)
Then the Echo Input is heard over the faded stream

This would mimic the behaviour that the Echo Dot has
But if you leave echo input cabled to the Sonos speaker line-in and disable the Sonos Skill, it then works exactly like all the other Amazon echo speakers work at the moment... so I can’t see that Sonos would be allowed to make any changes, like you suggest. The answer has to be to simply remove the Sonos Skill from the Alexa App.


I want the true integration with Sonos though, which you only get from the Sonos skill. So I want to control from my Sonos app or z-wave controllers (next track) etc. and, when I use multi-room, I don't want Alexa booming out of every Sonos speaker in my house.

To your point Sonos doesn't need to make any changes to the Echo. The changes would be on the Sonos side entirely. The suggestion is to 'mix' the input channel with the streaming channel (only on the connected speaker). The Echo Input would be completely ignorant of this setup.

Now, whether Sonos can support mixing (maybe a hardware/software restriction), and whether that doesn't raise any other issues, I don't know. I'd leave that to Sonos.
Userlevel 4
Badge +11
Can you not sort the issue by using an Echo Dot rather than an Echo Input? I tell my Dots what I want to listen to on my Sonos, but I don't have them linked with any cables - they act as a controller not a source.