Answered

Alexa will not play music via Sonos

  • 26 July 2018
  • 5 replies
  • 3084 views

Both Sonos One and Echo Dot cannot play music via Sonos speakers. All is set-up correctly, speakers were found by Alexa Sonos skill and named Kitchen and Living. However, when I ask Alexa to play any music in Kitchen or in Living, she replies that she cannot find a device that is able to play music... the funny thing is: it does work occasionally, but fully at random it seems. Maybe once in 30 times or so. I have tried all kinds of resets, new installations, renaming speakers, re-enabling skills etc. Nothing seems to solve the issue. I first thought it might be the Sonos One that was the issue, but then I also got a Dot and that gave the same result. Who knows what this might be?
icon

Best answer by Arjan76 26 July 2018, 23:01

Wow! Indeed it was an authorization issue. I did delete the skills but reenabled them before deleting the devices. I now made sure devices were gone before reenabling sonos skill and got the geographic issue notification. It appeared that in my device settings on amazon.com my location was not yet set to us or uk. Changed it and now it works perfectly!!! Thanks for your help!
View original

5 replies

Userlevel 6
Badge +19
Have you asked her to "Discover Devices"? Then also what Music service are you asking her to play from? Does playing Radio work?
Hi, thanks for your reply: yes i rediscovered devices a couple of times, alexa finds them, that works fine. I use amazon music and also tried tunein radio. Both do not work, and sometimes they do...
Userlevel 6
Badge +19
I'd submit a diagnostic and post the number here then give them a call. this is not a typical issue so sounds like there might be other things going on with your set up
Userlevel 7
Badge +20
Hi

Can you open the Alexa App>Settings>History and ensure that Alexa heard you correctly? If yes, then I suspect this is an Amazon account authorisation issue. Please log out of all Amazon apps on your device, including Alexa. Then log back into the Alexa App and Disable the Sonos Skill in the Alexa App>Skills>Your Skills and then Enable again. Please retest and let us know how you get on.
Wow! Indeed it was an authorization issue. I did delete the skills but reenabled them before deleting the devices. I now made sure devices were gone before reenabling sonos skill and got the geographic issue notification. It appeared that in my device settings on amazon.com my location was not yet set to us or uk. Changed it and now it works perfectly!!! Thanks for your help!

Reply