Answered

Alexa timer commands to a stereo pair

  • 26 April 2022
  • 5 replies
  • 81 views

I was wondering if you could help me with how to Alexa to work properly with a stereo pair of Ones, as it relates to timer commands.

I have got a number of Sonos devices in my home. In my kitchen I have a pair of Ones, configured as a Stereo Pair. One of the devices is called ‘Kitchen’ and the other is called ‘Kitchen 2’ The two devices are configured together into a stereo pair that is also called Kitchen.

If the devices are NOT configured as a pair then I can use Alexa to set a timer on each of them correctly. I simply say, “Alexa, set a timer for 2 minutes on Kitchen,” and it works. Same with Kitchen 2.

However, when I pair the two devices into a pair called Kitchen and issue the same command, I get back an error message from Alexa that says that ‘Kitchen’ is offline. I realize that Alexa is looking for the individual device ‘Kitchen’ and not the group ‘Kitchen’ and that’s probably why things are failing.

Interestingly, if I say ‘Alexa, play music in Kitchen,” the command works fine for the Stereo pair. It just seems to be the timer and alarm commands that have a problem.

Could someone please give me some guidance as to how I can configure this to work properly?

My wife likes to tell the Alexa devices all over the house to set alarms in the kitchen, so trying to figure out how to give that functionality.

Thanks!

icon

Best answer by Paul0521 1 May 2022, 18:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Note there are some problems with Alexa on Sonos at the moment as reported here: 

https://status.sonos.com

However my suggestion (when Alexa is fixed) and if things still do not work for you, then unpair your Sonos speakers and remove Alexa from both. Give it 15 minutes or so and then check that the Amazon Alexa App no longer shows your Sonos Alexa components in its device list. 

You could actually remove them manually and your Kitchen & Kitchen 2 speakers too for that matter. 

I would also remove the Sonos Skill in The Alexa App ‘Settings/Skills & Games’ just for good measure

Next stereo pair your Kitchen and Kitchen 2 speakers first of all in the Sonos App and add Alexa to the stereo pair which will now be called ‘Kitchen’ - that will just create the Alexa Assistant on the left speaker only and should allow you to set a timer without any further errors (hopefully).

Ken, thanks for the suggestions. I will give it a try when the problems between Alexa and Sonos are sorted out and report back. Hopefully that fixes it.

Ken - I did some rather extensive testing and troubleshooting this weekend. I still haven’t gotten it to work, but I now have a lot more insight about what works and what doesn’t work. Here’s what I did -

I initially did what you suggested above. Backed everything out and essentially started from scratch. I also did a factory reset on the two Ones in the kitchen just to be sure.

Unfortunately, same problem.

At that point I assumed that the problem was with the naming of the stereo pair, so I broke the stereo pair and tried various Alexa commands. What I found was that I was not able to set any timer or alarm commands by location name on any Sonos device - i tried it in multiple rooms (different Sonos devices) of my home. 

If I went up to the Sonos One in the kitchen and said, ‘Set a timer for one minute,’ it worked fine. If I went up to the same device and said, ‘Set a timer for one minute on Kitchen,’ it would say, ‘Timer set in Kitchen for one minute. Sorry, there was a problem setting timer in Kitchen because device appears to be off line. Please try reconnecting device.’ I get the same thing happening if I try on any other SonosNet connected device in my house.

Now interestingly, if I give Alexa another location based command that doesn’t involve timers or alarms, things work fine. If I say ‘Alexa, play music in Kitchen,’ Alexa starts the music in the Kitchen (either as an individual speaker or a stereo pair.

Also (and I think that this is significant, but I can’t figures out exactly how) - timer and alarm commands work fine on my Sonos Move, which is connected over WiFi. If I say, “Alexa, start a 10 second timer on Move,” it works just fine … no error message.

At that point I wondered if this was a problem with how Alexa works over SonosNet - I use a SonosNet WM0 configuration in my house, but the Move is on wireless WM1.

To test this I broke the SonosNet configuration and moved everything back to WiFi (WM1). However, even on WiFi, everything exhibited the same behavior - the timer based commands did not work on any device except the Move. So it does not appear to be SonosNet that is causing the problem.

I suspect that maybe it has something to do with the naming conventions - the Move is not associated with a Room in the house, where as all of the other devices are. But that is pure speculation on my part.

Does anyone have any suggestions about what to try at this point. I may just open a trouble ticket with Sonos, point them to this thread and see what they say.

Thanks!

 

 

 

At that point I assumed that the problem was with the naming of the stereo pair, so I broke the stereo pair and tried various Alexa commands. What I found was that I was not able to set any timer or alarm commands by location name on any Sonos device - i tried it in multiple rooms (different Sonos devices) of my home. 

By location name, do you mean the Sonos ‘Room’ Name as it appear in the Sonos App?.. or do you mean the actual physical room they’re located in? Which of course may be different, or the same, but can you perhaps clarify that for me?

Please note too, you likely have Alexa ‘Group’ Names in the Alexa App. Check to see if they are the same name as your Sonos ‘Room’ Names as the ‘Group’ names ‘may’ be the thing causing Alexa some confusion.

In my own case for example, I have a Sonos ‘Room’ Name called ‘Living Room’ (A Sonos Arc/Surrounds) and it’s actually physically located in our ‘Lounge’ area. In the same physical room, I have a stereo pair of Fives called ‘Fireplace’. In the Alexa App the two Sonos ‘Rooms’ (Living Room/Fireplace) are both located in a Group called ‘Lounge’

So Alexa cannot get confused between the room names and the group names.

My thoughts are your problems maybe connected to having the same room and group names.. er .. perhaps🤔?

If I went up to the Sonos One in the kitchen and said, ‘Set a timer for one minute,’ it worked fine. If I went up to the same device and said, ‘Set a timer for one minute on Kitchen,’ it would say, ‘Timer set in Kitchen for one minute. Sorry, there was a problem setting timer in Kitchen because device appears to be off line. Please try reconnecting device.’ I get the same thing happening if I try on any other SonosNet connected device in my house.

Check and see if you have a Sonos device name called ‘Kitchen’ and an Alexa group name also called kitchen and if so, perhaps see what happens if you give that group an entirely different name. 

Now interestingly, if I give Alexa another location based command that doesn’t involve timers or alarms, things work fine. If I say ‘Alexa, play music in Kitchen,’ Alexa starts the music in the Kitchen (either as an individual speaker or a stereo pair.

Alexa is likely intelligent enough here to realise you want to play music on a speaker called Kitchen - rather than the group called Kitchen because you could have a smart-light called ‘Kitchen’ too in that same group and that obviously cannot play a Music source 😀.. so I think that’s why this works. 

Also (and I think that this is significant, but I can’t figures out exactly how) - timer and alarm commands work fine on my Sonos Move, which is connected over WiFi. If I say, “Alexa, start a 10 second timer on Move,” it works just fine … no error message.

At that point I wondered if this was a problem with how Alexa works over SonosNet - I use a SonosNet WM0 configuration in my house, but the Move is on wireless WM1.

To test this I broke the SonosNet configuration and moved everything back to WiFi (WM1). However, even on WiFi, everything exhibited the same behavior - the timer based commands did not work on any device except the Move. So it does not appear to be SonosNet that is causing the problem.

I suspect that maybe it has something to do with the naming conventions - the Move is not associated with a Room in the house, where as all of the other devices are. But that is pure speculation on my part.

Does anyone have any suggestions about what to try at this point. I may just open a trouble ticket with Sonos, point them to this thread and see what they say.

Thanks!

Yes I’m sure it’s nothing to do with WiFi or SonosNet connected devices - this is more likely to do with your ‘device’ names and your Alexa ‘group’ names being give the same name.

As you mention, the Move is not in any group, so that’s likely why you are not getting the problem with that device. At least that’s my initial thoughts.

So my suggestion is to rename your Alexa groups (or remove them if not required) and ensure the group name is different to all your device names. 

In my own Home setup here, all devices and groups in Alexa each have their own ‘unique’ name and I’ve not yet encountered the issue you mention, well not so far, at least..

I hope the thoughts above help you to resolve the matter. 👍 

Ken - thanks for all of your detailed feedback and advice. It was very helpful as I figured out the next steps from a trouble shooting point of view.

After a bunch of additional testing I was able to figure out what the problem is -

Sonos seems to get confused when the elements in a stereo pair are named to the same room as the stereo pair itself is. Once again, this is only a problem with timer and alarm commands. Music commands (Play music in Kitchen) work fine.

When I had two Sonos Ones named Kitchen  and Kitchen 2 in a stereo pair that was named Kitchen, the problem occurred. If I renamed the two Sonos Ones to Dining Room and Dining Room 2, and created a stereo pair called Dining Room I had the same problem. But if I moved the stereo pair to Kitchen while keeping the two individual Sonos Ones named Dining Room and Dining Room 2 then everything worked fine.

I also deleted by Alexa groups, just so that wasn’t another variable in the equation, but I don’t think that it was.

So it sounds as if this is some sort of a Sonos bug, and the work around is to assign the two underlying elements of the stereo pair to a different room to prevent a conflict.

I am going to submit a trouble report to Sonos and reference this thread so that they can look into it further. But at least for now I seem to have found an effective work around that isn’t too difficult to implement or live with.