Answered

Alexa stopped working on beam and will not reactivate


Hi there,

I've been using Alexa on my beam for months with only a few issues. The main issue is sometimes it stops responding to voice until I go into the Sonos app and I remove Alexa voice service in room settings and then just re-add it. That has always fixed it in the past, in a few seconds. A bit annoying, but only every month or two. Tonight, same issue, so I removed Alexa and went to add again. However, it won't add tonight. I've tried from three different devices.

As soon as I press to sign into Amazon, it pauses for a second and then says there was a problem adding Alexa, it doesn't take me to the Amazon login page at all. I've tried restarting, deleting the skill in the Alexa app, deregistering the device from Amazon etc. Otherwise it's working fine as a speaker and TV bar. Even works for streaming when I ask an Amazon echo to play music on it. Just won't enable Alexa its self.

Any one else have this. Wondering if server side as was working fine.

Any ideas?

Thanks
Steve
icon

Best answer by stevebuk 28 June 2019, 11:25

Thank you. I can confirm this is indeed resolved for me now.
View original

14 replies

A friend and I are having the same issue. We just got our Sonos Ones and both of us are getting the “There was a problem adding Alexa” message

Thank you. I can confirm this is indeed resolved for me now.
Having a similar problem. Alexa suddenly stopped working on Beam, can't add it in the app "there was a problem adding alexa" despite multiple attempts at deleting both the Sonos and Alexa apps.

Any ideas?

Alexa stopped working on Beam? The Beam is still working with the tv and I can play pandora for music through it and my Play 1. I think now I have it all messed up. I am selecting and trying different options. I have a Sony 65xbrx900f tv. The tv says I have no devices. Help Please. 

Userlevel 7
Badge +20

Hi

First, can you ensure that the mic is still switched on - please just touch the Mic symbol and ensure the small round light is on.  Then please open the Sonos App>Settings>Services>Voice>Amazon Alexa and make sure that the Beam is shown as Enabled.

I have a SONOS beam that Alexa worked perfectly on until I added 2 x One SL as surround sound. It hasn’t worked since, the mic light isn’t on and doesn’t come on when you touch the mic symbol. The Alexa app says SONOS is offline but I can’t find anyway to bring it online. I deleted and reinstalled the SONOS app and now when I open the app, a page pops up saying ‘we can’t find any products registered to your SONOS account. Let’s register them now’. If I tap on ‘Register your products’ it immediately says ‘Products now linked to your account’. When you then press ‘done’ the page returns saying ‘we can’t find any products registered to your account’. Can anyone help me out here please. Thanks in advance.

Userlevel 7
Badge +20

I have a SONOS beam that Alexa worked perfectly on until I added 2 x One SL as surround sound. It hasn’t worked since, the mic light isn’t on and doesn’t come on when you touch the mic symbol. The Alexa app says SONOS is offline but I can’t find anyway to bring it online. I deleted and reinstalled the SONOS app and now when I open the app, a page pops up saying ‘we can’t find any products registered to your SONOS account. Let’s register them now’. If I tap on ‘Register your products’ it immediately says ‘Products now linked to your account’. When you then press ‘done’ the page returns saying ‘we can’t find any products registered to your account’. Can anyone help me out here please. Thanks in advance.


Do you by any chance have any wi-fi repeaters of multiple wi-fi SSID’s?

Thank you for your reply. Sorry but I’m not particularly computer savvy and don’t have a clue what wi-fi repeaters or wi-fi SSID’s are…  :confused:

Userlevel 7
Badge +20

Hi

 

That probably means no then. :)  Can you open the Sonos App>Settings>Services> Amazon Alexa and ensure that the Beam is shown as Enabled?

Yippee! All working now, thank you so much for your help :relaxed:

Userlevel 7
Badge +20

Great news :)

Userlevel 1
Badge +2

Once again, the latest Sonos app update and latest Alexa app update have broken Alexa’s communication with my Sonos Beam living room setup, which consists of a Sonos Beam, a Sonos sub, and two Sonos Ones as stereo left and right. I have done the usual dance of: removing Alexa's voice from all rooms via the Sonos app, deregistering all Sonos devices from Amazon/Alexa, disabling the Sonos skill, removing Amazon music from the Sonos app, signing out of all Amazon services, signing out of Sonos, signing out of the Alexa app, powering down my phone, restarting my phone, signing in to Alexa, enabling the Sonos skill, signing in to Sonos, and enabling Alexa's voice one room at a time.

 

This returned Alexa service to my single Sonos One in my bedroom and my single Sonos One in my kitchen, but Alexa is still not working on my Sonos Beam setup in my living room. There seems to be a specific problem with Alexa and Sonos Beam. 

 

I have the latest software versions of both the Sonos app and the Alexa app. I do not have network interference from nearby channels; I checked and also Sonos tech support has checked. Whatever is going on needs to be fixed. It seems to be a problem specific to the Sonos Beam and Alexa.  Invariably, it balks at the complicated living room setup and interacting with my Sonos Beam. Please get to the bottom of what keeps causing this issues between the Sonos Beam and Alexa. 

 

I have been in touch with tech support (reached out again today) but dealing with this every two or three weeks is becoming tiresome. 

Userlevel 7
Badge +20

Hi

 

For some reason a PlayBar or Beam with Surrounds sometimes loses it’s Alexa service, I haven’t worked out why.  Can you please open the Sonos App>Settings>Services>Amazon Alexa and ensure that your Beam is shown as Enabled.

As this happens after an update, which involves a reboot of your devices to allow the new Firmware to be installed, I wonder if you have duplicate IP addresses within your Home network.

As a general comment, when trying to resolve Sonos issues with either Alexa or Google and you feel the need to reboot the Router, it is ALWAYS advisable to reboot ALL connected devices within the home.

For those of you reading this that aren't totally clear on how this works, I’ll try and explain below:

  • Each time a new device connects to your Wi-Fi or is plugged into an Ethernet cable, a device (normally your Router) allocates it a unique network (IP) address;
  • Normally this address is in the format of 192.168.0.1 (This specific address is normally reserved for the Router) and then the next device to connect is allocated the next number - 192.168.0.2 and so on;
  • The issue occurs when the Router is rebooted, as the Router then loses any knowledge of the addresses previously allocated and so will start from 192.168.0.2 again;
  • Any devices within your network that have not been rebooted at the same time will continue to use the IP address that they were allocated before the Router was Rebooted;
  • So, an example scenario of a household with 20 connected devices, including 5 Sonos devices would mean that the next device to connect would be allocated 192.168.0.22 and all is stable. However, as soon as the Router is rebooted and the previously allocated addresses are lost, the Router will then allocate 192.168.0.2 to the next device – meaning that there are now two devices with the same IP address within the Network.  If the Sonos devices are then rebooted, these will also be allocated addresses that had previously been allocated before the Router was rebooted and so the problem gets worse;
  • For standalone devices, this can often go unnoticed by the user but for devices that need to communicate with each other (Sonos, Alexa and GA devices) this will cause a lot of seemingly unrelated performance and functional issues;

The ONLY way to resolve this issue is to reboot your network in this order:

  • Router
  • Any wired Network devices or switches;
  • Any other wired devices;
  • All other Wi-Fi devices (Turning Wi-Fi off and on again on each device would also work)

The way that you can reduce the effect of this problem is to reserve an IP address within your Router Set-Up for all permanent devices. This ensures that a device is never just allocated the next IP address that the Router ‘thinks’ is free.  I personally use the range 192.168.0.175 – 192.168.0.244 for my devices that are connected to my network on a regular basis.  This removes the requirement to reboot these devices whenever the Router is rebooted, as they will always be allocated the exact same address and the Router will NEVER allocate this address to another device.

Reply