Answered

Alexa says Spotify is offline when it isn’t...

  • 20 May 2019
  • 9 replies
  • 9429 views

When I ask Alexa to play music on my Sonos one, it says “Playing Elton John (for example) on Spotify. Sorry that device is offline” but it isn’t...I can play Spotify from the Sonos app but not via Alexa. It’s worked fine up until today and I’ve changed nothing.

Any ideas?
icon

Best answer by UKMedia 21 May 2019, 09:40

If the problem persists can you look at this long post:

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
1.4/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.
1.5/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app, select ‘Devices>All Devices'. Now select each Sonos Device in turn and click the Trash Can in the top right of the screen;
3.3/ In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to carry out step 3.8 again.

Let us know how you get on.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +20
Can you open the Alexa App>Devices and check that the Sonos One is on-line? If it's shown as off-line, please power down the Sonos One for 10 secs and then power back on.
Did that - Sonos 1 is showing as online but Alexa still says “this device is offline” when asked toplay something from Spotify
It seems to think Spotify is offline
Userlevel 7
Badge +19
Are you able to play the Spotify content without using Alexa voice commands and instead using the Sonos Controller? This will help to discern if the problem is within the Sonos connection to Alexa and Spotify or if the problem is Alexa relaying the command to Spotify.
Yes, no problem with that at all
Userlevel 7
Badge +20
Hi

Edit:

Can you open the Spotify App and follow these instructions:

Hit the gear icon in the settings. Go to PLAYBACK. In the playback section you should see Equaliser and OFFLINE. Tap the button next to OFFLINE and Spotify should now be online.

If the problem persists, can you open the Alexa App>Settings>Music>Spotify and select 'Unlink Account' then please go through the process of linking the same Spotify account as the one identified as a 'Service' in the Sonos App.
Neither of those worked...
Userlevel 7
Badge +20
Okay, please open the Alexa App in a browser (alexa.amazon.uk or alexa.amazon.com) and select 'Music, Video & Books'. Select Spotify and then your Sonos One in the drop down list at the top of the screen. If you select 'Go to Spotify App' does it take you to the correct Spotify Account?
Userlevel 7
Badge +20
If the problem persists can you look at this long post:

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
1.4/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.
1.5/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app, select ‘Devices>All Devices'. Now select each Sonos Device in turn and click the Trash Can in the top right of the screen;
3.3/ In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to carry out step 3.8 again.

Let us know how you get on.