Answered

Alexa says she is playing "On Kitchen" but no sound comes out

  • 28 January 2018
  • 20 replies
  • 70477 views

Hey there;

I have a house full of echos, dots and sonos speakers. In general, my Alexa Sonos skill is not working well.

For example, I have two Play Ones paired in my kitchen as "Kitchen".

When I say, "Alexa, play Billy Joel in the Kitchen" she says "Shuffling songs by Billy Joel on Kitchen" -- but no music plays in the Kitchen. She thinks she is streaming....

I have deleted all my smart devices, and reinstalled, etc. Not sure where to go from here.

I was hoping you guys might have some troubleshooting suggestions.

Thanks,
Mark
icon

Best answer by Keith N 1 February 2018, 02:52

Hey there, Mark. Thanks for posting. When users describe problems where Alexa goes silent, I recommend checking out this helpful article written up by Edward R that outlines common resolutions for problems with Alexa on Sonos.

If you are still having trouble after going through that article, I'd suggest giving our support technicians a call to troubleshoot this in real time. They are able to walk through alexa.amazon.com with you to ensure Alexa is setup with Sonos properly.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

Userlevel 7
Badge +19
Hey there, Mark. Thanks for posting. When users describe problems where Alexa goes silent, I recommend checking out this helpful article written up by Edward R that outlines common resolutions for problems with Alexa on Sonos.

If you are still having trouble after going through that article, I'd suggest giving our support technicians a call to troubleshoot this in real time. They are able to walk through alexa.amazon.com with you to ensure Alexa is setup with Sonos properly.
Userlevel 7
Badge +20
Hey there;

I have a house full of echos, dots and sonos speakers. In general, my Alexa Sonos skill is not working well.

For example, I have two Play Ones paired in my kitchen as "Kitchen".

When I say, "Alexa, play Billy Joel in the Kitchen" she says "Shuffling songs by Billy Joel on Kitchen" -- but no music plays in the Kitchen. She thinks she is streaming....

I have deleted all my smart devices, and reinstalled, etc. Not sure where to go from here.

I was hoping you guys might have some troubleshooting suggestions.

Thanks,
Mark


Hi Mark

In addition to Keith's comments, this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Thank you - I will try these steps when I get home.
Badge
Ok so today I have no BBC radio 2 or 5 playing on my Sonos One via Alexa or tune in - any clues? Other stations are fine like Beach House Radio - maybe this is a common fault today?
Userlevel 7
Badge +20
Ok so today I have no BBC radio 2 or 5 playing on my Sonos One via Alexa or tune in - any clues? Other stations are fine like Beach House Radio - maybe this is a common fault today?

There is an Amazon-TuneIn issue I believe.
Userlevel 3
Badge +4
Ok so today I have no BBC radio 2 or 5 playing on my Sonos One via Alexa or tune in - any clues? Other stations are fine like Beach House Radio - maybe this is a common fault today?I had this but it’s fixed now. Do you still have the problem?
Badge
Yeah it's fixed! Just checked - having given up and using Sonos-only lol
Badge
Hey UK,

trying this on Play 1's, so step 3.3 isn't showing for me.
ANy suggestions?


3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.[/quote]
Badge
Using 2 Play 1's and a Playbase,
Following the instructions below, and the 3 devices show up upon Power-up, so i dont have the ability to Re-register the devices.

Thanks again.

Hey there;

I have a house full of echos, dots and sonos speakers. In general, my Alexa Sonos skill is not working well.

For example, I have two Play Ones paired in my kitchen as "Kitchen".

When I say, "Alexa, play Billy Joel in the Kitchen" she says "Shuffling songs by Billy Joel on Kitchen" -- but no music plays in the Kitchen. She thinks she is streaming....

I have deleted all my smart devices, and reinstalled, etc. Not sure where to go from here.

I was hoping you guys might have some troubleshooting suggestions.

Thanks,
Mark


Hi Mark

In addition to Keith's comments, this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Badge
Disregard previous post. Solved. Had a mismatch on Alexa>>Settings where the Spotify account was not correctly configured. All good.
went for level 3 reset, no joy.
I had this problem with a stereo pair of Ones. I tried the UkMedia’s steps and that didn’t fix the problem. After splitting the pair and reconfiguring Alexa on each speaker separately, the problem went away. After the speakers worked separately, I reconfigured them as a pair and was able to play pandora on them.
Hey there;

I have a house full of echos, dots and sonos speakers. In general, my Alexa Sonos skill is not working well.

For example, I have two Play Ones paired in my kitchen as "Kitchen".

When I say, "Alexa, play Billy Joel in the Kitchen" she says "Shuffling songs by Billy Joel on Kitchen" -- but no music plays in the Kitchen. She thinks she is streaming....

I have deleted all my smart devices, and reinstalled, etc. Not sure where to go from here.

I was hoping you guys might have some troubleshooting suggestions.

Thanks,
Mark


Hi Mark

In addition to Keith's comments, this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.


Thanks - just unlinking and relinking the skill worked for me. I was having the issue where Alexa was stating something was playing on one of my two Sonos devices but in reality there was radio silence. This was across two Sonos spekaers and multiple Alexa devices.

Thinking about it I wonder if this was caused when I changed my language Amazon Spot speaks from (for a bit of fun setting it to US English, then to Canadain English (dreadful accent sound) and then back to UK English (if you haven't tried a different setting it really does make a difference in terms of what commands are picked up on - or rather aren't!).

As a sidepoint another thing I noticed when Alexa's voice was set to US was BBC radio stations are played via tuneIn on the actual Alexa device (like they are on when streamed via Sonos) rather than the BBC skill.
Hey there;

I have a house full of echos, dots and sonos speakers. In general, my Alexa Sonos skill is not working well.

For example, I have two Play Ones paired in my kitchen as "Kitchen".

When I say, "Alexa, play Billy Joel in the Kitchen" she says "Shuffling songs by Billy Joel on Kitchen" -- but no music plays in the Kitchen. She thinks she is streaming....

I have deleted all my smart devices, and reinstalled, etc. Not sure where to go from here.

I was hoping you guys might have some troubleshooting suggestions.

Thanks,
Mark


Hi Mark

In addition to Keith's comments, this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.



Thanks, I followed steps 1 and 2 and it fixed it for me. I wonder though if that is a permanent fix of is it just a temporary workaround and this issue can return at some time?
Userlevel 7
Badge +20
Section 2 is a set-up only task, Disabling the Sonos skill can be required sometimes if there is a major Alexa or Sonos Skill update, I've only had to do it once in 12 months.
Userlevel 7
Badge +22
Also on side not: as someone who always had difficulty with the "in kitchen" part of the command and like how with the Sonos One you don't have to say the "in kitchen"

Recent Alexa update has option to set a sonos speaker as the default music speaker. It must still not be official as Sonos hasn't mentioned it.

But go in and create a smart group in Alexa app with your Echo device in Kitchen. Then it will have a setting for default music speaker and you can set the Sonos Kitchen unit. Then you don't have to say "in kitchen" anymore to send music to the Sonos speaker.

Its not 100% yet - so I think that is why Sonos hasn't said anything about it (but Amazon included it in their latest update).
Userlevel 7
Badge +20
Also on side not: as someone who always had difficulty with the "in kitchen" part of the command and like how with the Sonos One you don't have to say the "in kitchen"

Recent Alexa update has option to set a sonos speaker as the default music speaker. It must still not be official as Sonos hasn't mentioned it.

But go in and create a smart group in Alexa app with your Echo device in Kitchen. Then it will have a setting for default music speaker and you can set the Sonos Kitchen unit. Then you don't have to say "in kitchen" anymore to send music to the Sonos speaker.

Its not 100% yet - so I think that is why Sonos hasn't said anything about it (but Amazon included it in their latest update).


Yes this works 100%. I still create the Sonos device with Kitchen in it but then create a Kitchen group containing Kitchen Echo Dot, Kitchen Sonos and any Kitchen smart devices. The reason for this is that I personally still like to create unique names at the device level and with the new preferred speaker option, you don't need to use the longer name in the command.
Userlevel 7
Badge +22
My Echo Show for some reason every once in a while will default to its own speaker playing music - so still some bugs but in general great.
Userlevel 7
Badge +20
My Echo Show for some reason every once in a while will default to its own speaker playing music - so still some bugs but in general great.

Agreed. e.g. If I ask for BBC Radio 2, it doesn't use the Preferred Speaker and outputs on the Echo Dot but if I ask for BBC Radio 2 from TuneIn it outputs correctly.:?:?
My problem was that I originally had an account at amazon.com (US),
and then on amazon.com (US) I subscribed to Amazon Music in GBP Pounds using a UK address and UK creditcard.
My Sonos One speaker kept saying "Your amazon music marketplace is not configured correctly for this device", because alexa.amazon.com (US) didn't want use my UK Amazon Music subscription.
I fixed the problem by transferring (moving) my UK Amazon Music subscription to the UK website, and from alexa.amazon.COM to alexa.amazon.CO.UK

How to transfer your Amazon account between the US or UK, ".COM" or ".CO.UK" , a different Amazon Marketplace (different Amazon country),
Go to www.amazon.co.uk/mycd if you want to move your Amazon music account from UK to US,
or www.amazon.com/mycd if you want to move your Amazon music account from US to UK,
click on Preferences,
Under "Country Settings" click on "Change your country", click the "Change" button,
change the country to UK or US, this country should be the same country as your Amazon music country, so select country US if your Amazon music account is subscribed in US$ dollars, or select country UK if your Amazon music account is subscribed in UK pounds,
click the "Update" button.
Wait 10 minutes for your Amazon account to be transferred to the different Amazon Marketplace.
It is not possible to transfer Amazon.co.jp (Japan) or Amazon.cn (China) account to another marketplace.

Enable the "Sonos skill" by going to one of the websites below
UK Amazon Music account: https://www.amazon.co.uk/Sonos-Inc/dp/B072ML3N6K/
US Amazon Music account: https://www.amazon.com/Sonos-Inc/dp/B072ML3N6K/
Allow popup's on the above webpage because a popup webpage will then ask you to sign into your Sonos account, to link the "Sonos skill" with Alexa.

Unplug your Sonos One speaker for 10 seconds then plug it in.

Open Sonos App on your phone, click "More", click "Voice Services", click "Amazon Alexa",
click "Add to Sonos", click "connect your Alexa account", then your phone's internet browser should open and then click "Allow", Alexa will say "Hello" on your Sonos One speaker, click "Continue" on Sonos app.

Using a supported browser on a PC or Mac, go to alexa.amazon.co.uk or alexa.amazon.com, whichever one has your Amazon Music subscription, sign in, click on "Settings", click on "Music & Media", click on "Amazon Music", your Amazon Music account should already be linked, else follow the steps to link Amazon Music to Alexa.

The following will be transferred to a different Amazon marketplace (different Amazon country):
Kindle books, Audible audiobooks, Amazon Music, Amazon Prime.

The following will NOT be trasferred:
Gift cards (US$ gift card will not transfer to amazon.co.uk),
Appstore games
Prime Video rentals or purchases
Newsstand and magazine subscriptions from the Kindle Store
Kindle Unlimited
Amazon Household and Family Library profiles
Reference: https://www.amazon.co.uk/gp/help/customer/display.html?nodeId=201248840

It might be a better option for some people to have separate accounts for Amazon US & UK.
Just remember which Amazon account has Amazon Music, and enable the "Sonos skill" from the Amazon account with Amazon music.
I think you need a US creditcard to subscribe to Amazon Music in US$, and you need a UK creditcard to subscribe to Amazon Music in UK pounds. Your Amazon Music country, your creditcard's country, and your Amazon billing address country all need to be the same country.