Answered

Alexa responds but will not play music

  • 25 November 2017
  • 22 replies
  • 117760 views

Userlevel 1
Alexa responds to a 'play music command' but it does not actually play anything. The Sonos One works fine from the app. Alexa also will tell you the weather etc... just fine. When music is playing if you ask Alexa to turn off music it says 'I can only do that when music is playing' . Alexa connects to tunein and my amazon account but doesn't end up playing anything even though it says it is.
icon

Best answer by novasupra 26 November 2017, 16:49

Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

Moderator Note: If the information listed here did not resolve your issue, try this topic: Resolving the Majority of Issues with Alexa on Sonos
View original

22 replies

Userlevel 1
Sorry, one thing to add, 2 weeks ago when we set up the Sonos One / Alexa system, Alexa worked perfectly.
I have the same issue. I can ask my dot in the bedroom to play music in the living room(sonos one) and it will work but when i ask alexa on the sonos one to play on itself or to play on the dot the above happens.

Please advise
Userlevel 1
I'm having this issue too. Alexa was working fine, now when I ask to play the radio or Spotify, it will reply "playing radio from tunein" but nothing plays. It will respond correctly for the weather or radio and I can still play music if I initiate it from the app.
Userlevel 1
Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

Moderator Note: If the information listed here did not resolve your issue, try this topic: Resolving the Majority of Issues with Alexa on Sonos
Badge
Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

thanks! that worked for me too!!
I had to disable and enable Sonos from the alexa app. Let alexa discover it and started working. Thsnk you to Nora
Hahaa it actually worked. Thanks for helping me out
Badge
Boom, fixed my issue I came here to research...bye ;)
Thanks so much. This has been frustrating me for a while now. Did make the time to get it resolved until now. I thought I had it fixed once with a power cycle. Didn’t last.
This worked for me..disabling the sonos skill and then enabling. Thank you
Hi im having the same issue. Does anyone have a step by step instruction on how to disable sonos in the alexa app. I have done different things on the alexa app and I still have the same problem.
Userlevel 7
Badge +20
Hi im having the same issue. Does anyone have a step by step instruction on how to disable sonos in the alexa app. I have done different things on the alexa app and I still have the same problem.

Open the Alexa App>Skills>Your Skills and scroll down and click on the Sonos Skill. Click on Disable Skill and then return to All Skills and search for the Sonos skill and select Enable Skill. Let us know how you get on.
I'm getting the same issue in the latest of the debacles that is the sonos one. I've had to reset my system so many times its infuriating - either because of the dreaded "hmmm you need to enable..." or this issue. I've followed the steps above to no avail. It seems as if Sonos simply aren't capable of getting the Sonos skill to work properly, because every update causes issues.

I'm so close to just sending the one back and going for something else entirely. How well does Google Home work with Sonos?
Soooo, after my frustration this morning, I decided to give this one more go...and think I have found a solution - for my system at least.


Alexa won't play music if there is anything in your queue on the sonos app. Deleted this and it started working - didn't need to disable or enable the skill or do a hard reset. This was the only thing I changed.

So either this is the issue, or my Sonos decided to spontaneously work - neither is a particularly positive reflection on Sonos however!
Badge
Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

Yes. It worked for me.

Jim T
Thanks Badback, this worked for me too, ...briefly! While i was typing this reply I lost control of Amazon Music. Now nothing in my queue to delete and Alexa can’t control my music.
I’ve tried both (enabling and disabling the skill + emptying the queue) but can’t get it to work. Had it working for a week perhaps. I recently upgraded the iOS device with the Alexa app to iOS 12. Can this be related? (I realize everybody else in this thread was having problems before the iOS 12 release, but they managed to get Alexa working again).
Hey everyone I just fixed my issue. Originally I was told to delete the sonos and Alexa apps, reboot my sonos, etc but neither fixed the problem. Saw another post that said to disable the sonos skill in the Alexa app and reenable it. This worked! Hope this helps you guys too!!

Thanks! so much...I've been fighting this for a few weeks, and had almost given up. This fixed my issue immediately! 🆒
I had the same issue "Alexa responds but will not play music" then i deleted the sonos skill from the Amazon Alexa App and then i enable the skill back in the amazon alexa app and it was able to discover all my sonos and now i can finally play music from all my music services on the sonos speakers using alexa. 😃
I tried disabling and enabling Sonos skills but it didn't work. I had setup a preferred speake but disabled it and Alexa does now play music from Spotify
Userlevel 7
Badge +20
I tried disabling and enabling Sonos skills but it didn't work. I had setup a preferred speake but disabled it and Alexa does now play music from Spotify


Preferred Speaker settings shouldn't impact Spotify play back. Please see this guide for setting up Alexa Groups: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788

Sorry for the long post but Alexa issues normally fall in to three categories:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
1.4/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.
1.5/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app, select ‘Devices>All Devices'. Now select each Sonos Device in turn and click the Trash Can in the top right of the screen;
3.3/ In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to carry out step 3.8 again.

Let us know how you get on.
Obviously when I tried to set up a preferred speaker I did'nt do it correctly.. as soon as I removed preferred speaker Spotify played through Sonos speakers. I won't bother trying to set up preferred speakers, it's not worth the hassell. Thanks for the explanaintion.

Reply