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Alexa only playing one song through Sonos then STOPS


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39 replies

Ryan S
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  • Retired Sonos Staff
  • 12372 replies
  • December 6, 2017
Hi guys, we're still looking into this and are working to improve the Alexa skill constantly, but there isn't yet a single cause to this error. We'd love to look into it with you, so if you consistently have this issue, I'd suggest that you give us a call on our support line. That way we can get a good look at what's going on.

The steps going around to disable the skill and remove devices helps in some cases. Also, it's good to make sure that you Sonos devices are all set up using the right Amazon account, sometimes you might have multiple Amazon accounts logged into your mobile device which can cause setup issues.

UKMedia
  • 5124 replies
  • December 6, 2017
Please see the steps I've listed in the answer to this post which defines a total reset of Voice Control actions:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239

  • Contributor I
  • 3 replies
  • December 7, 2017
I just connected my Dot to our Prine Account. Alexa recognizes my Amazon Music Playlist but only plays the first song. There are 200 songs in the playlist.

  • Lyricist I
  • 2 replies
  • December 19, 2017
I'll try the fix. Most annoying. It's the old 'power on and off or delete app' trick then. Nothing changes in techland does it?

  • Lyricist II
  • 4 replies
  • December 24, 2017
Ryan S wrote:
Hi guys, we're still looking into this and are working to improve the Alexa skill constantly, but there isn't yet a single cause to this error. We'd love to look into it with you, so if you consistently have this issue, I'd suggest that you give us a call on our support line. That way we can get a good look at what's going on.

The steps going around to disable the skill and remove devices helps in some cases. Also, it's good to make sure that you Sonos devices are all set up using the right Amazon account, sometimes you might have multiple Amazon accounts logged into your mobile device which can cause setup issues.
Alexa and Sonos was a huge fail. Nothing but issues. After buying 3 of these things, I really feel ripped off. I'm not going to be on the phone for an hour again trouble shooting the problem, what a waste of time and money. Listening to music shouldn't be so difficult.

UKMedia
  • 5124 replies
  • December 24, 2017
I believe this is an Amazon Account authorisation issue which is being worked on by Amazon. Try the simple steps I've listed in this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-alexa-issues-6796539/index1.html#post16180399

  • Lyricist I
  • 2 replies
  • December 28, 2017
Returning my Sonos One because of this. i feel like I was ripped off. Tempted to return all of my Sonos devices and just go with Bose. This is ridiculous. Wasted my Christmas break with this crap.

UKMedia
  • 5124 replies
  • December 28, 2017
smalaveetil wrote:
Returning my Sonos One because of this. i feel like I was ripped off. Tempted to return all of my Sonos devices and just go with Bose. This is ridiculous. Wasted my Christmas break with this crap.


Or you could detail your Sonos setup and the exact problem and we could try and use some of our Christmas break time to help you sort your problems out....

  • Lyricist I
  • 1 reply
  • December 30, 2017
I have the same "1 track plays and stops" problem. I've now done the reset (Alexa web app: remove Sonos device and add back), and it has fixed the issue in short term testing.

  • Contributor I
  • 5 replies
  • February 3, 2018
I'm having this issue as well. I disabled the Sonos skill in the Alexa app, then re-enabled, added my devices again, etc. It seems this is a known problem for at least three months now, and still no solution, Sonos? Diagnostics no. 8449376.

UKMedia
  • 5124 replies
  • Answer
  • February 4, 2018
Please look at the steps I've listed within this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/alexa-says-she-is-playing-on-kitchen-but-no-sound-comes-out-6800126/index1.html#post16201009

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  • Author
  • Trending Lyricist I
  • 15 replies
  • March 9, 2018
SOLVED
The issue was this:
When setting up the SONOS Bar we chose the living room for its name ID. Alexa had the living in a living room group
The Alexa software seems confused by the matching names.
Changed Sound Bar Group to TV room and Alexa streams on TV room now.
The only way I can get both SONOS Groups to play together is by grouping them is SONOS App
but I can work with that.

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  • Author
  • Trending Lyricist I
  • 15 replies
  • March 12, 2018
This issue not solved. Sorry...The steps above to rename the SONOS rooms from the SONOS Desktop App only seems to be a short-term workaround.

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  • Author
  • Trending Lyricist I
  • 15 replies
  • March 23, 2018
Here is what corrected my issue:

RESOLVED:

Symptom::
Alexa only pays one song then stops. Duplicate Device Queues are being created in the Now Playing Dropdown list in the Now Playing screen of the Alexa App.

Cause:
A 2nd Amazon user account in the Setting-->Alexa Accounts--> HouseHold Profile.

Solution:
Removing the additional family member accounts from the Household Profile screen.
(Setting-->Alexa Accounts--> HouseHold Profile.)

Thanks for letting me help troubleshoot
Doug G

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