Answered

Alexa no longer working with Sonos

  • 10 August 2021
  • 49 replies
  • 2235 views

Userlevel 3
Badge +2
  • Trending Lyricist II
  • 28 replies

After working fine for ages commands to Alexa for a Sonos Play:1 now just come back with “Sorry I’m having trouble, please try in a little while”

Ive tried all normal fixes, remove/re-discover the Sonos device, disable/re-enable the Sonos skill, restarted the Sonos and even factory reset the Echo Show.

icon

Best answer by jwsg 11 August 2021, 13:05

View original

49 replies

Userlevel 1

I am having the exact same issue had worked fine for months on Beam & One.

I asked it to play Magic FM London the other night which it did but at some point during playback it developed the same "sorry I am having problems right now fault" and wouldn't turn it off so had to use the Sonos S2 app instead.

As you said tried disabling skill, removing Alexa and relinking and it even plays the Hello Alexa welcome message on all Sonos devices to show its set up but has the same issue on all devices.

Userlevel 1

Have same problem here in the Midlands UK. Just spoken to Sonos and there is an issue between sonos and Alexa. Apparently the development engineers from both are working on it. Sonos told me they would post someting about it on here and any resolution in due course.

Userlevel 1

That's good to hear something is being done about it.

 

Shame Sonos never updated there service status page as I checked that first and its been a problem since at least yesterday.

Userlevel 3
Badge +2

It did seem like a cloud issue (such as the skill not keeping up with anAPI change) Maybe EU servers but if Sonos aware then should get fixed.

Same issue here started last night, Sonos Play 1 Gen 2. 
Is it fair to say they are aware and working on it? Annoying how these things can go wrong, wasted hours on this today. Not impressed. 

Userlevel 3
Badge +2

I’m afraid as systems get more complex, testing seems to be getting less and less. If they are working on it, and if they have a fix, then that might be released at around the same time of day as they broke it - but in any case we’re powerless beyond posting on forums or social media or raising tickets.

Ive noticed a post on Amazon from a Bose 300 owner getting the same error in the last day.

I noticed if you set up Google voice you have the same problem.

 

Any timeline to resolve the Alexa problem? 

Userlevel 1

Same here with all my Sonos devices: 2 Ones 2nd Gen, Beam, Arc.

Lost 2 hours messing with the Alexa app, Sonos app and Amazon settings.

So pleased I have found this forum.  Same problem with Alexa.  I spent all day yesterday trying to fix it!

Glad it’s not just me.  Thank you to those that reported the issue to Sonos.  I was just about to start trying all sorts of things to fix it.  I guess I will now wait.   Enjoy your day. 

same here, though now I’ll stop wasting my time trying to fix it!

+1

Started last night...commands would not work.  Alexa through Sonos is my voice gateway to a fully automated home.  Cost me an hour this a.m. looking for the issue and rebuilding the system.

Give they can send push notifications...one would think they would have proactively advised their users of an issue.

Me too here in Devon

Me too, Wrexham.

Userlevel 3
Badge +2

It does appear to have been picked up by Sonos

https://status.sonos.com/

Alexa Voice Control - Playback Failure

Update - We are continuing to investigate this issue.
Aug 10, 20:52 UTC

Investigating - We are currently investigating this issue.
Aug 10, 20:52 UTC

 

And on https://uk.amazonforum.com/

I'm sorry you're experiencing this issue with your Alexa enabled Sonos device not responding to commands.

Our technical team is aware of this issue and actively working toward a resolution.

Wow, I’m glad I found this page :smiley: - same experience in London! :rolling_eyes: Thought I was going nuts….Alexa is generally how I control my Beam.  Oddly she occasionally has lapsed and done something simple like set a timer but generally is ‘having trouble’.  The Alexa app will show the song playing and allow me to skip tracks but is also giving me ‘having trouble’ messages….let’s hope they sort this quickly- I won’t waste any more time trying to fix it at least.

Wow, I’m glad I found this page :smiley: - same experience in London! :rolling_eyes: Thought I was going nuts….Alexa is generally how I control my Beam.  Oddly she occasionally has lapsed and done something simple like set a timer but generally is ‘having trouble’.  The Alexa app will show the song playing and allow me to skip tracks but is also giving me ‘having trouble’ messages….let’s hope they sort this quickly- I won’t waste any more time trying to fix it at least.

Just saw this on the service status page from noon: 

Alexa - Functionality Issue

Identified - We've identified a problem with Alexa on Sonos and are working with them on a fix. You may not be able to use voice commands until it’s resolved.
Aug 11, 11:57 UTC

Wow, I’m glad I found this page :smiley: - same experience in London! :rolling_eyes: Thought I was going nuts….Alexa is generally how I control my Beam.  Oddly she occasionally has lapsed and done something simple like set a timer but generally is ‘having trouble’.  The Alexa app will show the song playing and allow me to skip tracks but is also giving me ‘having trouble’ messages….let’s hope they sort this quickly- I won’t waste any more time trying to fix it at least.

Just saw this on the service status page from noon: 

Alexa - Functionality Issue

Identified - We've identified a problem with Alexa on Sonos and are working with them on a fix. You may not be able to use voice commands until it’s resolved.
Aug 11, 11:57 UTC

Is it still??

Yip same here, been having this issue since yesterday morning. Good that it has been picked up and hopefully fixed soon.

So glad I found this too. Driving me mad. I was even on the Amazon chat earlier and I have sent back my Echo Show 8 as they couldn't diagnose it so sending me a new one. Let’s hope it gets sorted ASAP as it’s the main feature I use Alexa for is playing music.

Userlevel 3
Badge +2

The error message is so poor I did a factory reset of a Show 5 which simply brought back the old gremlins of unwanted Home screen content appearing. As nice as it is for Amazon to replace the unit they’d be better off investing in testing and diagnostics.

If you have an Alexa device using Sonos as a speaker take sonos out the group and Alexa will work again, it doesnt like sonos speakers until its fixed

Same in USA

I am having the same issue on both of my Play Ones

Reply