Answered

Alexa mutes speakers

  • 7 October 2017
  • 43 replies
  • 6273 views

Userlevel 2
So, I'm upstairs in the shower listening to my morning podcast and it mutes itself every 10 seconds.

Come to find out my wife was in the kitchen using Alexa to make a shopping list.

How do I turn off this muting "feature" for Alexa? Or can I assign the dot to a single room so the whole house doesn't mute everytime someone wants a knock knock joke or the weather.
icon

Best answer by Ryan S 9 October 2017, 18:35

As MikeV said, the volume "ducking" will happen on all players across your system, grouped or not grouped. The only ones which shouldn't duck are those playing TV audio. That said, we're doing some more work on the ducking feature and will continue to improve the entire integration over time. You can expect to see the Alexa skill continue to adapt and move quickly. Thanks for the feedback guys!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

43 replies

Userlevel 6
Badge +8
I’ve just deleted the Sonos skill, as the API just isn’t ready. Sonos isn’t really usable if you have Alexa and multi-zones set up. Hopefully it will get fixed soon and then I can re-enable the skill. I’d rather control it the old fashioned way than put up with the ducking feature.

Same here.
Has this ducking issue been addressed? It makes Sonos unusable when someone is using Alexa in another room.
Userlevel 7
Badge +22
NO it is no different. If you don't want a speaker to duck you have to disable voice control on that speaker.
Badge
We have two Sonus systems and four echo dots in the house and this dipping feature is driving us nuts. What can’t a Sonus system be associated to a particular echo system, so that only commands to that echo dot dip the Sonus? It can’t be that difficult to do?
We have two Sonus systems and four echo dots in the house and this dipping feature is driving us nuts. What can’t a Sonus system be associated to a particular echo system, so that only commands to that echo dot dip the Sonus? It can’t be that difficult to do?

Why? Because Amazon has not finished their SDK for multi-room 3rd party speakers. It is expected in early 2018. And I would hesitate before calling anything easy. "Easy" is an extremely sliding scale in the world of software engineering. You would be surprised at the "easy" things that are actually quite difficult.
Userlevel 7
Badge +22
Sonos has said they want to do it so when they can they will.
Badge
We have two Sonus systems and four echo dots in the house and this dipping feature is driving us nuts. What can’t a Sonus system be associated to a particular echo system, so that only commands to that echo dot dip the Sonus? It can’t be that difficult to do?

Why? Because Amazon has not finished their SDK for multi-room 3rd party speakers. It is expected in early 2018. And I would hesitate before calling anything easy. "Easy" is an extremely sliding scale in the world of software engineering. You would be surprised at the "easy" things that are actually quite difficult.
Badge
With thirty years developing systems and software, I fully understand that one persons “easy” isn’t always as easy as it appears, but I also know that you need to let people know the limitations of what you’ve released. If a release only supports a single echo and Sonus then it should be in the release notes.
It's Sonos. And it simply isn't true that the system "only supports a single Echo and Sonos". I have two echos and 8 Sonos devices and I can control them all just fine. Sure the ducking happens on all of them when I say the wake work but, knowing it's a Beta skill, I can patiently wait for the new SDK.
Badge
If it dips the volume on all Sonus systems then it’s not a true multi room system. (If you don’t use the echo skill you don’t get this behaviour) If your happy with the dipping issues then enjoy, but for many of us it’s not a good experience, which is reflected by the amount of people saying they’ve removed the Sonus skill from their Echo systems.
It's SONOS! SonOs!

And yes, the ducking happens on all speakers. That may mean an unenjoyable experience for some, but it most certainly does not mean you cannot use Alexa to control a true multi-room music system.

"Alexa, play smooth jazz in the kitchen."

"Alexa, play The Bridge from SiriusXM in the master bedroom".

^^^See, I just did it. Music, in multiple rooms, via Alexa.
Userlevel 2
Badge +2
I have multiple Sonos and Echo devices in two locations, in different states. Because they utilize the same accounts, a question to Alexa in Arizona will duck my Sonoses in Washington state.
Badge +1
My system has stopped dipping the volume when using Alexa. I'm not quite sure when it stopped, maybe a couple of weeks ago. We have a 9 zone Sonos system, with 2 Ones, and 3 Amazon Alexas, so safe to say this problem was driving us nuts. It does mean that if we have a music on loudly, Alexa doesn't hear us, but I'd rather live with that than having all the speakers dip just because someone uses an Alexa in the kitchen.
Badge
I'm experiencing the same problem which is made worse because of multiple users. Previously I had an echo dot sitting next to my play 5 to experiment with Alexa and Sonos. Alexa would mute all speakers but I never really noticed or cared. I purchased a Sonos One and since I didn't have a use for the dot I gave it to my son for his room. Mistake. Whenever he interacts with his Alexa it mutes sound everywhere but when he tries to play music through his dot it has an impact on other Sonos zones and changes what is playing elsewhere (he isn't using any Sonos room name, etc). My solution will be to unplug his dot until the APIs mature and hope this improves with time...price of being on the cutting edge.
Userlevel 7
Badge +22
Hit Dot shouldn't mute the Sonos One. You can disable the Alexa skill on the rest of the Sonos speakers in your house and his dot will not effect them.
I just setup two Sonos One, Playbase (with optical cable) and Sub. I have the same ducking problem (across the whole home theater setup) whenever someone on the TV actually says something, which is really quite annoying because the word "Alexa" is not even said on the TV. Do I need to figure out how the playbase should actually continue to play sound without ducking?
Just came across this because my system suddenly started dropping audio - realised the birthday gift for my parents has ruined my Sonos! Every time they use their Alexa (tied to my Amazon for Prime music) I lose volume. Sonos should toggle this option as I only use a dot right next to me for voice control - which I hardly use for sonos