Alexa Multi-room Music / Audio Groups

  • 25 November 2017
  • 64 replies
  • 50461 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

64 replies

Userlevel 7
Badge +20
This used to work great and I did this all the time (made a group in Sonos and told Alexa to play music on any speaker in the group and the whole group played). Suddenly this stopped working. Now Alexa ungroups the Sonos groups when you direct music to one speaker. Ugh!!!!!!

Hi

This is easy to fix. Please open the Alexa App>Smart Home>Groups and create an Alexa Group for each Echo device, I call them the room name. Then add the Echo & Sonos devices that you want to have music on when music is initiated from each specific Echo device and then set these Sonos devices as Preferred Speakers. Now ask Alexa for your music and it will group the Speakers in the Sonos App and output to that group.

Edit: I case you are wondering why this solution will work, Amazon have recently released an upgrade which means there is now support for 3rd party speakers via the Preferred Speaker setting. Prior to this Sonos did not support Alexa Groups. I don't think this option is available in all countries yet but if you get the issue of Alexa breaking Sonos Groups then please try the above.
Badge
I tried this and it does not work. I set up a group in alexa with my living room echo and patio sonos one and called the group downstairs. When i tell alexa to play "todays hits on pandora downstairs" she replies that she can't do that yet and to set up multi-room music.
Userlevel 7
Badge +20
Hi

I've tried to explain in greater detail in this post: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788
Thanks UK Media. It does seem a rather clunky way of making it work, but thanks for your guide above. Finally got there. Basically it seems you have to have a separate Alexa device per group that you want. So if you want an upstairs, downstairs & everywhere group, you’ll need three Alexa devices as far as I can see.

Now all we need is the “turn audio off” option in a routine to turn Sonos music off.
Thanks UK Media. It does seem a rather clunky way of making it work, but thanks for your guide above. Finally got there. Basically it seems you have to have a separate Alexa device per group that you want. So if you want an upstairs, downstairs & everywhere group, you’ll need three Alexa devices as far as I can see.

Now all we need is the “turn audio off” option in a routine to turn Sonos music off.


No. You can have a group with no assigned Alexa device. I have a bedroom Echo assigned to the Bedroom group, a living room Echo assigned to the Living Room group. But I also have a group of all downstairs speakers called Downstairs, , all upstairs speakers called Upstairs, and all speakers in a group called Everywhere. They have no entry for the Alexa device.

To play music in the bedroom, i simply tell the bedroom Echo what to play. It defaults to the bedroom. Same with the living room Echo. To play upstairs, I add "upstairs" to the command. Same with the downstairs and everwhere.
Strange I tried an upstairs group, a downstairs group and an everywhere group. I can only get the groups to work if I have one of my echo dots associated with each group (I have play 1s). If I try to set up a group with just sonos speakers and no echo, it just doesn’t work and only plays on one of the “preferred devices” in the group
You do have to make all of the speakers in the group preferred. But there is no need to assign an Alexa device.
I tried again. It worked. Then I stopped the music and asked it to play on another group. It just played on one speaker outside of the group. So it’s obviously still very intermittent and buggy.

In fact further playing around with it seems to be that it just wants to play off the last speaker no matter the grouping. Frustrating seems to only work correctly occasionally
Yeah, it does seem to be a work in progress.
Userlevel 7
Badge +20
I tried again. It worked. Then I stopped the music and asked it to play on another group. It just played on one speaker outside of the group. So it’s obviously still very intermittent and buggy.

In fact further playing around with it seems to be that it just wants to play off the last speaker no matter the grouping. Frustrating seems to only work correctly occasionally


Are you including the Group Name in the command as per scenario 2?

There is a further piece of information over and above the Post I referenced: If any of the Preferred Speakers in a Group are already Grouped within the Sonos App, this grouping is NOT broken and the new command will create a Group of the old Rooms and the new rooms.
Yes was including the group name. But I was trying going from playing “everywhere” to playing “upstairs” so makes sense about the grouping not being broken. So still makes it a bit clunky. But as someone else said it seems to be very much a work in progress.
Userlevel 7
Badge +20
Yes was including the group name. But I was trying going from playing “everywhere” to playing “upstairs” so makes sense about the grouping not being broken. So still makes it a bit clunky. But as someone else said it seems to be very much a work in progress.

Yes, and I'm not sure how much of the development is with Amazon and how much with Sonos - obviously there must be development on both sides but I suspect that Amazon control the Architecture.
Hi everyone, I tried the steps above without success. I created a group in Alexa called downstairs. Added my Sonos speakers along with my Echo device. I can only add my Sonos speakers or the Echo as the preferred speaker, not both. So the music only plays on the preferred speaker.
Hi everyone, I tried the steps above without success. I created a group in Alexa called downstairs. Added my Sonos speakers along with my Echo device. I can only add my Sonos speakers or the Echo as the preferred speaker, not both. So the music only plays on the preferred speaker.

You still cannot play music over Echos and Sonos grouped together. It's either all Sonos or all Echos.