Answered

Alexa doesn't respond if I'm playing an imported playlist from my music library

  • 9 December 2020
  • 4 replies
  • 91 views

I’m new to Sonos and I installed my first device, a Sonos Move, about 10 days ago.

Everything was working fine until this morning when Alexa wouldn’t respond while I was playing an m3u playlist from my Music Library. Through trial and error I determined that she does respond if I pause playback but not while the playlist is playing. I also verified that Alexa responds normally when I’m playing a playlist from Amazon Music.

I tried powering it off and on to no avail.

Anyone have any ideas?

icon

Best answer by Annazel S 12 December 2020, 22:55

Hi @Tim8aBug.

Thanks for reaching out, let me check it for you.

While you can use Alexa to play music for music services like Amazon Music, Spotify, Apple Music, etc, initiating music from a local source/music library is not supported. Hence, once the music library is playing, you can use Alexa to skip tracks, repeat tracks, and pause/resume.

To better understand what’s going on, why Alexa doesn’t respond while playing, kindly reproduce the issue, then submit a diagnostic report through the Sonos app shortly after the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing this issue.

 

You may also refer to this article that provides steps to resolve issues with Alexa not following commands, not responding at all, or responding with an error.

 

Let me know how that goes.

View original

4 replies

Userlevel 5
Badge +16

Hi @Tim8aBug.

Thanks for reaching out, let me check it for you.

While you can use Alexa to play music for music services like Amazon Music, Spotify, Apple Music, etc, initiating music from a local source/music library is not supported. Hence, once the music library is playing, you can use Alexa to skip tracks, repeat tracks, and pause/resume.

To better understand what’s going on, why Alexa doesn’t respond while playing, kindly reproduce the issue, then submit a diagnostic report through the Sonos app shortly after the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing this issue.

 

You may also refer to this article that provides steps to resolve issues with Alexa not following commands, not responding at all, or responding with an error.

 

Let me know how that goes.

Hi there!

I have the same problem with my new Move, starting at 11:30 EST on 12/29 and have submitted a diagnostic report # 1804242065.

The Move works great. Alexa works great. But saying “Alexa” while music is playing (via Spotify or Amazon) does not activate Alexa as it should. As soon as I pause the music, I can say “Alexa” and it will respond. I tested various distances, I shouted, I whispered—it simply does not respond while music is playing, and it has nothing to do with hearing me.

I’ve had a One for over a year with no issues like this one. The only difference between the two is I have turned off Truplay for the Move.

Any assistance would be very appreciated!

@Annazel S Just tagging you to make sure you see this followup!

Userlevel 5
Badge +16

Hi there @Elstring.

Thanks for reaching out and my apologies for the delayed response time, let me help you with this.

Upon checking the diagnostic report, there are symptoms indicative of interference that have been detected on one or more Sonos components running on your WiFi. This usually causes network communication problems, either between Sonos and your router or between Sonos and the internet.

 

Using the Sonos app, please navigate to Settings > System > Date & Time and confirm that Set Time from the Internet is enabled.

You may also follow the suggestions in this article, it provides steps to resolve issues with Alexa not following commands, not responding at all, or responding with an error.

 

If the above advice was followed and the issue persists, please reproduce the issue then, submit a diagnostic report through the Sonos app shortly after the problem occurs, and provide us with the confirmation number, so I can see if there’s anything else causing this issue.

 

Let us know how it goes and if you have any questions feel free to reach out.

Reply