Answered

Alexa asking to link Spotify Premium Account even though already linked when using Sonos


Show first post

31 replies

I'm having this issue and can't seem to resolve it using many of the steps provided by others. My confirmation number is 173648517
Userlevel 6
Badge +20
mdetig84 wrote:

I'm having this issue and can't seem to resolve it using many of the steps provided by others. My confirmation number is 173648517



There was an outage on Spotify yesterday. Can you please retest and post on this thread if the issue persists?
I've been having this issue yesterday and again today when trying to set up my new Sonos One. I can play Spotify through my Sonos One from the Spotify app but have the same issue as the OP when I try to play Spotify using Alexa.
Userlevel 6
Badge +20
ajmcqueen79 wrote:

I've been having this issue yesterday and again today when trying to set up my new Sonos One. I can play Spotify through my Sonos One from the Spotify app but have the same issue as the OP when I try to play Spotify using Alexa.



Please find below my standard trouble shooting guide for Alexa problems on Sonos, they get more complex as you progress:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a web browser(https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.
Thanks UKMedia, solution 3 did the trick!
UKMedia wrote:

mdetig84 wrote:

I'm having this issue and can't seem to resolve it using many of the steps provided by others. My confirmation number is 173648517



There was an outage on Spotify yesterday. Can you please retest and post on this thread if the issue persists?

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings