Question

Alexa and Spotify Commands not working

  • 27 December 2017
  • 14 replies
  • 5357 views

Alexa does not respond to 'stop' when using Spotify. Anybody any idea why?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

First, check in the Alexa app for Smart Devices having duplicate names. Second, try using "pause" instead of stop and specify the room name.
Thanks, but not working. In fact none of the commands seem to work using Spotify. TuneIn is fine.
Userlevel 7
Badge +20
Thanks, but not working. In fact none of the commands seem to work using Spotify. TuneIn is fine.

Can you just confirm the command syntax that you using? Are you using a Sonos One or other Sonos players with an Echo device?
It's a Sonos One. So, for example, 'Alexa: stop' 'Alexa: turn off'. No commands work when playing Spotify.
Userlevel 7
Badge +20
It's a Sonos One. So, for example, 'Alexa: stop' 'Alexa: turn off'. No commands work when playing Spotify.

So can you confirm that you have:

1/ Added Spotify in the Alexa App>Music, Video & Books
2/ Set Spotify as your default music source in the Alexa App>Settings>Music & Media

Please try 'Alexa, Play soft jazz' or 'Alexa, Play Piano Chill Playlist'

If these don't work can you confirm that you only have one Spotify account and that the same one is identified as a Music Source within the Sonos App and the Alexa App.
Those commands did work, but once they started playing I couldn't stop them.
Those commands did work, but once they started playing I couldn't stop them.

I would try again, and when it fails, submit a diagnostic to Sonos and post the reference number here. You may also want to check your Alexa dialog history on the Alexa app to see if anything is being interpreted wrong.

To submit a diagnostic: https://sonos.custhelp.com/app/answers/detail/a_id/142

To check Alexa dialog history: https://www.amazon.com/gp/help/customer/display.html?nodeId=201602040
Userlevel 1
Badge +5
It's a Sonos One. So, for example, 'Alexa: stop' 'Alexa: turn off'. No commands work when playing Spotify.
So can you confirm that you have:
1/ Added Spotify in the Alexa App>Music, Video & Books
2/ Set Spotify as your default music source in the Alexa App>Settings>Music & Media.


I have similar issue when I try 1. It reports “app support unavailable”
So “Alexa, skip this track” she asks “what do you want to play” .
Yet Alexa play Rolling Stones is ok
(I have premium Spotify trial) through Sonos one
Userlevel 1
Badge +5
Tried
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
This worked for me
Had a good support call with Sonos. Basically removed then re-added skill from Alexa website and all commands now working. His top tip was if you make any changes do it via the website, and not the Alexa app. This is known to have bugs in it which Amazon need to fix, whereas the website is fine.
Sent my Alexa back. For numerous reasons. The main issue is it listens to conversations in the room/home. Wow that shocked me
Sent my Alexa back. For numerous reasons. The main issue is it listens to conversations in the room/home. Wow that shocked me

In what way does it listen to conversations? It listens for a wake word. Nothing is sent to the cloud until you activate it via the wake word.
Friends of mine, that do not have a cat, started talking about their fictitious cat. The next time they were online facebook ads for cat products began appearing on sites. Makes you wonder what is going on.
Friends of mine, that do not have a cat, started talking about their fictitious cat. The next time they were online facebook ads for cat products began appearing on sites. Makes you wonder what is going on.

Nonsense. You are repeating old wives tales from the internet. From the FAQ at Amazon:

2. How do I know when Amazon Echo, Echo Plus, or Echo Dot are streaming my voice to the Cloud?

When Amazon Echo, Echo Plus, or Echo Dot detect the wake word, when you press the action button on top of the devices, or when you press and hold your remote's microphone button, the light ring around the top of your device turns blue, to indicate that the device is streaming audio to the Cloud. When you use the wake word, the audio stream includes a fraction of a second of audio before the wake word, and closes once your question or request has been processed. Within Sounds settings in the Alexa App (Settings > [Your Device Name] > Sounds), you can enable a 'start of request sound,' a short audible tone that plays after the wake word is recognized to indicate that the device is streaming audio. You can also enable an 'end of request sound' that will play a short audible tone at the end of your request, to indicate that the connection has closed and the device is no longer streaming audio.


If it the above tales were actually happening and are so easily proven, Amazon would be liable for billions in a class action invasion of privacy suit, considering they explicitly state they do not listen to all of your conversations.