Alexa and Sonos in The Netherlands

  • 24 November 2022
  • 6 replies

  • Contributor I
  • 1 reply


Are there any updates on the integration for Alexa and Sonos from anyone who has managed to link sonos and alexa in The Netherlands?

I just bought a set of Sonos One ..and don't see Amazon Alexa as an option for voice assistant 😥

I certainly wish I had researched this earlier. What an absolute bummer! 


Best answer by GuitarSuperstar 24 November 2022, 16:06

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

Log in to your Sonos account on the main Sonos website and change your location under your Profle to Germany (or any other country where Alexa is supported on Sonos). This should allow you to add Alexa to your set of Ones.

I have the same issue with Sonos One (Gen2). I've set country to Germany, but still there is nothing in a list except Sonos voice control. Please help

Userlevel 1

First make sure you have the voice enabled Sonos One, not the SL.

Set your Sonos account to a country that Sonos supports. This limitation doesn’t come from Amazon, but is invented by Sonos for reasons totally unknown to the world. Amazon location does’t matter, they support almost all countries. After setting country for Sonos account, log out of all Sonos. Disable your Sonos skill in Alexa.

Once all is kogged out and phone restarted, Sonos one power cycled, log in to Sonos app. Add Sonos skill to Alexa. Go to System Settings, you should now find Alexa voice capability as installable option.

Userlevel 7
Badge +17

You still won’t get Alexa (or SVC for that matter) in Dutch though…..


What I did. Set region to Germany in my account profile (sonos web). Made logoff from sonos device. Installed Fake GPS app to my android phone. Turned developer mode in android. Enabled fake gps app (developer menu). Started Fake GPS app and set coordinates to random location in Germany. Additionaly set parameter "spoof wifi provider". Then I've run sonos app and made logon.

Userlevel 1

A bit overdoing it, but good that you got it working 🙂.