Question

After upgrade to new sonos, Alexa is not working



Show first post

43 replies

Userlevel 1
Badge

they say iOS app work but not android? are you using iOS @UKMedia ?

 

i’m on android, and i can’t make it to work. i already removed Alexa and re-added it. 

 

after re-adding, i get this message:

 

 

 

 

after clicking not now, Alexa still shows as added and available but voice commands are not recognized on sonos device.

 

i also tried relinking Sonos skill in Alexa app, but still no luck

I'm using the Android App without issues at the moment. 🤞

 

 

You tried to remove alexa and re-add it? 

Userlevel 7
Badge +20

Nope and I don't want to try it. 🤣🤣

Userlevel 3
Badge +2

Same i dont have such option to remove alexa...

Im having the same exact issue. 
 

Userlevel 3
Badge +2

I’m having the same issue with my Beam and One. Have deregistered both in Amazon.  Disabled skill. Deleted devices from Alexa. 
Switched both off. Deleted apps.  Rebooted router and phone. Reinstalled apps. Rejoined system on Sonos app. 
Relinked in Alexa app. 
In Manage devices voice assistant. Shows Alexa is already added still and cannot click on it. 
Spent hours on this and can’t get through to support.  
Was going up the wall. At least now I’ve found this thread I know I’m not alone!! 

Userlevel 3
Badge +2

All

I managed to get through to support. 
They said that Alexa not working is a “known issue” and we will have to wait for the fix to be released  

(The link to the “known issues” doesn’t seem to include this major bug though so when it will be fixed is anyone’s guess)

 

I see. The current Alexa issue is known at the moment due to the time and date not yet being fully integrated in the new Sonos app.

 
For more information on the missing added feature being added back in the new Sonos app, please check this link: https://en.community.sonos.com/controllers-and-music-services-228995/the-new-sonos-app-and-future-feature-updates-6892942


 

 

 

Userlevel 7
Badge +20

Thanks for the update, this is very useful information. 👍

Badge

Just to circle back to this. I contacted phone support last night and as one of the troubleshooting steps, they had me perform a factory reset on my Sonos Arc. After that I was able to add Alexa again and now have it working again. Sucks that I had to factory reset though because I lost the TruePlay configuration and don't have easy access to an iOS device to set it up again since it doesn't work with Android.

Factory reset was what I was going to do to try to reset the baseline.  Encouraging to hear that may be a useful direction

I just got off the phone with Sonos tech support. After many troubleshooting steps were taken to get Alexa connected I was told that this is a known issue with the new app and developers are currently working on a fix with no ETA. 

After upgrade to new sonos app. The alexa is not working on my Beam. And from alexa app, it appear the speaker is offline.. No matter how many time i disabled and reenabled the skill…

I have also reset the voice assistant couple times as well

 

diagnosis number: **************

 

Moderator Note: Recorded and removed Diagnostic Number. Modified in accordance with the Community Code of Conduct.

Same issue here

Userlevel 3
Badge +2

Thanks for the update, this is very useful information. 👍

This was on another post as a workaround. 

 

Having exact same issues.  

Factory reset worked as a fix on Sonos Move after trying almost everything else.

Having same issues.  Going to attempt factory reset.  🙏😬

Worked.  2 One’s and 1 Beam.  

It's the weirdest and completely most bizarre fix but it worked for me. I had the exact same issue. I'm using an android phone, I uninstalled the Amazon shopping app. Then was able to activate the Alexa function with out issue. Then reinstalled the Amazon shopping app. I have no idea why it worked but I saw that few ppl on another chat tried solution and it worked. 

Userlevel 7
Badge +20

It's the weirdest and completely most bizarre fix but it worked for me. I had the exact same issue. I'm using an android phone, I uninstalled the Amazon shopping app. Then was able to activate the Alexa function with out issue. Then reinstalled the Amazon shopping app. I have no idea why it worked but I saw that few ppl on another chat tried solution and it worked. 

I’ve heard of this when someone has multiple Amazon accounts on a single phone.

I got a message from the Sonos App saying that one of my Sonos devices has no internet connection.  It’s odd as all of them are connected to Wi-Fi.

 

Reply