About ducking time



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Userlevel 7
Badge +19
Ducking is now fixed.
Userlevel 6
Badge +6
Ducking is now fixed.

I believe you, thought no official announcement from Sonos ??

Rather than universal ducking I now have no ducking at all, though I have Ip each Sonos device in groups with a preferred speaker. Am I missing something ?

Andrew
Userlevel 7
Badge +19
Strangely enough there was an official announcement on twitter, which was deleted.

Do you have ALL of your Sonos Speakers assigned to an Alexa group? So I have a Sonos speakers in rooms without an alexa device but have still set the room as a group and added the appropriate Sonos Room speaker and set it as default music device. If not that may be the cause.

Otherwise I do wonder if they removed the tweet because of a bug like you have found. For me it works as intended.
1) Create an Alexa Group for each room that has an Amazon Echo in.
2) Put the (e.g. living-room) Echo device and all Sonos speakers which are in the same room into the Alexa Group; tap 'Save'.
3) Tap (the green area of) the Alexa Group
4) Set up 'Preferred Music Speaker(s)'
Userlevel 7
Badge +22
Some have been seeing support via the last Alexa update (ducking and setting for Sonos speakers to be set as default music speaker for an echo device - ie no saying "in room" anymore). It seems to work most of the time but seems to be a work in progress where Amazon just put out their part and Sonos must have a few thing to do as well in getting it to full speed. Thus I think no announcement since its a WIP. Hopefully see something soon on Sonos end.

But enjoy it while it is working.
Userlevel 7
Badge +19
You also need to set a group for each room you have a sonos speaker, even if there is not an alexa device present. Or set a group for all your Sonos kit that is not in an alexa room.... if that makes sense.
Userlevel 7
Badge +22
What is the need for a Sonos speaker being in a group if there is no Alexa device to be associated with it?
You also need to set a group for each room you have a sonos speaker, even if there is not an alexa device present. Or set a group for all your Sonos kit that is not in an alexa room.... if that makes sense.
Correct, I forgot about that.
What is the need for a Sonos speaker being in a group if there is no Alexa device to be associated with it?
If you don't put each Sonos speaker in an Alexa group, then the volume will continue to lower in all rooms, I think.
Userlevel 6
Badge +6
I have set up each sonos device in a group as Smilja described, even where no Alexa device is present but have no ducking anywhere.

I suspect it is being rolled out / worked on, and that an announcement will follow. To be honest I can wait, ducking has been bugging the hell out of me for the last 12 months so I’m glad a fix is imminent.

Andrew
Userlevel 7
Badge +20
Light testing suggests that this is working for me now - only the preferred music speaker ducks. Great! Thanks to Smilja and bockersjv for the instructions.

Now I just need multi-household support.
Badge
This seems to be working for me which is very nice. Especially for the Amazon Tap that gets used by kids outside, that was awful with the volume going down all over the house every time they would wake up Alexa. The only thing that I can't seem to do is prevent the Ecobee thermostat with integrated Alexa from ducking all the Sonos speakers. The Ecobee isn't available to put in a group in the Alexa app, even though it does show up as an Alexa Enabled Device. I'll probably just mute the Ecobee to avoid issues, there are enough Echo Dots around the house at this point.

I don't have much use for a Sonos One with our setup. We put our Sonos One in the basement since it didn't get wife approval after it replaced the most used Amazon Echo in the house (not a Dot, but the full size Echo). The Sonos One didn't perform as well from a voice interaction standpoint and that got annoying quickly. More false wake up triggers which cause an audible ding instead of a light ring, not hearing your voice over the music it was playing as well as an Echo, etc, etc.

What has worked well for us and works even better now with the latest improvement is a dedicated echo dot for voice interaction and a Sonos Play:1 in the same room (could be other Sonos speakers). That seems to give us the minimum annoyance factor for voice interaction and still have the improved sound quality and whole house music.

It's really nice to be able to walk into the kitchen, say "Alexa, play Classic Rock" and the music starts playing on all the Sonos speakers that are defined as the Preferred Speakers in the Alexa App. We no longer have to say "Alexa, play Classic Rock in Kitchen". That feature plus the ducking fix are huge improvements.
What is the need for a Sonos speaker being in a group if there is no Alexa device to be associated with it?Nothing of any great benefit, if it’s standalone, but ...

If for example, you had a group called ‘Upstairs' and added to that group: 3 x Sonos One Speakers (one from each bedroom, perhaps) and set them all as 'preferred' in the group, but had no echo devices at all, like echo dots etc. in order to 'Alexa Enable' the Group ... then a user can still go to any of the Sonos Ones in the group (or any other Alexa device elsewhere in the home) and say 'Alexa, play some music upstairs' and the three Sonos Ones will Group together automatically and play the music... Speaking to any of the three Sonos Ones, will also 'duck' all three speakers in the group too.

The 'key' here, is you do not need an echo dot to enable the group, if you are happy to include the 'group name' in the Alexa instruction.

Obviously if the same group was made 'Alexa Enabled' with one (or more) echo dots, then when speaking to any of those echo devices there would then be no need to mention the group name (upstairs) at all.

Note: an Amazon echo device can only be used 'once only', for 'enabling a group' across all the Alexa groups you create.
[...] I don't have much use for a Sonos One with our setup. We put our Sonos One in the basement since it didn't get wife approval after it replaced the most used Amazon Echo in the house (not a Dot, but the full size Echo). The Sonos One didn't perform as well from a voice interaction standpoint and that got annoying quickly. More false wake up triggers which cause an audible ding instead of a light ring, not hearing your voice over the music it was playing as well as an Echo, etc, etc.
In my case it's the other way around. The living room Echo is deaf when music is playing in the living room.
I’m reasonably sure that Sonos have improved the 'listening ability' of the Alexa part of their devices with each new recent firmware update, at least my devices seem to have improved, but I would still like to see some kind of slider bar that allows a 'percentage' adjustment of the sound of Alexa's voice in relation to the audio output of the speaker itself, as I have had Alexa 'bawl' at me on the odd early morning occasion, having played music quite loudly the night before.
I’m reasonably sure that Sonos have improved the 'listening ability' of the Alexa part of their devices with each new recent firmware update, at least my devices seem to have improved, but I would still like to see some kind of slider bar that allows a 'percentage' adjustment of the sound of Alexa's voice in relation to the audio output of the speaker itself, as I have had Alexa 'bawl' at me on the odd early morning occasion, having played music quite loudly the night before.
That's not even doable for Amazon's Echos right now.