Answered

Volume control Sonos Playbar through Samsung One Remote


Does anyone know how to connect the Samsung One Remote control to the Sonos Playbar so that I can control the volume of the playbar? I tried various ways but can’t get it to work.... I read the the playbar has IR whereas the Samsung remote control has RF but nevertheless there seems to be a way to make them connect. Hope someone can share the ultimate solution for this issue with me!!
icon

Best answer by buzz 19 February 2018, 03:26

Read this FAQ.

View original

22 replies

Read this FAQ.
Thanks. I tried this earlier, didn’t work then but it does now!🆒
Declare victory and move on.
Read this FAQ.

Anyone have another link for this? Or can you copy and paste what it says? I'm also trying to connect my Playbase with my One Remote but when I click this FAQ link, it brings me to a blank page that says "Ctomer Portal is not enabled for this interface."
Yea, they changed the location/address of all the FAQs last week. Try this link:

https://support.sonos.com/s/article/3444
Thanks for this. One thing I noted when setting it up with my new TV today is that the Sonos never needed to learn the remote codes, so I tried changing the volume with my old tv remote, and it still worked.

Therefore, I then tried setting up the sonos with the “dumb” remote Samsung also supplies, which works and means you can use either. I’m guessing a few people may have already worked this out, but I haven’t seen any mention of this elsewhere.

I am guessing the Playbar has some of its own codes which is what the smart remote uses, and are on top of whatever the sonos can learn.
Userlevel 1
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!
Badge
Great answer. It works perfectly for me. On a really minor point, do you know if you can change the label from Samsung?
Userlevel 2
Badge
This honestly saved me from having to buy a beam. Fourth test did the trick. And yes you can rename from Samsung to Sonos.
Thx @af2k!
Badge +2
My Samsung Series 7 2018 just discovered and offered to control the Playbar without me doing anything but selecting optical out for sound. Works flawlessly and indication on screen labeled SONOS
Thank you.
Badge +3
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!


Not sure if I’m missing something. I have the same TV but I don’t have a setting for “universal remote”. Been looking everywhere for it. I have picture, sound, general, and support as options and none of those have a universal remote sub menu. Struggling to get my Playbar controlled by the one remote.
Badge +3
Figured it out. You don’t go to settings > universal remote. You go to sources > universal remote. After that works like a charm. Bravo
I tried this process a couple of month ago, then decided to try it again. the minor detail I forgot, you must set your TV audio from "TV sound" to "Audio Out/Optical". LOL
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!


So I've been setting up my sonos with the Q8 samsung TV and I get it working but then it disappears from the optical connection and then sometimes it tries to set itself up automatically with a 50/50 success rate. If it fails, I go in and set it up again. I tried to use your method by calling it a Samsung theater system but after the third time I press no on the power test, it goes to the screen where I enter the model number of the theater system. Any thoughts on this at all?

I've tried calling Samsung, but they're absolutely no help. All they can tell me is that if I use an HDMI cable instead of optical then it will work. I tell them there is no HDMI on the playbar and he said it will still work. Seems like they're partially braindead over there.
I have my Sonos universal remote setup to HDMI 1. Since I have a device connected to it(chrome cast) I believe that's why I can toggle the sound along with my tv audio set to out/optical.
I have my Sonos universal remote setup to HDMI 1. Since I have a device connected to it(chrome cast) I believe that's why I can toggle the sound along with my tv audio set to out/optical. So I currently have a cable box to HDMI, Xbox to another HDMI, and a blue ray player to another HDMI. So when you set up your Sonos you just told your TV that the Home Theater Sonos was connected to the HDMI that the chrome cast was on?
Yep, I think the trick is to have a device connected to be on, so for instance if you set your Sonos universal remote to HDMI 1, that device should be on or if you set your Sonos universal remote to HDMI 2 that device should be on. I might be wrong but when I set up my Sonos to HDMI 2 with my PS4 I was able to change the volume but when I went back to HDMI one I couldn't. Tomorrow I will toggle with it again in the meantime try that method, and I'll get back to you tomorrow
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!
Great video which walks you through this very easy:

https://youtu.be/lDDFhersXMs
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!

—————————————————————
Following instructions worked for me

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and *hit "No" (unsuccessful) for 1st time & hit “Yes” for 2nd time to covert Samsung to Infrared*, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings