Answered

Two Sonos products not in Boost network.

  • 26 January 2023
  • 8 replies
  • 179 views

Userlevel 1
Badge +3

I recently had to redo my network and have since been struggling to get all Sonos product reconnected. Sonos support directed me to set up a 2.4 network for Boost. I did and two Sonos products (mac addresses 48:A6:B8:EC:75:9C and 48:A6:B8:EC:75:C2) still show as connected via 2.4 whereas all other Sonos now show as Boost wired connected as expected. What are the two that are not, do I need them to be connected wired, and if so, how do I do that?

Sonos performance now seems about where it needs to be but there are still issues. I have eight One’s in pairs of two each, a Port running my non Sonos family room speakers, a Sonos soundbar, sub, and two more Ones in the rear of a separate home theater system upstairs. Occasionally, frequently enough to be annoying, one or more of the pairs will drop out, reconnecting a minute or so later.

Between having major issues reconnecting Sonos and my home security cameras, just shoot me if I ever need to redo the network again.

icon

Best answer by Corry P 31 January 2023, 16:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +22

I found my home security cameras overloaded my WiFi keeping it too busy for several other devices to work. Moving the cameras off the shared WiFi to their own connection solved that.

What kind of Sonos devices are these two? For instance, a Roam or a Move will not be able to connect to a SonosNet signal, they don’t have the proper hardware, and are not designed to do so. If these two devices are not either of these, often a simple power cycle (reboot) of the Sonos device will nudge it over to reconnecting to the correct signal. 

As to your “dropouts”, there’s a couple of possibilities. The first I’d be looking at is the potential for wifi interference . If we’re talking about surrounds, you need to be aware that they connect to the front ‘sound bar’, and not directly to your SonosNet (or regular wifi) using a 5Ghz channel. And the input from a TV tends to be larger in bandwidth than a normal music stream, so they can be more “sensitive” to dropouts due to interference. And that interference doesn’t have to come from inside your home, unfortunately. As indicated in that linked FAQ, there are external sources of interference that can affect your system.

The other potential you should be aware of is the possibility of items on your network “fighting” for the same IP address. There’s a “easy” fix, but it’s potentially temporary, and a longer, more involved version, which I recommend. 

The first is a simple wifi refresh, by unplugging all your Sonos devices from power, then rebooting your router. Give the router a couple of minutes to boot back up, and load up everything, and then plug back in your Sonos devices. This gives you dual benefits. 1) you’ve reloaded the firmware the router is using, and 2) you’ve reloaded the firmware and the IP addresses for all your Sonos devices. Note that surrounds, while they’re still connecting to the sound bar, do still use a proxied IP address from your router.

If this fixes your issue, I’d heartily recommend reading your router’s manual, and figuring out how to reserve the IP addresses in use for the Sonos devices. Routers sometimes can get lost in their assignments from the DHCP table, and setting up reserved IP addresses can help reduce that possibility.

I recently had to redo my network and have since been struggling to get all Sonos product reconnected. Sonos support directed me to set up a 2.4 network for Boost. I did and two Sonos products (mac addresses 48:A6:B8:EC:75:9C and 48:A6:B8:EC:75:C2) still show as connected via 2.4 whereas all other Sonos now show as Boost wired connected as expected. What are the two that are not, do I need them to be connected wired, and if so, how do I do that?

In the Sonos App ‘Settings/System/About My System’ you should see a list of your Sonos devices and their MAC/IP addresses and their Wireless Mode (WM:0 = SonosNet mode and WM:1 means the device is still using your WiFi signal) I won’t bore you with other Sonos Wireless Mode settings - However, subject to the *note below, just see which ones are not showing as WM:0 and power-cycle them.

*Note: Sonos portable products Roam/Move do not use SonosNet and will always show as WM:1 so if you have any of those products, then they will continue to always run on your WiFi signal.

If you do not have any Sonos portable products (Roam/Move) and so plan to run all devices on SonosNet, then you can safely remove the local WiFi network SSID/Credentials from the Sonos App ‘Settings/System/Network/Manage Networks’ area and that will ensure your devices do not connect/hop-onto your WiFi network, but use the SonosNet signal  - only remove those credentials when all devices are safely running on SonosNet and showing in your Sonos App.

Hope that assists.

@Waugust,

It’s also helpful to set the routers 2.4Ghz WiFi band to channel 1, 6 or 11 with a channel-width of 20Mhz only and set the SonosNet channel in the Sonos App so that it is at least 5 channels away from your chosen router channel - also position the wired Sonos product so it is at least one metre away from the router or any other wireless devices.

Userlevel 1
Badge +3

Thanks for everyone’s suggestions.

I have created what I’ll call a subnetwork using a Boost. All but the two Sonos MAC addresses I cited in my post now show as “wired connected”. I don’t know of any other devices the two could be. I actually took the time to rename every generic Sonos device by the names I’ve given them in the mobile app, within Orbi’s attached devices page. That doesn’t doing anything other than make it easier for me to keep track of things.

I notice that many of my wifi devices are named what they are (Roku, Apple TV, wifi phone, etc.) I wish Sonos did that; the generic descriptions don’t say what type of speaker it is.  Renaming them is how I found two MAC addresses I can’t account for. 

I do have two Move speakers and know they are not part of the network.

@Ken_Griffiths you suggested a few things I’d like to know more about.

The Orbi 2.4Ghz channel is set to 11, and I believe channel-width of 20Mhz, both done by Netgear support at the suggestion of Sonos support.

You said, “...set the SonosNet channel in the Sonos App so that it is at least 5 channels away from your chosen router channel.” By “chosen router channel” are you referring to the 5Ghz channel, which is set to 48?

You said, “...also position the wired Sonos product so it is at least one metre away from the router or any other wireless devices.” Not sure what this means but if it is Boost I will need to change that.

Thanks again to all of you. This isn’t “Greek to me” but it’s not far off. 

Thanks for everyone’s suggestions.

I have created what I’ll call a subnetwork using a Boost. All but the two Sonos MAC addresses I cited in my post now show as “wired connected”. I don’t know of any other devices the two could be. I actually took the time to rename every generic Sonos device by the names I’ve given them in the mobile app, within Orbi’s attached devices page. That doesn’t doing anything other than make it easier for me to keep track of things.

I notice that many of my wifi devices are named what they are (Roku, Apple TV, wifi phone, etc.) I wish Sonos did that; the generic descriptions don’t say what type of speaker it is.  Renaming them is how I found two MAC addresses I can’t account for. 

I do have two Move speakers and know they are not part of the network.

@Ken_Griffiths you suggested a few things I’d like to know more about.

The Orbi 2.4Ghz channel is set to 11, and I believe channel-width of 20Mhz, both done by Netgear support at the suggestion of Sonos support.

You said, “...set the SonosNet channel in the Sonos App so that it is at least 5 channels away from your chosen router channel.” By “chosen router channel” are you referring to the 5Ghz channel, which is set to 48?

No, I meant your 2.4Ghz WiFi channel, just leave your 5Ghz channel on 48.

You said, “...also position the wired Sonos product so it is at least one metre away from the router or any other wireless devices.” Not sure what this means but if it is Boost I will need to change that.

Thanks again to all of you. This isn’t “Greek to me” but it’s not far off. 

Yes, I would position the Boost so that it’s at least one metre away from your router, or any other wireless devices to reduce the potential for wireless interference.

Note some routers may show wireless sonos devices (running on a SonosNet signal) as being ethernet connected in the routers configuration pages - I some routers do this because the devices are operating on SonosNet and the router is interpreting the devices are wired because the Boost ‘bridge’ is wired. It’s nothing to be overly concerned about… it’s just a display issue and should not give rise to any problems. 

Userlevel 7
Badge +18

Hi @Waugust 

Thanks for your post!

The two devices you supplied the MAC addresses of are your two Moves. As already mentioned above, they are expected to remain on WiFi and will not connect to SonosNet, so what you see is expected. If you were hoping that they would connect to 5GHz, they will do so unless the 5GHz signal strength is low (or unless the bands are separated and they don’t know the password). I don’t know why you thought they “weren’t part of the network” - everything that get’s it’s IP address from your router is part of the network.

Your initial post suggests a reasonably-sized group is configured. With WiFi interference minimised, and if you still experience dropouts, I recommend ensuring that the room in charge of a group (selected first) is either an ethernet-wired device, or a room close to one.

I hope this helps.

Userlevel 1
Badge +3

It does help @Corry P , thank you.

To all who offered advice, I think the genie is back in the bottle (my network is working including Sonos.)

I will make equipment changes to the home to (hopefully) get more network stability in the future. Meetings this week with two network installers to discuss moving the router to a more central location, and making more use of ethernet connections where possible.