Answered

Turntable + Mixer + Tuner help w/ Sonos Connect

  • 6 September 2019
  • 5 replies
  • 81 views

Hey There,

I'm looking to get my Turntables to work with my Sonos connect. Currently, I have 2 turntables plugged into a mixer, and then my mixer plugs into my tuner that work with my home speakers.

I have my Sonos Connect plugged into my Tuner, so I can hear music (via the Sonos app) on my home speakers and my Sonos Speakers, but I'm wondering if there's a way I can get both turntables to also play on my Sonos Speakers? Thanks!
icon

Best answer by ratty 6 September 2019, 19:05

Your "SONOS" source is presumably the Connect's Line-Out. Unless you configure Line-In Autoplay (see the Connect's room settings) you have to explicitly tell the Connect to play its Line-In, using the controller's browse/music menu.
View original

5 replies

Does the mixer have a second output? Just wire it to the Line-In jacks on the Connect.

Note that Line-In has a 75ms delay through the Sonos system, so accurate cueing of the turntables could be tricky.
Does the mixer have a second output? Just wire it to the Line-In jacks on the Connect.

Note that Line-In has a 75ms delay through the Sonos system, so accurate cueing of the turntables could be tricky.


Thanks for writing back, Ratty!

I tried this, and it did not seem to work. I have attached a picture for reference. The Main Out labeled "Amp" on the left goes into my Tuner, i tired doing the Main Out labeled "Record" and put that into my Sonos Connect, but no luck :/

According to the manual that should work. The RECORD (tape) output is at fixed level.

Did you actually use a Sonos controller to select the Line-In source? (Note: This can be set to Autoplay in the room settings.)
According to the manual that should work. The RECORD (tape) output is at fixed level.

Did you actually use a Sonos controller to select the Line-In source? (Note: This can be set to Autoplay in the room settings.)


I selected the "SONOS" source on my Tuner, thinking that should do the trick, but no such luck.
Your "SONOS" source is presumably the Connect's Line-Out. Unless you configure Line-In Autoplay (see the Connect's room settings) you have to explicitly tell the Connect to play its Line-In, using the controller's browse/music menu.

Reply