Answered

Speakers connecting to WiFi (WM:1) despite Wired Setup

  • 12 July 2022
  • 6 replies
  • 133 views

Badge

Bit of confusion regarding SonosNet -

 

I currently have several Sonos speakers and a Port connected via Ethernet for max stability and to minimize latency, and I have a few (two Sonos Ones and a Roam) that are showing up as WM:1 in About My System. I was under the impression that WM:1 means they’re in wireless mode (e.g. connected to my ASUS router, not SonosNet), but I also have read that as soon as you wire at least 1 speaker to Ethernet, SonosNet is created and all speakers (except possibly the Roam) should show WM:0 to indicate SonosNet is active. What gives?

 

I don’t actually mind the speakers using the ASUS router’s wifi, but I have to finally give in and update the firmware to use some new AIMesh features and based on reading around the forum it seems like the newer firmware is still causing Sonos speakers to drop off the network. Thinking if I can get them on SonosNet instead that should avoid the issue.

 

Thanks!

icon

Best answer by John B 13 July 2022, 12:49

View original

6 replies

Userlevel 7

Sonos portable devices like the Roam and Move will always be in a wireless setup and show “WM: 1”.

The two Sonos Ones should connect to SonosNet. They may just need to be power cycled. Unplug them both from power for a couple of minutes and then plug them back in. Wait about a minute to allow them to connect to the network and then check their WM status again in the Sonos app.

Don’t overlook the possibility of a bad network cable.

Have you "disabled WiFi" on the wired devices? If so, re-enable.

I have one wires Play one showing WM0, two are showing WM2 and the remaining are showing WM1.  WiFi is enabled on the wired speaker.  I am having skipping and unable to connect issues when using the Sonos app. Help!

I am on an Orbi RBR/RBS40 mesh system. The wired speaker is a Play1, i have various other Sonos speakers

Badge

Don’t overlook the possibility of a bad network cable.

Checked that by ensuring that the wired speakers & Port were connected to the Asus router through ethernet (in the Asus’ configuration app). 

 

Sonos portable devices like the Roam and Move will always be in a wireless setup and show “WM: 1”.

The two Sonos Ones should connect to SonosNet. They may just need to be power cycled. Unplug them both from power for a couple of minutes and then plug them back in. Wait about a minute to allow them to connect to the network and then check their WM status again in the Sonos app.

For whatever reason, even after power cycle the Ones are showing WM:1 and are connected wirelessly to the Asus router (as confirmed in the router’s app); I assume if they eventually cooperate and I can get them into WM:0 they would show in the Asus router’s app as “wired” (since they’re connecting wirelessly through another Sonos speaker, then ultimately to the router through that speaker’s ethernet connection)

Have you "disabled WiFi" on the wired devices? If so, re-enable.

Ooo possibly, will check this and report back!

Reply