Sonos and Eero w/Xfinity modem: Is "bridge mode" the only solution?

  • 6 June 2020
  • 4 replies
  • 396 views

Userlevel 5
Badge +1

Once I installed Eero in my house, I found that various Sonos devices would routinely drop off / disappear from the Sonos app. Sonos support explained that adding Eero essentially created dual wireless networks running in my house (Xfinity modem publishing it’s wifi signal, and Eero creating it’s mesh network) and this created conflicts that confused the Sonos network/devices. They suggested I put the Xfinity modem into “bridge mode” which turns off the modem’s internal wifi and just passes through the bandwidth to the Eero gateway connected to it. Once I did this, I was able to go back and reset all the Sonos devices and the Sonos solution has been working well. This is good. However, the downside to this solution is that once the Xfinity modem is in bridge mode, it’s no longer possible to use the Xfinity mobile app with it, or to watch Xfinity content on computers, etc. So my question to this group: has anyone found another solution to getting Xfinity-Eero-Sonos to work together without going into bridge mode?


4 replies

Userlevel 3
Badge +4

I have a similar issue with Cogeco (Canada) that I can’t run my modem in bridge mode. A couple of things you could try. 
 

it’s a pain but ensure that your mesh network runs on a different IP range to your main modem. Essentially I have my mesh network separated from the main modem. The ‘wan’ port on my mesh ‘router’ is on the same subnet as the main router and then the DHCP scope is set to a different range. 
 

I hope that makes sense. It required some trial and error. 
 

Another option is to hide the ssid of the xfinity modem and make sure Sonos knows nothing about it. See if xfinity services work in such a scenario. 
 

You could either use one of your speakers or buy a boost and plug that into one of the network ports on the primary Eero node and let Sonosnet do it’s thing. 
 

Hope the above makes sense. Ultimately it’s all a work around - bridge mode with a mesh network is generally the most stable across all network protocols - not just Sonos. 


Whatever you do be careful with DHCP - Sonosnet won’t fix that. I’d you have two DHCP ‘servers’ handing out IP addresses your going to have issues. If xfinity modem is handing out IP’s make sure it’s only giving an IP to the xfinity network and not the eero network. 
We’re getting into the weeds a bit but multiple devices handing out IP’s need careful setup. 
 

Good luck. 

Userlevel 3
Badge +4

@bholding,

Another option would be to go back to the normal Xfinity modem/router configuration, turn off the Xfinity gatway wireless interface(s), and change your Eero mesh system into bridge mode instead.

In the original setup you had two conflicts:

  1. both the Xfinity gateway and the Eero were providing WiFi service
  2. the Eero (in its default mode) also acts as a firewall between the Xfinity side and the WiFi mesh network it is providing 

Without more information it looks like the Sonos support staff was trying to solve both of those problems by changing the Xfinity gateway into the bridge mode which has the effect of turning off its wireless interfaces too along with its firewall and leaving the Eero to be the only firewall. Of course this also had the effect of removing the services the Xfinity gateway provides.

You’ll need to consider which set of “advanced” features are more important to you though - the Xfinity or the Eero. It appears you know what you’re missing from the Xfinity side so here is an Eero article on what you lose when the Eero is in “bridge” mode. Some of those Eero features appear to be available on the Xfinity gateway by different names but you’ll miss some of the deeper Eero WiFi control features.

If the Eero features are more important to you then I’d suggest staying with your current setup.

If you want the Xfinity services here is an idea of the steps needed to do the switchover:

  1. Revert the Xfinity gateway back to its normal modem/router mode (here is an Xfinity support article on how to enable/disable Bridge mode). This requires a device with an Ethernet connection direct to the gateway.
  2. While connected to the Xfinity gateway after disabling “bridge mode” turn off/disable the Xfinity gateway WiFi interfaces (here is an Xfinity support article on how to change the WiFi settings). If the gateway has both 2.4 and 5GHz networks you’ll want to “disable” both and then save the configuration.
  3. Connect to your Eero system via the Eero app and follow this Eero support document to change from the Automatic mode to Bridge mode. Since you already have your Eeros setup you can skip ahead to step 2.
  4. Reboot all wired devices and all Sonos devices.
  5. Disconnect and reconnect all wireless devices (probably easiest to toggle the wifi interface off and then back on).

The effect of the above will make your Eero mesh system the only system providing wireless access for your household LAN/WiFi while also allowing you to to control and use the Xfinity gateway services. The Xfinity gateway will also be the only firewall for your network. 

This entire process will disrupt your household network again since you’ll be changing back to using the Xfinity DHCP server instead of the Eero provided one. As noted above, all devices on your network will need to be rebooted or reconnect to the LAN/WiFi network so they can obtain correct IP addresses from the Xfinity gateway. The above process shouldn’t change any of the Eero wireless configuration so all of your devices that use wireless should be able to continue to work as is.

Your Sonos system should work after this whether it is using one wired connection and Sonosnet or connecting to the WiFi.  I assume the Sonos support staff would have mentioned if you’re using Sonosnet and there was overlapping WiFi channels or interference but you might review that while you’re cleaning up after the changes above.

Hope this helps.

Userlevel 5
Badge +1

@britishwonderings and @david82,

Thank you so much for your thoughtful responses - they are super helpful. Given the continued growth of Eero I’d like to think the Sonos folks would come up with some type of technical fix for this, though I’m not sure what that would like like. In the meantime this must be creating a serious support issue for them, and one that is not easily explained. They were helpful on the phone, but I still haven’t seen a formal response published from Sonos about Eero and how the community might best configure their home networks. Maybe they can start by leveraging your thorough explanations above. Thanks again.

 

Userlevel 3
Badge +4

@britishwonderings and @david82,

Thank you so much for your thoughtful responses - they are super helpful.

 

you’re definitely welcome.

Given the continued growth of Eero I’d like to think the Sonos folks would come up with some type of technical fix for this, though I’m not sure what that would like like. In the meantime this must be creating a serious support issue for them, and one that is not easily explained. They were helpful on the phone, but I still haven’t seen a formal response published from Sonos about Eero and how the community might best configure their home networks. Maybe they can start by leveraging your thorough explanations above. Thanks again.

in your case, i’m not certain whether the problem was centered on the multiple competing wireless networks or the fact that the Eero system, by default, acted as a firewall between the Xfinity side of the network and the Eero mesh wireless side, or both. my guess is both.

the nexus of your problem started with the addition of the Eero system so i’d suggest it is more in Eero’s ballpark to provide guidelines about how to work with Sonos and Xfinity or any home broadband provider gateway. all of the WiFi mesh vendors have similar issues.

Xfinity offers a WiFi mesh/extender system that should integrate well with its system. i am not an Xfinity customer so i don’t know how well personally but do know some Xfinity product engineers and they’re excellent.

Reply