Answered

How to get 2 Beams both connected to the wired network

  • 19 December 2021
  • 8 replies
  • 88 views

I have 2 Beams in separate rooms (my only Sonos products) and I am trying to get both of them onto my wired network (house is wired for Ethernet).

The first Beam connects no problem and recognises the wired connection. The second Beam will only connect on Wi-Fi and does not recognise the wired connection at all (it will not allow me to disable the Wi-Fi).
Is there a specific technique for getting this to work? 

icon

Best answer by ratty 20 December 2021, 18:31

View original

8 replies

hi @Renee4 it might help to switch off your router and the Beams (count to ten) and switch all on again to free (previously) assigned IP addresses - you suggest not to disable wifi because this will also disable the SonosNet between the Beams

 

Thanks, yes I tried that. It made no difference. I believe that if you “disable wifi” on the specific product in the sonos app that sonosNet still works - can anyone confirm that? However I do not want SonosNet working - I want the sonos speakers to communicate via the wired network. I have wifi disabled on the first beam.

Can I just be clear on what I am trying to achieve: My Beams should be connected to the Ethernet and communicating with the internet and each other via the wired network only (no use of SonosNet). My apps (sonos / Alexa etc) are on mobile devices (phone. tablet, etc) and I assume they are also communicating “via the internet” to the sonos devices.

My house is long and narrow with exceptionally thick walls across its width making wifi patchy (the speaker that I am trying to get onto the wired network frequently drops out on Wifi) - hence why I want to use the wired network.

Thanks, yes I tried that. It made no difference. I believe that if you “disable wifi” on the specific product in the sonos app that sonosNet still works - can anyone confirm that?

No, it’s SonosNet wireless that’s disabled. The controller option is confusingly labelled. 

Moreover in a home theatre player, such as Beam, the option also disables the private 5GHz wireless used to connect the HT satellites. If you have any surrounds/Sub you should not disable the wireless. 

 

My apps (sonos / Alexa etc) are on mobile devices (phone. tablet, etc) and I assume they are also communicating “via the internet” to the sonos devices.

No, not via “the internet”, at least not for the Sonos app. That communicates with the Sonos devices locally. (Alexa does however use a bridge between Amazon and Sonos in the cloud.)

 

The first Beam connects no problem and recognises the wired connection. The second Beam will only connect on Wi-Fi and does not recognise the wired connection at all (it will not allow me to disable the Wi-Fi).

It should work. Your Ethernet connection could be defective. Try a different cable or router/switch port. 

To know for sure whether there’s a wired connection:

  1. go to Settings/System/About and note the IP address (A.B.C.D) of the Beam
  2. point a browser to http://A.B.C.D:1400/status/enetports
  3. if the Link column shows a 0 there’s no connection 

 

If the wired connection is proved to be good, then the Beam is objecting to the path to the router not being direct. Temporarily wire it directly. The wireless should disable and the setting persist.

 

As a final comment, in your situation you shouldn’t actually need to disable the wireless at all. The Beams should prefer the wired connection, unless you have a managed switch in the way which is configured for RSTP. In that case either the switch needs to be reconfigured, or the advice to temporarily wire the Beam to the router to disable its wireless can be followed instead.

Thanks @ratty been through your suggestions and for:

http://a.b.c.d:1400/status/enetports For the relevant beam IP address I get Port=0 Link=1Speed=100FD

Does that mean that it is using the wired network?
 

Thanks @ratty been through your suggestions and for:

http://a.b.c.d:1400/status/enetports For the relevant beam IP address I get Port=0 Link=1Speed=100FD

Does that mean that it is using the wired network?
 

That means there’s a wired connection, but it doesn’t prove that the Beam is actually using it.

Since you're already in the status pages go to http://A.B.C.D:1400/status/showstp. In the top section labelled br0 does it say root port  0 ?

Either way I think you’ll just need to temporarily wire the Beam to your router to get its radio disabled.

 "In the top section labelled br0 does it say root port  0 ?"

No, it says root port 1

Does that confirm it is using WiFi?

Interestingly, the other Beam which is also wired and does have WiFi disabled is also showing root port 1.

What does all that mean? 

 

When you say direct connect to router I take it you mean I need to temporarily move my Beam closer to the router or use a single long ethernet cable?

@ratty sorry to be so useless on this and thanks for your assistance. 

My mistake: “root port 1” is correct in this instance. It means that the active connection is via the Ethernet port and that the device is not the STP root bridge (which would be “root port 0”). Let’s not go any further down this rabbit hole for now. :sunglasses:

 

Since both your Beams are using the Ethernet connection do you still want to disable the wireless? It’s not really necessary.

If you still wish to proceed, unhook the Beam from power and HDMI. Take it to the router and wire it directly with an Ethernet cable. It will only need power; not the HDMI. Once it’s powered up you should be able now to disable its wireless. Wait 5 minutes to make sure the setting ‘sticks’ then unhook it and put it back in the other room.

@ratty No, if they are both using the ethernet my mission is accomplished! Thank you so much for all your help. 

Reply