Question

Help on improving my home setup - (Omada wifi / another boost?)


Userlevel 1
Badge

I have recently changed our home Wifi to TP Link Omada as our existing Wifi didnt reach around the home, I am planning on adding some managed switches too which I think will help with our sonos setup in the long run.

 

I currently have a number of devices hard wired (wifi off), a boost and some on wifi (should be sonosnet)

 

We have had performance issues on and off over the years and hard wiring some of the sonos appears to have fixed it, the office and nursery speakers are hard wired as they are the furthest from the Boost. Would an additional boost help?

 

Since changed to Omada APs, our devices connected by WiFi arent able to play anything, the wired devices are still functioning, these are currently connected to dumb switches.

 

Our network matrix is as below:

 

 

Any advice, suggestions are appreciated. 

I plan to move the location of the boost again as a first port of call. Does anyone use TP Link Omada and know the best settings to use?


49 replies

Hi. Are you saying that you have 'wifi disabled' set on your wired devices? If so then you have semi crippled SonosNet. You should start by re-enabling the wireless radios on those devices.

Why do you think managed switches would benefit Sonos? It isn’t clear to me why that would help.

You have some serious wireless interference there, but we'll come back to that.

I don't think a further Boost would help at all.

First please clarify the position on 'wifi disabled'.

Userlevel 7
Badge +21

Yep, step one is to turn back on the Sonos radios, the WiFi disable doesn’t disable WiFi it turns off the internal radio completely.

Same question on managed switches, why? Is your wired traffic so high that you have to try and manage it to keep from overloading your links?

A wired Sonos with the radio on works almost exactly like a Boost so again, turn on your radios before spending money you may not see any gain from.

 

There are specific, and rare, situations where you want the radios off. Do you have a rack of several Amps, Ports, Connects or ZPs?

Managed switches are not a problem if properly setup. Use STP, not RSTP. Many managed switches default to RSTP.

With respect to the Network Matrix shown, signal strength’s are mostly not great, but easily within the usable range, however, interference is high. I suspect that even WiFi is suffering somewhat. You should be using  only 20-MHz channels 1, 6,and 11. Do you have any ZigBee or Bluetooth devices near the red units?

These are mostly older SONOS devices because the latest devices do not share data with the Network Matrix. I’m not suggesting that older units are a problem, only that wireless issues with newer product are much harder for users to self diagnose because the Network Matrix will become less and less useful as new product is added. 

I’ll agree with everyone else that turning OFF the SONOS radios is generally counter productive because it might limit the flexibility of SonosNet. to work around issues.

Userlevel 1
Badge

Hi. Are you saying that you have 'wifi disabled' set on your wired devices? If so then you have semi crippled SonosNet. You should start by re-enabling the wireless radios on those devices.

 

Yes i did disable Wifi on the wired devices, my previous wi-fi setup (BT Whole Home) provided very poor Sonos performance so I had to wire some devices in to get sound in some rooms. I will re-enable WiFi on my wired devices.

 

Managed switches are not a problem if properly setup. Use STP, not RSTP. Many managed switches default to RSTP.

 

STP is enabled, not RSTP. This was the first thing I tried.

 

Do you have any ZigBee or Bluetooth devices near the red units?

 

In the kitchen I have a zigbee switch near the speaker, boost is near my Hubitat hub with zigbee receiver so this may be the first thing to move!

Since changed to Omada APs, our devices connected by WiFi arent able to play anything, the wired devices are still functioning, these are currently connected to dumb switches.

 

Do you mean the devices connected by WiFi or via SonosNet? I can see just one Roam on WiFi.

Apart from the nasty ambient RF noise levels the matrix shows a SonosNet with a distinctly suboptimal mesh. The Boost is supporting just one node directly, and it takes 3 hops to reach Guest Bedroom (Boost -> Kitchen -> Bathroom -> Guest Bedroom). Re-enabling the radio on the two wired devices with it currently disabled may improve things.

 

I have to ask: why Omada? It’s a business solution with a high level of complexity, not designed for home use. In particular you could find that Sonos devices on WiFi are inaccessible due to subnetting or isolation between network segments. Configuration tweaks may be available in the Omada management console to address this.

Userlevel 1
Badge

I meant on the SonosNet devices, Wifi is the term the Sonos App uses so I chose to use it here :)

 

I chose Omada as it works well for me at work, I am an IT Infrastructure Engineer so am familiar with the setup but translating it to getting a good setup for Sonos is where I am getting stuck.

We use HP Aruba, Omada and Ubiquiti at different sites at work and I preferred the Omada system over the others, so wanted to see if it would improve things at home.

 

My previous Wi-Fi coverage was poor, so I wanted to install Omada to install the coverage around the house, which it has done, but given the issues I am getting with Sonos I may revert back. I can still return my kit and not lose out! Which I am leaning towards, as the system is too complex for the needs at home. I would have liked to add VLANs for my IOT devices but this may be overkill… Something that works solidly is better. Possibly a better Mesh Wifi that the previous BT solution as that was poor at best!

 

What I am seeing today after some changes:

 

  1. Re-enabling “Wi-Fi” (as its called in the Sonos App) to re-enable Sonosnet introduces loops on my wired devices
  2. Removing ethernet and going Wi-Fi only on these devices, works for a while after re-adding the speakers, but they soon lose connection again.

So in hindsight, If i was to start again… what would the best route be?

 

Wireless from the router isn’t good enough to give coverage everywhere, BT Whole Home Wifi performs pretty poor but did have less issues than with Omada.

Does wiring just one Sonos device create loops?  

 

Userlevel 1
Badge

Does wiring just one Sonos device create loops?  

 

As well as the boost or the boost only?

 

Current setup:

 

Lounge / Nursery - wired, wifi (sonosnet) off

Boost - wired

Dining Room (Roam) - Wifi (not sonosnet)

Others - sonosnet

 

 

 

Like many such home solutions Sonos depends on there being a single flat broadcast subnet. No subnetting, no L2 client isolation and no blocks on device discovery. It’s not unusual to run into problems on enterprise grade networks, whether at home or in the workplace.

If re-enabling the radios causes loops then the switch(es) on the paths between the wired units are most probably just blocking STP BPDUs. 

With only Boost wired, what does the matrix look like?

As for alternative WiFi meshes, most home grade systems should be fine at least with the Sonos system in SonosNet mode as all the WiFi needs to do is carry controller traffic. Attempting to operate the entire system in WiFi-only (“wireless”) mode, i.e. without Boost and without any wired nodes at all, could have mixed results. It’s worth a try, if the Omada first gets swapped out for something more friendly, such as Deco, Orbi, Velop, etc.

@wolvesphil,

Here’s one suggestion to maybe consider…

Maybe try just wiring the Boost only to the Omada router and leave every other Sonos Product wireless (with its WiFi adapter enabled obviously) so all then run on their own SonosNet wireless connection and leave your Omada setup to just do its own thing.

Remove the Omada WiFi credentials in the Sonos App network settings (they’re not needed when running all on SonosNet) and try to set a SonosNet channel that is not in use by the Omada network.

You need to check that multicast broadcasts for ‘device discovery’ by the controller App can see the Sonos system when the controller device is connected to any of the Omada access points… sometimes this is where issues can sometimes occur with various mesh systems.

Do not wire any Sonos device to an Omada satellite hub and just see if that perhaps may work better for you.

Remove the Omada WiFi credentials in the Sonos App network settings (they’re not needed when running all on SonosNet) and try to set a SonosNet channel that is not in use by the Omada network.

There appears to be a Roam.

Userlevel 1
Badge

Like many such home solutions Sonos depends on there being a single flat broadcast subnet. No subnetting, no L2 client isolation and no blocks on device discovery. It’s not unusual to run into problems on enterprise grade networks, whether at home or in the workplace.

If re-enabling the radios causes loops then the switch(es) on the paths between the wired units are most probably just blocking STP BPDUs. 

With only Boost wired, what does the matrix look like?

As for alternative WiFi meshes, most home grade systems should be fine at least with the Sonos system in SonosNet mode as all the WiFi needs to do is carry controller traffic. Attempting to operate the entire system in WiFi-only (“wireless”) mode, i.e. without Boost and without any wired nodes at all, could have mixed results. It’s worth a try, if the Omada first gets swapped out for something more friendly, such as Deco, Orbi, etc.

 

If I change setup, Deco is the one I am contemplating most. I like with Omada that I can see more info but I guess I don’t really need to see granular detail if everything just works! And my family would be much happier!

 

I have now set it so only my Boost is wired, tested the wireless devices and they are working well. I have set STP globally on my switches for now rather than on each port, with a lower priority that the Sonos default and things seem happier… Time will tell!

 

The latest matrix is:

 

 

I think moving the Boost may be the next step to improve things.

Remove the Omada WiFi credentials in the Sonos App network settings (they’re not needed when running all on SonosNet) and try to set a SonosNet channel that is not in use by the Omada network.

There appears to be a Roam.

Oh yes, missed that (Thanks @ratty) - in that case the WiFi credentials will need to remain in the Sonos App’s network settings.

Userlevel 1
Badge

Remove the Omada WiFi credentials in the Sonos App network settings (they’re not needed when running all on SonosNet) and try to set a SonosNet channel that is not in use by the Omada network.

There appears to be a Roam.

There is a roam

 

 

I think moving the Boost may be the next step to improve things.

There is still a lot of interference, not only around the Boost, but also surrounding the other devices shown as red on left hand column of the matrix, but I would certainly let things settle for at least 20-30 minutes and keep any Sonos devices at least a metre away from other wireless (and Bluetooth) devices - then perhaps look at changing the SonosNet channel - but always allow time for things to settle down before making any change.

This image may assist you too, as it shows the zigbee channels that can sometimes interfere with 2.4Ghz non-overlapping WiFi channels:

 

 

The latest matrix is:

not happy.

Two apparently wired devices (Nursery and Lounge) still have no wireless content. And there are two root bridges, suggesting fragmented spanning trees. And Office doesn’t seem to have any STP status either. It looks like the system’s broken in two.

Userlevel 1
Badge
 

 

I think moving the Boost may be the next step to improve things.

There is still a lot of interference, not only around the Boost, but also surrounding the other devices shown as red on left hand column of the matrix, but I would certainly let things settle for at least 20-30 minutes and keep any Sonos devices at least a metre away from other wireless (and Bluetooth) devices - then perhaps look at changing the SonosNet channel - but always allow time for things to settle down before making any change.

This image may assist you too, as it shows the zigbee channels that can sometimes interfere with 2.4Ghz channels:

 

 

That graphic is useful, and something I wasn’t aware of! I have changed the settings of my Zigbee Hub and Sonosnet and will see if this makes any difference (when my Sonos speakers are back online as they have since disappeared...)

 they have since disappeared...)

See my post.

Have you refreshed the matrix?  It won’t update unless you come out and go in again (ie re-click the Network Matrix link).  Nursery was originally wired but you have said it no longer is, so I wonder if this is really the current position?

Userlevel 1
Badge

Now only the boost is wired…

What does Office being green mean? Does this mean connected to Boost but nothing else connected via it?

 

@wolvesphil,

After some system changes, I sometimes find power-cycling the Sonos products may often help, starting with switching off all, then bringing them back online, one at a time, starting with the Wired Boost then the next nearest (wireless) device (as the crow flies) and the next and so on and so forth. I then wait half an hour.. it’s sometimes a case of being patient and letting things settle.

Reserving their IP addresses in the routers DHCP reservation table is also a very worthwhile thing to do too, (if not done already?).

Office has jumped onto the WiFi (WM:1 in the controller’s About), quite possibly on 5GHz. 

Now only the boost is wired…

What does Office being green mean? Does this mean connected to Boost but nothing else connected via it?

 

It means it is somehow escaping the wireless interference affecting the rest of your speakers, indicated by the red

Edit: @ratty’s suggestion that it has jumped onto 5GHz is a very plausible explanation.

Userlevel 1
Badge

@wolvesphil,

Reserving their IP addresses in the routers DHCP reservation table is also a very worthwhile thing to do too, (if not done already?).

 

Already done this, I will try a staged reboot, when my son wakes up! He is due his nap soon and the “Nursery” one is used to play white noise…

Office has jumped onto the WiFi (WM:1 in the controller’s About), quite possible on 5GHz. 

Thanks for the explanation, will see Ken’s suggestion of turning all off and then back on bit by bit helps….

Do you have a baby monitoring wireless system?

Reply