Connecting a Sonos through an Aruba WiFi Controller? Here's how:

  • 27 January 2017
  • 9 replies
  • 7684 views

Userlevel 1
Just wanted to share my experience with setting up my Sonos Play 5 with an Aruba WiFi controller.
After many hours of tcpdump'ing and connecting the Sonos to wired networks (with everything working perfectly!), I found that by default, Aruba WiFi controllers (mine is a 225 running version 6.4.4.8-4.2.4.4_57496) drop broadcast & multicast traffic between attached wireless clients, which is used by the Sonos Controller app to find the Sonos.
There is a setting in the Virtual Controller under "Networks" (usually the name of the SSID you've created), WLAN Settings (click "Show Advanced options"), then "Broadcast Filtering". Mine was set to "All", and a quick change to "Disabled" + reboot, the app now found the Sonos with ease. Hope this helps someone not spend 4 hours on their Christmas morning trying to debug their brand new Sonos Play 5 ;-)

Steve

9 replies

Thank you so much - I can have my life back now 🙂.
Thanks!
Thank you Steve! You saved me more then 4 hours of searching. Spent about 2 hours until I found your post here. I see posts that mention AirGroup configuration but as I do not have that configured I continued looking. Then I read this here and I have Aruba AP105's with the "Broadcast Filtering" option set to "ARP". I did the same as you, set it to "Disabled" and rebooted the AP's and it worked like a charm. Thanks again Steve!
Thank you Steve appreciate your post. Saved me hours of trial and error.
Thank you for posting this! This worked for us too. Using Aruba IAP315.
Maaaaan this was crazy helpful, thanks!
Thanks so much Steve! This worked perfectly for my IAP-105's ?
Just wanted to share my experience with setting up my Sonos Play 5 with an Aruba WiFi controller.
After many hours of tcpdump'ing and connecting the Sonos to wired networks (with everything working perfectly!), I found that by default, Aruba WiFi controllers (mine is a 225 running version 6.4.4.8-4.2.4.4_57496) drop broadcast & multicast traffic between attached wireless clients, which is used by the Sonos Controller app to find the Sonos.
There is a setting in the Virtual Controller under "Networks" (usually the name of the SSID you've created), WLAN Settings (click "Show Advanced options"), then "Broadcast Filtering". Mine was set to "All", and a quick change to "Disabled" + reboot, the app now found the Sonos with ease. Hope this helps someone not spend 4 hours on their Christmas morning trying to debug their brand new Sonos Play 5 ;-)

Steve

Hello Steve,

Your solution saved me some hours...
Thanks
Kurt
Genius! Steve_c_c.

I have Aruba Central and you have to go here to disable Broadcast Filtering:

  • WIRELESS MANAGEMENT
  • Edit the Network you're trying to join (click the pencil on the right).
  • Expand "Broadcast/Multicast"


  • Click the drop down and choose DISABLE:
  • Save your changes.
After you connect your speaker you can turn this back on and the system works just fine.

Reply