Answered

BEAM: Connecting wired network kills network access for all devices.

  • 18 July 2018
  • 6 replies
  • 2759 views

I'm still debugging this but wondered if anyone else has come across it.

My Beam is all installed via WiFi and I'm very happy with it. However I thought I'd hard wire it to my network as I have fixed connections to most of the permanently connected devices. Unfortunately (tried 4 times now) when I connect a network cable after a few seconds all my home network dies. Symptoms from another PC is that I can no longer ping the gateway (192.168.0.1) any more. Unplug the Beam and it recovers.

Network is Virgin Media SuperHub -> TP-Link T2600G switch -> devices.

Any thoughts would be appreciated.

Thanks - David
icon

Best answer by ratty 18 July 2018, 17:14

Presumably you have another wired Sonos device. In that case wiring the Beam is almost certainly creating an undetected network loop, resulting in a broadcast storm. In the TP-Link switch you'll need to enable STP (not RSTP).



Background reading: https://en.community.sonos.com/troubleshooting-228999/sonos-and-the-spanning-tree-protocol-16973
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Presumably you have another wired Sonos device. In that case wiring the Beam is almost certainly creating an undetected network loop, resulting in a broadcast storm. In the TP-Link switch you'll need to enable STP (not RSTP).

Background reading: https://en.community.sonos.com/troubleshooting-228999/sonos-and-the-spanning-tree-protocol-16973
Do you lose connectivity for everything, both with wired and wireless connections? It sounds like there may be a loop, causing a broadcast storm. Probably packets coming in on the wire and being sent back via WiFi, or the reverse, or both at once. As a test you could try disabling Wi-Fi with the Beam connected via wire, to verify if it is because both network connections are up at one time.

If that is the case, the Beam may need Wi-Fi disabled while wired Ethernet is connected, but I don’t know how to do that yet. You also log into your Wi-Fi router and add the Beam’s MAC address to a blocked list, so that wired connectivity is the only one functioning. Doing this should leave the Beam’s *direct* wireless communication with other Sonos devices intact.
the Beam may need Wi-Fi disabled while wired Ethernet is connected
Disabling the radio on the Beam would be an unsupported configuration. It would doubtless also kill the connection to any surrounds/SUB which had been bonded to it.

You also log into your Wi-Fi router and add the Beam’s MAC address to a blocked list
The suspected network loop doesn't involved the router's WiFi, hence MAC filtering is irrelevant.
Whoops, I had comments blocked in my browser, didn’t see the previous reply. As Ratty said, if you have other wired Sonos speakers, that is probably the root of the issue. Sonos speakers intercommunicate wirelessly as a mesh, so more than one wired connection to any one of them is probably functionally equivalent to having multiple wired connections to a single device.

As Ratty noted above, spanning-tree is a good option here, if supported on the LAN.
Good afternoon,

That may well be it as I have a Sonos Play:1 connected directly to the router. Many many thanks. I'll take another look at the setup tonight.

Regards - David
Many thanks to ratty (and Dayv) for their answers.

That was the cause and I had spanning tree disabled on the switch. All sorted now.

Cheers - David