Answered

Audio Cutout - but only when sourcing from playbase or playbar

  • 17 February 2018
  • 32 replies
  • 948 views

Userlevel 1
Badge
I have a playbar on one tv and a playbase on another tv, also several other play:1 play:3 and connect:Amp.
When I use my phone or laptop as a source and switch to 'party mode', everything is perfect - always.
When I watch either TV with only it's playbase or playbar - it works flawlessly.
If, however, I attempt to group any other speakers to either the playbase or playbar sourced by TV sound - the audio cuts out every few seconds. This just started fairly recently - I recall watching some football this way (party mode) with no issues the entire evening - but by the time playoffs rolled around - it's not usable in that way. I'm unable to think of any significant changes that have been made since I recall this working - maybe the playbase is that new - it arrived on christmas day. :)

Another interesting thing to note is that the source playbase or playbar (depending on which tv I want to broadcast) never cuts out - only the satellite grouped speakers cut out - and they all cut out together.

This occurs with 'smart app' sourced audio as well as DTV sourced audio - I'm quite confident it's not a tv/receiver audio output issue in that the two setups are completely different but are behaving identically - also - the 'main' speaker never cuts out.

I tried switching between BOOST and home wifi - no change.
Only a single play:1 is not hardwired to the Gigabit Cat6e LAN.
I tried disabling the wificontrol - no change.
External interference is unlikely - I don't have many neighbors nearby.

I ran the diagnostics: 8505842
Currently playing Netflix Smart TV App in Master Bedroom - grouped in party mode and cutting out everywhere but MasterBedroom Playbar.

Associated ZP: 192.168.5.235
---------------------------------
PLAY:3: Bathroom
Serial Number: B8-E9-37-D0-90-8A:1
Version: 8.3 (build 40549090)
Hardware Version: 1.8.1.3-1
IP Address: 192.168.5.172
WM: 0
OTP:
---------------------------------
PLAY:1: Kitchen (L)
Serial Number: 5C-AA-FD-4D-FE-A2:F
Version: 8.3 (build 40549090)
Hardware Version: 1.8.3.7-1
IP Address: 192.168.5.235
WM: 0
OTP:
---------------------------------
PLAY:1: Kitchen (R)
Serial Number: 5C-AA-FD-4E-01-F2:D
Version: 8.3 (build 40549090)
Hardware Version: 1.8.3.7-1
IP Address: 192.168.5.243
WM: 0
OTP:
---------------------------------
PLAYBASE: Living Room
Serial Number: 5C-AA-FD-32-F1-5D:8
Version: 8.3 (build 40549090)
Hardware Version: 1.14.1.11-1
IP Address: 192.168.5.196
Audio In:
WM: 0
---------------------------------
PLAYBAR: Master Bedroom
Serial Number: 5C-AA-FD-17-9A-19:D
Version: 8.3 (build 40549090)
Hardware Version: 1.9.1.10-1
IP Address: 192.168.5.241
Audio In: Dolby Digital 2.0
WM: 0
OTP:
---------------------------------
PLAY:3: Office
Serial Number: B8-E9-37-DC-5C-42:8
Version: 8.3 (build 40549090)
Hardware Version: 1.8.1.3-1
IP Address: 192.168.5.208
WM: 0
OTP:
---------------------------------
CONNECT:AMP: Patio
Serial Number: 5C-AA-FD-EA-20-AE:D
Version: 8.3 (build 40549090)
Hardware Version: 1.17.3.1-1
IP Address: 192.168.5.60
WM: 0
OTP: 1.1.1(1-17-3-2.1)
icon

Best answer by kphagen 19 February 2018, 21:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

32 replies

Userlevel 1
Badge
Are others able to replicate this issue when grouping other speakers with a playbase/bar tv source audio or is it just me?

I think I may try unplugging them all and see if maybe if all I have is a playbar and a play3 online - will it work, then if that works, bring one more online, etc... I just joined the beta program - maybe there's hope inside that...
I have the same issue with TV sound and just posted a message. Two surrounds and any grouped speakers cut out but Playbase works fine. I am pretty sure it is since the latest app/firmware update. Never had issues before.
Hopefully a solution will be forthcoming.
Userlevel 1
Badge
Update:
I unplugged everything except for 1 playbar and 1 playbase.
I grouped playbar to playbase - no audio cutouts.
I grouped playbase to playbar - no audio cutouts.

Diagnostic (success): 8511677

Plan: I'll add in the connect:amp and see what happens, run diagnostic, post here.
Repeat with one more speaker until audio cuts out, then see if it's a quantity of sonos issue or a specific speakerset that's to blame.

K
Userlevel 1
Badge
Update2:
So far so good, I added the connect:Amp to the mix.
If anyone's following: playbase is sharing audio from direcTv - olympics; playbar is sharing audio from smartTv Netflix app - guardians of galaxy 2.

playbase(wired) + playbar(wired) + connect:amp(wired) = no audio cutouts when grouped to either playbase or playbar.

Diagnostic (success): 8511789

On Deck: Adding in a Play:3 (wired)...
Userlevel 1
Badge
Update3:

That broke it - I didn't even have to group it, simply bringing the Play:3 online resulted in audio cutting out on the grouped speakers.

playbase(wired) + playbar(wired) + connect:amp(wired) + play:3(wired) = audio cut outs - did not even have to add play:3 to group.

Diagnostic (fail): 8511869

Plan: I'll unplug just the play:3 and see if it gets back to good.
Userlevel 1
Badge
Update4:
With the Play:3 unplugged, the system did not roll back to perfect - however the frequency of the cut-outs appears to have diminished from every 5 or so seconds to maybe every 45 sec or minute...

Diagnostic (fail): 8511977
This Diagnostic should align with Update2 diagnostic above where the sound (allegedly) did not cut out.

Possibly I was not patient enough to notice actual skipping previously during update2 above.

Plan: I'll drop the connect:amp out of the set up, wait 5 minutes and then see if it can go a full 5 minutes with no cutout.
Userlevel 1
Badge
Update5:

Regressing back to only the PlayBar and PlayBase - I was able to make it through over 5 minutes without any noticeable audio cut outs.

Diagnostic (success): 8512149

Plan: I'll keep the connect:Amp out of the mix and add just the same Play:3 as earlier back in and see what happens.
Userlevel 1
Badge
Update6:

Adding in the Play:3 does not appear to have broken anything - I was able to enjoy audio for over 5 minutes without any cut-out.

Diagnostic (success): 8512225

For this round, I'm only leaving the playbar/playbase grouped and simply bringing the other units online.

Plan: Adding an additional Play:3(wired) to the mix and will give it a listen, keeping the connect:amp out of the mix for now to see how far I can get. My theory is that adding this 4th component will result in the noticeable audio cut-out issue.
Userlevel 1
Badge
Update7:

Interesting - no audio cutouts in over 5 minutes with

playbar + playbase + play:3 + play:3

Diagnostics (success): 8512324

Plan: For this next test, I'm going to keep everything as-is and simply group both play:3 components and see if it holds.
Userlevel 1
Badge
Update8:
As expected, I don't believe that grouping/ungrouping has any significant impact on this issue. It's been over 5 minutes with no audio cut out.

Diagnostics (success): 8512385

The issue I'm having appears related to either a quantity of devices or a combination of devices (or some specific faulty device). Possibly different components have different 'weights' where eventually the total component weight is too much for whatever the problem is - if that theory is accurate, the connect:Amp is the heavyweight in my setup.

I only have a pair of Play:1's and the connect:Amp left to test with.
I think I should fully expect it to fail if I add the connect:Amp - since it failed previously with that component and just one of the play:3 components.

Plan: I think I'll learn more with this next test if I add one Play:1(wired)
Userlevel 1
Badge
Update9:

Still going strong after 5 minutes of bringing a Play:1 (wired) to the party. Certainly is making a strong case for giving my Connect:Amp the stink-eye.

Diagnostic (success): 8512430

Plan: I'm going to bring in the other Play:1 (wireless) and at this point I'm kind of expecting it to work fine and pin the tail on that Connect:Amp. If that holds, then the Q is there a specific problem with *my* connect:AMP, or is it something wrong with all of them - or something else entirely 🙂.
Userlevel 1
Badge
Update10:

No issues after adding the second Play:1(wireless) - I'm going to add them (everything) to the group and let it ride a bit longer.

Diagnostic (success): 8512483
Userlevel 1
Badge
Update11:

I hope all of this is helpful.

It's a full on party mode, all components except the connect:AMP are enabled and grouped and playing audio from the direcTV signal sourced from the playBase. No audio cutouts during the last 10 or so minutes.

Diagnostic (success): 8512532

I'm convinced now that when I add the connect:Amp, I'll start hearing a lot of audio cut-outs.
Further, I expect the cut-outs to disappear after unplugging the connect:Amp...

I'll let you know in a few minutes! I'm certain you are all on the edges of your seats by now.
Userlevel 1
Badge
Yep - it's cutting out within seconds of the connect:Amp coming on line...
Userlevel 1
Badge
Diagnostic (fail) - 8512560
Userlevel 1
Badge
Update12:
Pulling the plug on the connect:Amp put the system back to good (no audio skips).

One thing to recall - broadcasting music sourced from an iPhone or MacBook is OK with the connect:Amp enabled.
Only when the audio is sourced from either the PlayBase or the PlayBar does the audio cut-out occur.

Help me Sonos Support - you're my only hope!

CONNECT:AMP: Patio
Serial Number: 5C-AA-FD-EA-20-AE:D
Version: 8.3 (build 40549090)
Hardware Version: 1.17.3.1-1
IP Address: 192.168.5.60
WM: 0
OTP: 1.1.1(1-17-3-2.1)
Userlevel 1
Badge
Update13:
On phone with tech support - they're pretty great btw. Thanks John.

They had me relocate the AMP, so I dropped one of the Play:3 and leveraged the network cable and powercable and switch for that component to take those potential faulty connections out of the mix also.

Next step is I need to review my router configuration with regards to 'Spanning Tree Protocol' before we get to the next level.
Userlevel 7
Badge +19
Hi there, kphagen. Thanks for posting and welcome to the Community. From what you've posted so far, it seems the best course of action would be to give our support technicians a call to troubleshoot this with you in real time. They are able to work with you in real time through a remote session and get a closer look at what is happening with the CONNECT:AMP.

I see you are working with a Luxul Router, what is the make and model of that router and the switch you are using? Thanks!
Userlevel 7
Badge +19
Glad to see you are on the phone with support! Feel free to reach out should you run into any other problems.
Userlevel 1
Badge
Update: I'm still struggling with my router support to review recommended settings - but I've done some more isolation.

I have an AC3100 (xwr-3100) Luxul router and two High Power AC1900 Dual-Band Wireless Access Points (xap-1510).
Also included is a switch that runs most of the home LAN connections: Netgear ProSAFE GS748T

In my media closet is another switch, CISCO sg100-16 (v2). This is the switch that the AMP was using to get on the network. I'm still working to get access to this switch but - here's the update.

When I moved the connect:AMP off of this switch - the problem persisted. However, I then turned the switch off and I'm not getting the audio cut-out. There appears to be some angry talk between the CISCO and the AMP which brings things down.

Here's a diagnostic (success) without the CISCO but with the AMP: 8513952
Userlevel 1
Badge
Update: That's it, once I powered up the Cisco - the cut-outs kicked back on. I'll work to gain access to the admin of the Cisco and make the suggested modifications - or I'll replace this component with something else - i think i was trying to make use of some spare parts I had lying around...

I think you guys have this scenario in your diagnostic lib already: 8513004
Userlevel 1
Badge
Rather than burn any more of my time on it (President's Day is over) - I saw this on sale and will just get the Cisco off my network for good. https://www.amazon.com/NETGEAR-Ethernet-Unmanaged-Lifetime-Protection/dp/B01AX8XHRQ/ref=sr_1_3?ie=UTF8&qid=1519143619&sr=8-3&keywords=16+port+gigabit+switch

It is supposed to arrive tomorrow - so maybe I'll have new news to report by the weekend.
Userlevel 1
Badge
Update: Well, that was a bust. Maybe it's one of my downstream media components that's not playing nice with the connect:AMP. I probably should have tried pulled those unessential connections before buying a new switch...
Userlevel 1
Badge
Not sure how many times in my life I need to learn this lesson, but clearly it was at least one more time.
I paid someone to set up my network for me and I think I just invested the same amount of time in unraveling it and understanding it enough to know they did some dumb stuff - but it sure does look neat, tidy and tight! :)

So, to recap, the skipping kept coming back anytime I enabled my unmanaged media closet switch - which in turn would bring the two WAPs online. If I disconnected the two WAPs, all was well - but when either one or both of them were plugged in - I'd start to get cut outs. I'm still baffled as to why this only occurred when audio was sourced from the playbar/playbase AND when a connect:AMP was online.

Anyway, I was unable to gain access to my main router and wap manager (sigh - they make "support" sound so good when they're selling it and you're tired of messing with it). But, what I could get into was my managed Netgear GS748T. After reading this thread, https://en.community.sonos.com/troubleshooting-228999/sonos-and-netgear-managed-switch-6761940/index1.html#post16199215 , I decided to give it a try.

It appears to be in direct conflict with the guidance being offered by Sonos documentation which writes a fairly confusing novel as to how one should Enable STP. This guy very clearly lists it out in a few steps.
Boom! No cut outs, WAPs back online - everything is on.

My initial settings on the Netgear 748T (when it was not working):
Spanning Tree State: Enable
STP Operation Mode: RSTP
Forward BPDU while STP Disabled: Disable

After making only the following changes - my issue was resolved.
Spanning Tree State: Disable
STP Operation Mode: STP
Forward BPDU while STP Disabled: Enable

I know I don't fully understand STP even though I've read enough that I probably should - so I probably don't know what I'm missing out on - but it doesn't seem to have any side effects at this time.

@Support : Here's my current diagnostic: 1796207156

Kevin
Userlevel 1
Badge
It's been a week and no issues!
#closed