Answered

Sonos Roam bluetooth 'hiccups'

  • 13 September 2021
  • 3 replies
  • 39 views

Sonos Roam connected via Bluetooth with iPhone XR with iOS 14.x.

Sonos app updated, Roam firmware updated.

I regularly experience what I call ‘hiccups’, that’s to say every few minutes, with Roam in Bluetooth mode, the audio interrupts for less than a second and than restarts.

It happens on a regular basis, no problem in Airplay or in the Sonos system, though.

 

I’ve already sent the diagnostic (1334768659) shortly after the last event.

 

Anyone else?
Any idea?
Thanks a lot

icon

Best answer by GuitarSuperstar 13 September 2021, 17:56

In your iPhone’s Bluetooth settings, disconnect the Roam and “Forget this device”. Then reboot the Roam by following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Pair the iPhone to the Roam over Bluetooth and test again.

View original

3 replies

Userlevel 7

In your iPhone’s Bluetooth settings, disconnect the Roam and “Forget this device”. Then reboot the Roam by following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.

Pair the iPhone to the Roam over Bluetooth and test again.

Userlevel 7

Hi 

Try resetting Network Settings on your iPhone:

Goto > Settings > General >scroll down to Reset > Reset Network Settings.

Note: Your cellular will reconnect automatically; you may have to re-enter your WiFi password. 

Check to see that no other BT capable devices are in close range causing interference. Make sure the music on your iPhone is stereo and not Apple Lossy if downloaded from iTunes/Apple Music. 

If none of what I or @GuitarSuperstar has recommended (including what you submitted for diagnostics) resolves the issue I suggest you reach out to Apple Support. They may have you factory reset your iPhone which involves erasing all contents and setting up as new or from a backup that was prior to when the issues began.  In any case you’ll get a fresh iOS update. Assuming the issues are not hardware related which means submitting your iPhone for service.

@GuitarSuperstar, it seems that your suggestion did the trick! :thumbsup_tone2:

I’ve listened now to several songs in a row and there has been no interruption, so it seems alright.

Just curious, though, if you have any insight of what the problem could be. Just ‘technically’ curious…

I thought that the first occurrences of the issue happened after I’ve associated the Roam also to my iPad, so I’ve made ‘forget’ the Roam to the iPad, too, before reconnecting it to the iPhone.

In any case, it seems solved. Do you think I must expect I’ll have to replicate the procedure from time to time?

 

Thanks a lot

MrG

Reply