Answered

Sonos One downgrade


Userlevel 1

Accidentally upgraded to S2.  Need to downgrade my Sonos ones to be compatible with S1 controller.  Reset and they are at flashing green, but S1 controller add device option is greyed out.  So mad! Need help!

icon

Best answer by Smilja 15 June 2020, 19:31

View original

42 replies

Userlevel 7
Badge +17

According to all I have read rolling back the upgrade to S2 is not possible.

Who are you mad with?

Userlevel 6
Badge +14

There is no user accessible method to downgrade anything Sonos.

Maybe ‘central control’ at Sonos HQ can do it,  but convincing them to do it will be a task-and-a-half.

Userlevel 1

According to reading, I should have been able to reset my Sonos Ones to factory setting and that would have allowed me to read to an S1 controller.  The good news...after additional reading, I was able to get all of my devices to the S2 controller so no more issues with seamless streaming.  YAY!!!

Userlevel 7
Badge +17

Very curious where you might have read that downgrading is possible - I’ve always read it is not possible. Do you have a link?

Very curious where you might have read that downgrading is possible - I’ve always read it is not possible. Do you have a link?

 

Is this process reversible?

While we don’t recommend downgrading your products to S1 after updating to S2, it is possible to downgrade by resetting the S2 products to their factory settings and adding them to an existing S1 system. An existing Sonos product running S1 software is required to downgrade an S2 product back to S1. Note that all settings and preferences will be lost when downgrading a product from S2 to S1.

 

Set up separate S1 and S2 Sonos systems

Userlevel 3
Badge +4

@mertoncm regarding “downgrading”: i have been able to move a device that had been upgraded to S2 over to an existing S1 system:  playbase upgraded to S2, factory reset, open S1 controller app with existing S1 device(s), add device with “add product.” 

i can’t tell from what you’ve described if your S1 controller app is joined to an existing S1 system or not.  if it isn’t then that will be your problem as i’m sure Sonos won’t want users to setup completely new S1 systems using devices that have been upgraded to S2.

if you do have an existing S1 system and it won’t let you add the device it might be worth resetting the S1 app and connecting it to the system again and see if that clears up the issue.

I got the update message today, and I did not consider that it might put my existing system into an inconsistent state. If I had written the specification I’d make sure there was a pretty big warning that you’re going to break existing functionality if you accept the update on a mixed legacy/modern network.

Back to resetting Play:1 and Play:3 speakers so they’ll play nice with my gen 1 Connects. It can be done, but I figure I’m done updating my Sonos system.

Userlevel 2

Installed Sonos on new Windows 10 PC and selected the Sonos S2 App on PC (without thinking and without any warning as to consequences - after all Sonos always just worked and I forgot all about the tech behind it - that was one of the biggest selling points) - I then connected my first Play:1 bluenote - and I did the usual system update.

Then I connected my old Play:5 and that’s when I realised my mistake...!

I removed the S2 App and installed the S1 App - Play:5 works and my other Play:1 bluenote works no problem - but the original that got upgraded by the S2 App is now not compatible and installing the S1 and S2 Apps on Phones and PCs (really!) just ends up in some catch-22 of complaints about incompatibility however I try it.

I’m now down a speaker...how do I get the old Play:1 back to to S1 OS - I’ve tried the factory reset (holding down of play/pause and + as you plug in) and it seems to remain on the S2 OS and is now incompatible.

Unless I am missing something obvious, this is a total mess, I know I’m behind the initial wave, but the tsunami will come when those users who, like me, forgot about the tech because Sonos was so good, begin to ‘upgrade’.

Help?

Userlevel 7
Badge +22

Try this:

Factory reset the device you want on S1, turn off all other Sonos devices, then run the S1 mobile app and set up a new system. That should put the S1 firmware onto the device. I think.

Userlevel 2

Thanks for the response Controlav,

Although I had previously tried your suggestion, I had another go at the Sonos today just to double check.

Something was different this time around - all the devices needed to be re-registered again, message saying they were previously part of another Sonos setup - and all of them then went on and behaved as expected.  Unless something was done centrally to my account I cannot understand what exactly changed.   

But all are now back working on S1 and my Play:1’s and Play:5 are pals again - one day I’ll get over the shock of the near obsolescence threat, something will make saying goodbye to the Play:5 worthwhile, and I’ll buy another Sonos product.

Thanks again - and sorry I cannot be much help to anyone trying to downgrade from S2 to S1 - all I can say it is definitely possible for a Play:1.

 

 

I had a similar issue. Accidentally upgraded to S2 and it killed my ZP80 and 100. So went to downgrade through app which didn’t work so factory reset both my Play:1 devices. After a while they both disappeared from my android S1 app so then went to add through app again and both were detected as new devices. Selected to setup first and pressed the play and vol+ buttons, heard chime, let go, app detected this and went to connecting screen and sat there and timed out and errored. Tried the same for other Play:1 and it did the same.Called support and they asked me to reboot router even though other devices were connecting to the wifi fine. Anyways rebooted router (and rebooted my phone while I was at it), factory reset both play:1 devices so they were flashing green again and this time it went through fine. Support guy explained the connecting stage is when it’s trying to communicate with router and internet. Must have been a stale session or the router remembered the mac addresses of the devices before and was trying to connect with them in some way the Play:1 didn’t like or something. Anyways all dandy now and devices all back on to S1 and working fine.

I’ve attempted multiple times, but I have been unsuccessful, due to 1) products (Play:1 and Connect) will say they are incompatible with S1 after factory reset, and 2) existing S1 controller forces you to upgrade.

My music library is huge and has taken years to accumulate. It includes FLAC and mp3 among others. Admittedly, some of the FLAC file bitrate sampling is larger than what Sonos requirements allow. However, after upgrading to S2, I could not view most of my library after indexing, and the files I could play cut out after 10 seconds, would skip to the next song, and do it again and again. Errors were my folder (which is on a PC directly plugged into my router) would drop offline, lose connection, and sometimes could not buffer properly--this would happen even on small mp3 files while playing on a Sonos Connect that was hardwired via ethernet to the same router as the PC with the files!

 

So I also attempted to remove all Sonos S2 controllers from phones and PCs. Install S1 controllers and factory reset all Sonos products, and while recreating the new system, each product would say it is incompatible with the controller. This happened whether it was an Android or PC controller.

 

At this point, I’m looking for a buyer who uses Sonos and music services--I don’t--but apparently it is the only way it will work with the new S2 app.

Userlevel 7
Badge +17

@peter334 I’ve read at least one of your devices must still be on S1 to be able to revert the rest to S1. I do not see you mentioning this. 

@peter334 I’ve read at least one of your devices must still be on S1 to be able to revert the rest to S1. I do not see you mentioning this. 


First para: I factory reset all three products/devices.

Userlevel 7
Badge +17

I’m not sure this means they are on S1 though. Maybe someone else knows this?

Sonos customer service inadvertently upgraded me to S2 and I am livid to say the least.  NEVER trust Sonos customer service.  I am looking at maybe a Bose or other setup for my living room now.  Suggestions anyone? 

Userlevel 7
Badge +17

If the upgrade happened against your will, you have a right to be angry, certainly if you now own a system that’s part S1 and part S2. If that’s not the case, I do not see any big disadvantages in an S2 system.

On the other hand: if Sonos did this and you do not want it, you can ask them for a solution.

Sonos customer service inadvertently upgraded me to S2 and I am livid to say the least.  NEVER trust Sonos customer service.  I am looking at maybe a Bose or other setup for my living room now.  Suggestions anyone? 

According to your profile you have an Arc.  This can operate only on S2, not S1.  Your other products listed are S2 compatible.  Would you have been less livid to have been left on S1 and unable to use your Arc?  Good luck with Bose.  That is assuming that that your post is genuine - it certainly doesn’t make much sense.

Userlevel 7
Badge +17

@Guru0006 Right. With the Arc you need S2, so the upgrade wasn’t inadvertently, it was to get your system on the same software to get them working together, probably the solution to having an s1 system not connecting to an s2 only Arc.

Can you tell what problem you have with owning an s2 system?

Back here that poster was complaining of nothing but trouble with S1. Here he was earnestly awaiting a backordered Arc (which of course requires S2).

There’s no pleasing some folks… :frowning2:

I have an Arc and gen 3 sub upstairs on S2.  That was not my issue.  I have a play5 and sub gen2 downstairs I wished to keep on S1 and sadly that is no longer possible.  I still have yet to get them to work even on S2 but am so disgusted with Sonos at the moment they are just sitting in the corner unplugged at the moment. Yes S1 has issues but I seem to have even more issues with the S2 app.  At least that is my experience. 

BTW I wanted to do this in order to keep both systems as separate as possible.  In this case I had them on different apps which I loved for the short time I had it. 

Successfully downgraded Boost from S2 to S1. Boost can't be setup on new S1 system first. Setup Play 5 first and add Boost to that existing system. Powered off Sonos One product that is on S2. Rebooted internet router before the downgrade. Now successfully running S1 and S2 systems.

I can confirm this works although you do need an S1 device on the network. Bought a Connect cheap from eBay and downgraded my two PLAY1 and PLAY3 speakers. Tried without an S1 device and it did not work. 

Userlevel 2
Badge

What a mess.   Sonos should have built a “legacy” option into S2 units, so users could easly run them as S1 units and in A SINGLE S1/S2 APP move S2 units into an S1 group.    Sure, freeze the S1.  minimal or no bug fixes, certainly no new features.  But make it easy for users to have both S1 and S2 units.  Their most loyal customers will have both.  In fact, a single app with 2 groups of units (s1 and s2) would ENCOURAGE users to upgrade units to S2… they would constantly see S2 features the S1 units don’s support.  Much better approach than the constant nagging upgrade messages S1 users get.

@RentalGuy . There is no such thing as an S1 unit or S2 unit.

The reasons for the S1 / S2 split have been explained numerous times. It isn't going to change. 

 

 

 

Reply