Sonos App controls no longer appear on your lock screen


After updating to 9.0 on iOS, I am getting the message "Sonos App controls no longer appear on your lock screen" on all my updated devices. The lock screen controls stopped working on all my controllers with above message.
I do not have any other music player running nor I have any sort of voice over configured. Settings for the app are correct with both hardware volume control and lock screen controls enabled on all devices.
icon

Best answer by Tom526 11 July 2018, 17:52

That's a limitation now due to the addition of AirPlay 2: https://www.sonos.com/en/contentsearch?fdid=9-0

"Alert: Changes to Lock Screen Controls for iOS

It will no longer be possible to control your Sonos system from the lock screen of your iPhone or iPad, including use of the hard volume buttons from the lock screen, if you have an Apple TV or other AirPlay-capable non-Sonos devices in your household with AirPlay enabled. It is still possible to use hard volume buttons from within the Sonos App."

View original

212 replies

Userlevel 2
Badge +4
That's a limitation now due to the addition of AirPlay 2: https://www.sonos.com/en/contentsearch?fdid=9-0

"Alert: Changes to Lock Screen Controls for iOS

It will no longer be possible to control your Sonos system from the lock screen of your iPhone or iPad, including use of the hard volume buttons from the lock screen, if you have an Apple TV or other AirPlay-capable non-Sonos devices in your household with AirPlay enabled. It is still possible to use hard volume buttons from within the Sonos App."
Userlevel 1
Badge
This is a real shame. It seems we gain functionality on the one hand, and lose it on the other. Mind I'm not as bothered about the lock screen as I am losing control from Apple Watch, which loses out also as far as I can tell.
Thanks Tom526. What I do not understand: Yes, I do have an apple TV, but I don't have a single AirPlay2 capable device in my household, so I'm gaining nothing, but I still see the loss of the functionality?
Userlevel 1
Badge
martin.altorfer wrote:

Thanks Tom526. What I do not understand: Yes, I do have an apple TV, but I don't have a single AirPlay2 capable device in my household, so I'm gaining nothing, but I still see the loss of the functionality?



You can disable Airplay functionality if you don't need it, which should bring the controls back:

https://support.sonos.com/s/article/3381?language=en_US
Jack Hennety wrote:


You can disable Airplay functionality if you don't need it, which should bring the controls back:
https://support.sonos.com/s/article/3381?language=en_US



Yes, but I'm using Airplay for the Apple TV, so disabling is no option. But since I have no sonos devices supporting AirPlay2 it seems I am one of those guys loosing something really nice with this update.
Userlevel 1
Badge
I do not have any AirPlay 2 Sonos devices and I also lost the iOS Lock Screen control for Sonos which is not ideal. I could not find an article on how to disable AirPlay in the Sonos app.
Userlevel 1
So, it’s not only we don’t get AirPlay 2 on our 1000€+ systems, but also we got ripped off controls, too. It’s quite a fckup, isn’t it?
Userlevel 7
Badge +21
Are you planning on using airplay 2 anywhere in the house? If not, you can set things so that your lock screen controls will come back.

https://support.sonos.com/s/article/3381?language=en_US

edit: Just realized I'm only repeating what's already been said. oops.
Where can one only disable Airplay2 but keep Airplay1 on iOS 11? I still need Airplay1 for my AppleTV. That support article doesn't mention it. Thanks.
Badge +1
I have only two Play 1s in my kitchen, how do I get the lock screen functions back please on my iPhone/iPad?
Userlevel 1
Badge
That support article was not helpful for me, unless I missed something.

I have lock screen controls enabled in iOS on my iPhone (was always enabled) but Sonos still warned me that they would not work with this new version and they don’t work. I don’t have any AirPlay 2 devices. I do have two AirPlay 1 devices on my home network which my Sonos Play:1 speakers are also connected to.
I have the same issue. AirPlay is disabled, lock screen controls are set to "on" but I still can't use the volume buttons when on lock screen.
Just realized my Apple TV had AirPlay turned on. Once I turned it off I was able to use Sonos on the lock screen.
Badge
This is a real shame, though I did just learn something I hadn't realized before: adjusting the volume also adjusted my phone's volume. I don't understand why that would be nor why we can't have this functionality AND AirPlay. I sure as heck don't want to disable all AirPlay throughout my house because we use it to show things on the TV.
Userlevel 1
This is so extremely disappointing! Sonos needs to give users the choice to enable or disable airplay functionality. Sonos controls in the lock screen was one of the main things that sold me on Sonos!! Sonos you NEED to fix this!!!
Please help and take me back to how things were before I did the app update. I don’t need any of this functionality. I can’t figure out to disable AirPlay like it mentions in the article.
The article says I can "disable third-party AirPlay endpoints and continue using lock screen control," but doesn't explain how. How exactly do I do this? Great products and experience otherwise. Thanks
PhillyGreg wrote:

Just realized my Apple TV had AirPlay turned on. Once I turned it off I was able to use Sonos on the lock screen.



I just did this, hoping that lock-screen control would reappear, but it did not. Could there be something else one has to do on one's iPhone, iPad or Mac? (This change is, generally speaking, extremely annoying!)
I worked it out !
I simply unplugged the apple TV box that I never use anyway.
Then went to sonos app
More tab - settings - advanced settings
Then “Reset Controller”
The Lock screen now works again.

Hope this helps out others.
AdamPB wrote:

I worked it out !
I simply unplugged the apple TV box that I never use anyway.
Then went to sonos app
More tab - settings - advanced settings
Then “Reset Controller”
The Lock screen now works again.

Hope this helps out others.



Thanks a lot, Adam! This worked for me as well. (Still, I am very annoyed to have had to disable AirPlay on my Apple TV, which is something I occasionally enjoy using!)
You can’t turn airplay off on an iPhone/iPad. You have to unplug any airplay enabled devices.
melvimbe wrote:

Are you planning on using airplay 2 anywhere in the house? If not, you can set things so that your lock screen controls will come back.

https://support.sonos.com/s/article/3381?language=en_US

edit: Just realized I'm only repeating what's already been said. oops.


No, you can’t turn off Airplay. You have to unplug all airplay devices, which is really Silly.
The lock screen controls were a feature I used constantly. I, like other people have already posted have no airplay 2 devices but I do have airplay 1 devices. I have to unplug all these devices to get the lock screen controls back which is just silly
Userlevel 4
Badge +18
This is an issue Apple created with the Airplay 2 changes. Now sure how Sonos could win here? Delay Airplay 2 playback and face the wrath of the mob here or enable it with this issue and still face the sort of posts above. :8
Userlevel 2
I'd really like my lock screen controls back. I have been using my Apple watch to control Sonos for years! Huge step backwards for this app. Very disappointed.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings