Answered

New Asus RT-AX82U/AX5400 Router Sonos System Not Showing Any Recommendations?

  • 5 December 2020
  • 25 replies
  • 1538 views

Badge

Background:

Family Room: AMP w/Sonos ONE (pair as surrounds)

Backyard: Connect(gen2)

Asus RT-AX82U/AX5400 Router

After installing new router and updating the wifi settings, the Sonos App (S2) does one of the following: 1) stays grey and doesn’t show up 2) only shows the Connect 3) Works perfectly for 3-5 seconds and then the system dissapears.

I've gone in and adjusted the router settings as recommended in various help sections, turned off the auto-priority/QoS settings in the router, updated the channel to Ch6 within the 2.4 channel, did the whole direct plug ethernet cord into the amp, and ONE speaker to update the wifi information directly as recommended. Also rebooted all sonos products.

The only thing working right now is the family room because it feeds audio in from the TV.

Any recommendations or links would be helpful...spent the last few days becoming a fake fix-it dude.

 

Thanks!

icon

Best answer by Toad74 18 December 2020, 22:07

Thanks @controlav for pointing me in the right direction!!!

 

Rolling back the Asus firmware for my RT-AX82U router from

Version 3.0.0.4.384.10177

2020/11/26 

to 

Version 3.0.0.4.384.9948

2020/11/03 

has allowed all three of my SONOS speakers function as expected.

 

@controlav

View original

25 replies

Userlevel 6
Badge +17

Hi @Long Beach Cliff May.

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

 Hi @Long Beach Cliff May .

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

​Our engineering team have been made aware of some ASUS RT series router that causes some issues with Sonos and has provided some work arounds. Let me share with you these troubleshooting steps to get things sorted.

  • First is we need to download the Asus App through this provided link.
  • Once the Asus app have been downloaded, Let us connect to the Asus router’s WiFi network and open the Asus app.
  • On the Asus app look and tap on devices.
  • Scroll to the blocked devices and look for Sonos and tap on it to open a new menu.
  • On the newly opened menu, look and tap on Disable Block Internet Access.

I hope this helps.

Please keep me posted on the progress and let me know how it goes. Here in the community, everyone is welcome.

Thanks,

Very much the same issue here with this same router.  Has there been any progress on ising this router?

Userlevel 7
Badge +21

Asus seem to be unable to produce router software that is compatible with Sonos:

 

 

Thanks @controlav for pointing me in the right direction!!!

 

Rolling back the Asus firmware for my RT-AX82U router from

Version 3.0.0.4.384.10177

2020/11/26 

to 

Version 3.0.0.4.384.9948

2020/11/03 

has allowed all three of my SONOS speakers function as expected.

 

@controlav

Userlevel 7
Badge +21

If its not too late, I would suggest returning it and buying my fave, an AmpliFi HD.

Userlevel 2
Badge

I have exactly the same issue.  Purchased an RT-AX82U and have been unable to get my Play1 to operate properly.  Connection is flaky.  When I used the Sonos2 app originally to try to set it up the Sonos wifi network didn’t show on the network list.  

I’ve tried all the advice with no success.  No thinking of going back to my old router as that worked first time!

Any advice appreciated.

Thanks

 

 

 

Userlevel 6
Badge +17

Hi @kilfinan.

Welcome to the Sonos community and thanks for reaching out to us. Allow me to share some information to help you out.

I would like to share with you a reply i have posted above as the work around for Sonos to work with Asus Rt series router.

Hi @Long Beach Cliff May.

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

 Hi @Long Beach Cliff May .

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

​Our engineering team have been made aware of some ASUS RT series router that causes some issues with Sonos and has provided some work arounds. Let me share with you these troubleshooting steps to get things sorted.

  • First is we need to download the Asus App through this provided link.
  • Once the Asus app have been downloaded, Let us connect to the Asus router’s WiFi network and open the Asus app.
  • On the Asus app look and tap on devices.
  • Scroll to the blocked devices and look for Sonos and tap on it to open a new menu.
  • On the newly opened menu, look and tap on Disable Block Internet Access.

I hope this helps.

Please keep me posted on the progress and let me know how it goes. Here in the community, everyone is welcome.

Thanks,

Here is also a post from @controlav’s post regarding his recomendations.

Asus seem to be unable to produce router software that is compatible with Sonos:

 

 

I hope these pieces of information helps.

Please let me know how it goes and keep me posted.

Thanks,

Having the exact same issues, I have not tried changing the firmware, but I’ll have a look to it tonight.

@Paul A Your recommendation are not suitable.

No one said the device were blocked by the router. What you suggest would fit if the user would have “Blocked” the device at some point which is not the case.

The devices are not blocked, at least not from a user point of view, but the router might be blocking some port, or acting on the channel etc in a way the interferes with Sonos...

I have been struggling for a week and thankfully came across this message and installing 

Version 3.0.0.4.384.9948

2020/11/03 works for me also!! 

Add RT-AX58U to the list, bought a new router a week ago updated firmware connected everything including Sonos system. 

Devices show connected in router interface but wouldn’t stay connected to the Sonos App. Found this thread reverted to version 3.0.0.4.384_9918 from 11/03 and it’s working great now.

 

 

Badge

Just joining the party and rolling back to 384.9948. Fingers crossed. 

I’ve lost a weekend faffing. So hopefully it’ll work.

Just wanted to say the rollback to 3.0.0.4.384_9918 seems to have also worked for me. I unplugged all my Sonos devices and rolled back the firmware on my router. So far so good!

We have an RT-AX82U router and were having the same issues too. As well as rolling back firmware, the new beta version  seems to work too - 9.0.0.4.386_41994

We have an RT-AX82U router and were having the same issues too. As well as rolling back firmware, the new beta version  seems to work too - 9.0.0.4.386_41994

I tried the latest beta, and although I can set it up wirelessly (by first going wired, and configuring it), it still glitches out whenever I try to use amazon music, setup google assistant, or even stream sonos radio. Again, this is on RT-AX82U with latest beta firmware. The fairness setting is disabled by default for both 2.4 and 5 bands.

We have an RT-AX82U router and were having the same issues too. As well as rolling back firmware, the new beta version  seems to work too - 9.0.0.4.386_41994

 

Tried the latest, but it brought back the old issues. Rolled back to 3.0.0.4.384.9948 and its working again. Thinking of picking up a new router. The beta has some critical security needed for this router.

Userlevel 7
Badge +21

Tried the latest, but it brought back the old issues. Rolled back to 3.0.0.4.384.9948 and its working again. Thinking of picking up a new router. The beta has some critical security needed for this router.

Good idea. I personally recommend the AmpliFi HD as it is super reliable, created by a highly regarded network company, and offers mesh extenders if you need those.

Hi

have tried everything, the only thing that works is:

 

Rolling back the Asus firmware for my RT-AX82U router from

Version 3.0.0.4.384.10177

2020/11/26 

to 

Version 3.0.0.4.384.9948

2020/11/03 

 

/Rahyman

Userlevel 1

I just got a Beam, and router Asus RT-AX58u, the BEAM always disconnecting from wifi, I tried everything I read here on the Sonos community about Asus routers, especially the RT ones, I decided to update to the latest firmware so after the update same problems, beam disconnecting again...i read somewhere here to try a router factory reset, so I did that and BAM the Beam is working well, not disconnecting anymore.

I suggest you guys try this router factory reset after firmware update.

UPDATE: I found the upload feature in the admin settings of the router and uploaded it there, so far it seems to be working. Has anybody contacted ASUS about this issue?

 

Quick question… How do you get the rescure mode activated on the AX82U?

I’ve tried plugging in and holding RESET until the power indicator flashes slowly, I also have the 2.4Ghz light strobing; however, when I try to upload the firmware shown above, the software states the router is not in recovery mode!

Any help would be appreciated, my Sonos system is currently bricked.

TIA

/Simon

I have a quick follow up, has anyone tried implementing a boost to their system?

Presumably the hard wired connection and dedicated separate network would allow all speakers to work?

just considering my options because I want to be able to use my system without having old firmware on my router!

Userlevel 7
Badge +21

I have a quick follow up, has anyone tried implementing a boost to their system?

Presumably the hard wired connection and dedicated separate network would allow all speakers to work?

just considering my options because I want to be able to use my system without having old firmware on my router!


I would just get a new router, clearly this Asus range has some major trouble with actually passing network packets in the correct manner and they seem incapable of fixing it.

An AmpliFi Instant costs the same as a Boost.

Just wanted to thank the community here for finding this out. I was pulling my hair out trying to get everything to work; speakers kept dropping off, music services dropping off, and occasional playing would stop every 3 seconds.

 

I’ve reverted my RT-AX82U router to 3.0.0.4.384.9948 and it worked for me too. The SONOS support pages do suggest turning the AirTime Fairness setting to off (which is definitely the default in .9948 - not sure about others?), but I don’t think that works here.

 

If anyone does get success with a later firmware please re-post here. I’m not missing out on anything from the updates until the most recent beta’s security patch (9.0.0.4.386.41994) but I’m keen to get that in as soon as I can. I’ve emailed ASUS customer support but feel it unlikely I will get anywhere as they likely have raw performance as their target.

Hi,

 

I have been using a power line as i couldn’t get the Sonos to work on my Asus RT-AX86U running 3.0.0.4.386_42095      but i just disabled QoS and everything now works over wifi..

 

airtime fairness is disabled

Tried the latest, but it brought back the old issues. Rolled back to 3.0.0.4.384.9948 and its working again. Thinking of picking up a new router. The beta has some critical security needed for this router.

Good idea. I personally recommend the AmpliFi HD as it is super reliable, created by a highly regarded network company, and offers mesh extenders if you need those.

The AmpliFi HD has a buggy dual-band and doesn’t support WiFi 6. I literally just replaced it with an Asus RT-AX3000, which works perfectly with proper dual-band for all my devices, it easily pulls 700 mbps down throughout my house (over twice what the HD could do). Everything except Sonos works like a charm, so I think this is on Sonos.

Userlevel 7
Badge +21

The AmpliFi HD has a buggy dual-band and doesn’t support WiFi 6. I literally just replaced it with an Asus RT-AX3000, which works perfectly with proper dual-band for all my devices, it easily pulls 700 mbps down throughout my house (over twice what the HD could do). Everything except Sonos works like a charm, so I think this is on Sonos.

Given all the posts/threads here about Asus not working correctly, and your single comment about some alleged issue with the AmpliFi HD, I can only LOL at your claim. While I have a totally reliable system.

Reply