Asus ZenWiFi AX rotuer QoS feature doesn't work with Sonos

  • 27 January 2021
  • 34 replies
  • 7521 views

Userlevel 2

If you have one of those Asus routers which support Quality of Service (QoS) feature to prioritize different kind of traffic (Streaming, Work from Home, etc.), this may be helpful to you. When I enabled this feature I had lot of issues with connecting to various Sonos speakers, or playing music on them, or adding a new speaker to the system, etc. Once I disabled QoS feature in the router, everything worked seamlessly.

I have ASUS ZenWiFi AX6600 (XT8) router.

Naveed.Ahmad 8 months ago

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

Userlevel 5
Badge +16

Hi there @Naveed.Ahmad.

Thanks for reaching out, let me check it for you.

There is a known issue of association failures with  ASUS routers that has Airtime Fairness, and the symptoms are the same as you described. 

We suggest disabling the said feature as a resolution and here are the steps to follow: 

  • Log into the ASUS router.
  • Under Advanced Settings, click Wireless.
  • Click the Professional tab.
  • Disable Airtime Fairness and click Apply.
  • Change the Frequency to 5GHz.
  • Disable Airtime Fairness and click Apply.

 

Let us know how it goes and if you have any questions feel free to reach out.

 

  • Log into the ASUS router.
  • Under Advanced Settings, click Wireless.
  • Click the Professional tab.
  • Disable Airtime Fairness and click Apply.
  • Change the Frequency to 5GHz.
  • Disable Airtime Fairness and click Apply.

 

Let us know how it goes and if you have any questions feel free to reach out.

 

I have the Asus RT-AX86U router and have noticed that Airtime Fairness is disabled by default. I’m unfortunately having the same problems many others are having.

I have the same issue with the Asus ZenWiFi XT8 AiMesh Airtime Fairness is disabled on all channels 2.4GHz, 5-1GHz, and 5-2GHz. The problem persists. 

Userlevel 5
Badge +16

Hi @darrylyoung, thanks for your response. @maxgro, thanks for reaching out, let me help figure this out.

Kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number. I'd start by reviewing your system,  it will help in identifying what's possibly causing the issue.

 

Looking forward to hearing from you soon.

Userlevel 2

@Annazel S, I already had Airtime Fairness disabled. And I am sadly reporting that disabling QoS also did not fully fix my problems. My speakers keep on disconnecting.

Here is a workaround that I applied today, which has worked so far throughout the day. I have connected one of my Sonos speakers (Play5 in my case) through ethernet cable to my modem. And the rest of the speakers have stayed connected so far. If this stops working, will report it here again.

FWIIW, I think the problem started happening when my routers received the firmware update ver 3.0.0.4.386_26044. Not sure if that’s the case for others too.

Userlevel 7
Badge +22

Many other threads indicate ASUS routers need to run older firmware to be fully compatible with Sonos. I would recommend people switch to a reliable router supplier, I personally recommend AmpliFi.

Hi, 

Echoing the above post, I was completely dead ( QoS and Airtime Fairness off) until connecting one speaker via Ethernet, then bringing the others back online one at a time and they are now communicating via “SonosNet” wireless and show up as hardwired devices from the routers perspective. 
 

Not completely ideal but it works for now!

Userlevel 2

It’s a bummer. Asus ZenWiFi XT8 router has received rave reviews and it is pretty awesome router. It provides free parental control and free blocking of adult content, whereas other router manufacturers charge for it. It also provides free ad. blocking from pesky 3rd party ads. For these reasons I am keeping the router. I wish Sonos and Asus work together to find a solution. Until then I am working around the issue by hardwiring one Sonos speaker with the router. Thereby, allowing other speakers to connect via SonosNet.

Problem solved, downgrade the latest firmware on the Asis XT8, it’s a mess, not only Sonos stopped working but basically everything on the 2.4GHz band that isn’t a phone or computer. My whole smart home fell apart after the Firmware upgrade. I downgraded the firmware of the router and everything worked again.

Here is the exact description of the issue

https://www.snbforums.com/threads/xt8-fw-3-0-0-4-386-26044-breaks-sonos.69574/

 

Quick update: I updated to the beta firmware 9.0.0.4.386.41994 on my Asus RT-AX86U router after speaking to somebody at Asus. They told me the following, after I explained the Sonos issue:

We are sorry to hear, that your Sonos system does not work properly after updating to the Firmware version:3.0.0.4.386_41535 on your RT-AX86U router. 
According to the information you sent us, it seems to be a Software issue. Therefore you should update the Firmware to the latest Version 9.0.0.4.386.41994 from 2021/01/29. This should fix the problem with Sonos. 
You will find the Firmware under the following link: https://www.asus.com/Networking-IoT-Servers/WiFi-6/All-series/RT-AX86U/HelpDesk_Download/

After updating the router firmware, I factory reset all of my Sonos speakers (again) and managed to set them up properly. Previously, I managed to do one but then all others would fail. I’ve only had it up and running for a couple of hours so your mileage may vary but I wanted to share anyway.

Hopefully they’ll push a proper release of the firmware soon so you don’t need to mess around with betas.

Here’s my experience with the Asus XT8’s and the most recent firmware including the beta.  

With the Beta, when I launched the Sonos app, all my speakers showed up. This was a change from firmware versions 26044 through 41793, as when I'd launch the app with those installed, only a few of my speakers would appear.

I thought I was good to go, but then I tried to play a song from one of the streaming services (Apple Music), and while the songs in the playlist showed up and were added to the queue, nothing would play, and I constantly received the error "cannot connect to Apple Music". Interestingly though, I could play local media on my network.

I reverted back to firmware version 25790 and everything is working as it should.  Seems like Asus is close to getting it right and hopefully once the final version of the latest beta is out everything will be fixed.

Userlevel 2

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

 

Hi, can you confirm that streaming services are also working without issue?  On the beta firmware for my XT8 (9.0.0.4.386.41994) all my speakers showed back up but I was not able to stream.  I could play music from my local library but no streaming services, ex. Apple Music or Sonos Radio.

Thanks, for going the extra mile on the reset, hopefully, it’s the fix we need!

I can confirm what Naveed.Ahmad originally posted that firmware version 3.0.0.4.386_41793 does work with my Sonos system after performing a factory reset as outlined HERE. This includes all streaming services and speakers.  I’m WiFi-only and have everything from amps to subs, playbase, beam, move, play 5,3,1’s.  

Thanks, Naveed.Ahmad for going through the factory reset!

 

Hi,

I think I’d like to chance the upgrade to 41793 based on @Naveed.Ahmad & @sean-a-thon success.

I’ve taken a look at the factory reset instructions in the link, but there does not appear to be any advice on FR 2 nodes.

What method did you use?  e.g do satellite node first on a XT8 etc 

 

Thanks

Userlevel 2

@Minimos, I initiated factory reset from my ASUS app on my Android mobile.
@sean-a-thon, Yes music is playing fine on the speakers too. I use Amazon Music service.

Sadly though, the Asus node disconnection problem reappeared. It would start blinking blue light and would not connect back again until I turn the node off and on again. The signal strength between the primary router and secondary node is otherwise great. I am beginning to think that investing in Asus router was a bad idea. It has given me enough grief. I ended up connecting the two routers via Ethernet cable, and repurposed the otherwise dedicated 160MHz backhaul for regular WiFi use.

@Naveed.Ahmad 

Thanks for the info.

To be a Guinea pig as well I’ve made the jump.  I had tons of trouble getting my Satellite node back online after the upgrade.  Eventually did a factory reset, removed the main node, plugged in the Satellite to flash matching firmware, factory reset again and the node got picked up.

So far so good, but you noting drop out again concerns me, I’ll see how it goes and report back in a few days. One thing worth trying is making sure the Wireless Settings are not left on 5GHZ-2 in the UI.  My 2nd node dropped after I changed some settings couldn’t figure out why, altering the view back to 2.4/5Ghz-1 solved the issue.

Also, I am pleased to report my Xbox Live issue is also resolved,  I had to change the NAT to Full Cone in the WAN setting (this is a new option not see on 25790).  It defaulted to Symmetric on install, and it had the same issues as 26044, but changing this resolved the issue.  I think even though it was not shown in 27590 Full Cone NAT was the default.

I have the XT8 and have been having loads of problems with my Sonos system, I have today installed the 3.0.0.4.386.41793 update, not brave enough for the beta version at present, i just let the XT8 do its own update, and since it did the Sonos are all online for the first time in weeks, alexa works fine too and i can access music from my plex server on them. Will see how it goes over the coming days.

Hi

Here's an update.

 

The Beam worked perfectly including Alexa until I added the Satellite, did not notice it had stopped working until I tried to change the volume and it did not respond (was testing all my other IOT devices worked with the new firmware)

 

Noticed that the DHCP assignments showed as static.  Anyway plugging back in an ethernet cable to the Beam solved the issues again.

 

I was digging around this forum and and found:-

The update was only an hour old, so I made the changes suggested to multi cast on the LAN, it did something as instantly all the DHCP assignments  for my Sonos devices changed to DHCP from static.  I thought this was the golden goose, unfortunately switching it back to wireless only brought back the issue of not being able to use Alexa or alter volume on the Beam over WIFI.

 

Just so we can get some consistency, My Beam has 2 SL ones as surrounds, I also have 4 other Play:1 in the house and a legacy Play:5, All bar the 5 are on S2.

 

QOS is currently on in the router.

 

Has anyone had success with an XT8 and a Satellite node?  I am conscious maybe some people reporting success age different setups, and getting to know how each is different may allow us as a group to find a solution

 

Thanks

 

Minimos

 

 

 

 

 

 

 

 

 

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

YES!!!! 3hrs on with support they couldn’t help. 5min search thru the community posts and BAM! Fixed!! Thank you!

Ok last update from me, hopefully will help others in a similar position who have not been lucky enough for a factory reset to resolve issues.

I disabled the Play:5 on S1 to see if that was interfering, rebooted all devices and it made no difference.

I then re-enabled the multicast LAN option, the Beam started working again with Alexa voice commands and responding to volume control from the app.

However, I could not play a music service to the Beam, I either get non Sonos product found or can’t add to queue error messages. This is the same for local sources and remote like Deezer, Sonos Radio etc

All the other Sonos devices in the house can stream music from services, and be grouped etc.

Adding in the Play:5 back into the mix did not break anything else, so I can rule the mix and match of Sonos software out as the problem.

I think, I’ve narrowed it down to the new firmware not being able to handle a system configured with surround speakers.

I’m leaving the cable in for now as it all works as it should, I’m lucky that my Beam is near a switch in the entertainment system, but its really annoying that I am so close to having it back as it was on 25790

I have Asus ZenWiFi AX…. got it up and working, then connected Arc, Sub, and surrounds.  All worked great.  Then made the mistake of updating firmware to 3.0.0.4.386_41793.  Probably 5 mins later system wasn’t able to be detected.  Quick internet search got me to this forum.  Reset back to factory reset… and works perfectly (all wifi). Not really too excited to start messing with things again at this time.  But there’s something about that update it doesn’t like.  

Problem Solved: I am glad to announce that all my Sonos speakers are now working fine with Asus Zen WiFi XT8 router. Here is what I did.

Asus released a new firmware 3.0.0.4.386_41793, but against all my hopes that did not fix it either. I then did a Factory Reset on the router. Set my WiFi’s name and password the same as before. And all my devices including all my Sonos speakers are connecting fine and playing music fine with WiFi.

I no longer need to connect one of the speakers through Ethernet cable to make the rest connect through SononNet network as the workaround.

Hope this solves the problem for all of you guys.

PS. I thought about doing a factory reset because my secondary node kept on disconnecting and flashing green light after the firmware version 41793. Factory reset solved that problem too.

Just remember that a factory reset wouldn’t help if you’ve already updated your router (it has already written over your “out of the box” firmware). What you need to do is to downgrade to an older version of the firmware. For example, it seems that version 25790 is the last working one without any troubles for Sonos speakers. Find all the Asus firmwares here: 

https://www.asus.com/Networking-IoT-Servers/Whole-Home-Mesh-WiFi-System/ZenWiFi-WiFi-Systems/ASUS-ZenWiFi-AX-XT8-/HelpDesk_BIOS/

I have also been running firmware 3.0.0.4.386_41793 and was having disconnect issues on only 2 of my 5 speakers.  I was working with Sonos support for about a week trying various things to resolve.  Yesterday I did a factory reset and so far the disconnect issues have not reoccurred.

After having upgraded my XT8’s (1 router + 2 nodes) to latest firmwared 3.0.0.4.386_4179 I encountered the exact same problems you all seem to be having. I did try the factory reset, both via UI and via the WPS-button but with no joy. I then decided to downgrade back to version 25790 and now it’s all FINALLY working again (and I don’t think I lost too many settings going from latest fw to 25790). For me it seems the only way was to downgrade again, and hey, with this thing now working, I do think the XT8 is otherwise a great system so I really hope ASUS work this issue out for the next release of firmware version!!!