F.A.Q.

Troubleshooting Sonos on WiFi

Troubleshooting Sonos on WiFi
Userlevel 7
Badge +18

Hi Folks, 

I’ll share some general advice about how Sonos products connect to your network, and the kind of network problems that can result in dropping rooms, to help you understand and solve some challenges with your Sonos system.

Updated 21/4/23

 

2.4 & 5GHz bands (and WiFi 6)

A few older Sonos devices will only connect to the 2.4GHz band, whereas most will connect to the 5GHz band broadcasted from your router. A full list of which devices will connect to 5GHz can be found here on our Supported WiFi modes and security standards for Sonos products page, under “Products that can connect to 5GHz WiFi networks”. Era 100 and Era 300 will connect to 802.11ax (WiFi 6) or 802.11ac (WiFi 5).

Home Theatre products will not connect to 5GHz, as the 5GHz radio is reserved for talking to the surrounds and Sub(s).

Sonos will perform best on 5GHz as it is faster, has lower latency and has less congestion. 2.4GHz still has it’s advantages, however, as physics dictates that it has a better range and a stronger solid-matter penetration ability (it gets through walls, ceilings and furniture easier), so do not be too concerned if your router informs you that your Sonos device is utilising it. Due to the amount of varied use of 2.4GHz, it can be important to ensure that you do not use channels that overlap with other nearby sources (1, 6 & 11 are the only channels that do not overlap - it’s best to stick with these).

Although we used to recommend splitting the bands on your router so that they had different credentials, we now recommend letting the router do it’s work with band steering - this way, one set of credentials can get all your devices connected to the best band for them (this will vary with model and location/reception). If in doubt, please get in touch with our technical support team.

 

Mesh Networks

If you have a mesh WiFi system to extend the range of your WiFi, and your original router is still present, you must either:

  • Configure your router to act as a modem only. Some have a specific option for this (like Virgin Media in the UK), but on most router’s you’d need to disable the DHCP server. If you still need to use the WiFi coming from your router, or if you connect devices via ethernet to it, this is not an option. Doing this will allow you to use the usually more advanced routing features on your mesh (as compared to those on a free, ISP-provided router).

    or
  • Configure your mesh system to be in ‘Bridge/AP mode’ - otherwise it acts as a router and you now have two logical networks running on one hardware layer (this is commonly referred to as Dual DHCP). To find out how to do this, perform an internet search for “[name of your mesh system] mesh bridge mode”. I’ve listed a few common ones here:

 

Netgear Orbi mesh: https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point

Linksys Velop mesh: https://www.linksys.com/us/support-article?articleNum=243548

Tenda mesh: https://www.tendacn.com/faq/3123.html

Eero mesh: https://support.eero.com/hc/en-us/articles/208276903-How-do-I-bridge-my-eeros-

Google mesh: https://support.google.com/wifi/answer/6240987 - In my experience Google mesh systems can be difficult about going into Bridge mode. Please contact Google if you have trouble with this.

 

Extenders / Boosters / Powerline adapters / Sky Q

Another challenge, with networking and Sonos, is WiFi boosters and extenders. Sonos does not support these as they halve your available bandwidth (due to being half-duplex) and often block multicast transmissions which gets in the way of the Sonos system from operating smoothly. 

Powerline line adaptors can also induce additional issues as they are subject to noise present on your mains power supply (‘noise’ is created by some LED dimmers, for example).

In the UK, Sky Q boxes can be a challenge with Sonos, as they repeat the WiFi from a Sky router (but not from other routers). If a speaker connects to one of these (common with Sonos Home Theatre products) it can result in the speaker being missing from the Sonos app. One option would be to use SonosNet by connecting one or more Sonos devices (not Era - Era does not use or create SonosNet) to the network with an ethernet cable. For other options, I recommend contacting our technical support team.

 

Sonos and Ethernet

To bypass some WiFi configuration issues, you can connect any one (or more) Sonos devices to the network with an ethernet cable (Sonos Move & Roam excluded). Wired Sonos products (other than Era models) will transmit a ‘Sonos only WiFi’ for use by your other Sonos devices (Sonos Move, Roam & Era excluded). This all happens automatically, but sometimes your speakers need a power cycle (unplug them from the wall socket, and plug them back in again after 30 seconds) to help them along. Wiring Sonos will not resolve anything if you have two routers on your network (as described in the Meshes section). Each Sonos player that picks up the ‘Sonos only WiFi’ from the wired Sonos speaker will rebroadcast it, thus extending the range for speakers out of range of the wired one(s). 

When you wire a Sonos product, you go from a configuration like this:

Sonos using your WiFi​​​​

to one like this:

Sonos using Sonosnet

It is worth pointing out, however, that the bandwidth available on 2.4GHz (which SonosNet uses) is limited. If you’re going to group a lot of rooms together, we recommend having one wired unit for every 5 non-wired units, and these wired units would ideally be evenly distributed in your home.

As long as you have good WiFi coverage, your router’s WiFi will often be a better option. As became evident with the release of the Era speakers, we are now moving away from SonosNet which was only really needed back when routers were not the more capable devices that they are today.

 

WiFi Noise / WiFi interference

Sometimes it’s just not a network configuration issue. All WiFi devices (not just Sonos) like to have at least 1 meter / 3 feet of space from all other WiFi devices (and devices that are not on your WiFi but may use similar frequencies). In my experience, one of the most common solutions to a ‘WiFi problem’ has been to physically move a speaker/Boost/Bridge farther away from the router it’s wired to. A common misconception is that the closer the device is to the WiFi broadcasting unit the better - this is not the case. Sometimes speakers are kept very close the router, but this is far from ideal - these devices should not be located less than 1m apart from each other. We have a helpful guide on reducing wireless interference. Close by glass or metal surfaces can reflect WiFi back at a device and also create interference. 

Interference is, I would say, the biggest cause of problems, like dropped rooms, or music interruptions, for Sonos users.

Many non-WiFi devices will use 2.4GHz - mobile/cellular telephones, baby monitors, smart meters, CCTV cameras, DECT phones, microwave ovens - the list goes on. This is another reason why 5GHz can be a better choice for your Sonos system to connect to - less congestion, more channels, more bandwidth, better experience.

 

Home Theatre

As mentioned above, Home Theatre Primary devices (like Ray, Beam or Arc) will connect to 2.4GHz WiFi or SonosNet. However, their surround speakers and Sub(s)/Sub Mini will connect directly to the HT Primary over a dedicated, low latency 5GHz channel. So, if you ever experience audio interruptions on your surrounds or Sub, keep in mind that the cause could be interference near the HT Primary just as much as it could be interference near the surrounds/Sub.

Audio interruptions of TV audio heard on the Home Theatre Primary itself have nothing to do with interference or networking - this is most commonly fixed by forcing the TV’s software to restart by unplugging the TV for a couple of minutes.

 

Network Configuration (IP Reservation and IGMP Filtering)

Sonos needs no more from your network than many other devices, but it can often help to reserve IP addresses for the devices that commonly connect to your network, including Sonos.

Normally, connecting devices send out a broadcast asking to be assigned a unique IP address so that they can be found and recognised on the network. If, for whatever reason, the router loses track of which clients have which addresses (if it reboots but the devices keep their IP, for example) it can start distributing out IP addresses that are already in use. This can result in the Sonos app asking a particular speaker (by it’s IP) if it is still online and ready to operate, but because the speaker is in fact a smart refrigerator, it doesn’t reply, resulting in a room dropping from the Sonos app.

To combat this, reserve IP addresses in your router’s settings pages for all the devices that commonly connect. This will greatly reduce the chance of such an occurrence, and has often been the answer to many user’s woes.

How to do this exactly will depend on your router, but the option is typically found in the Network or DHCP section of the settings. If your router has a Basic/Advanced settings division, this will most likely be in Advanced. Please consult your router’s manual. For a typical installation, your router’s own IP address will be, for example, 192.168.0.1, 192.168.1.1 or 10.0.0.1 (though other addresses are possible and common). The “DHCP pool” will be a range of addresses that the router will distribute to client devices, which will often range from 2 to 254 on the last number of the address. I recommend narrowing this somewhat to perhaps 30 (or higher if needed) to 254, then reserving addresses for regular client devices (including Sonos) between 2 and 29.

After making any such changes, it’s a good idea to reboot the router and then the devices that connect to it, but from then on things should be pretty stable.

Not all routers have IGMP Snooping/Filtering, but if yours does, it’s a good idea to turn it on. This feature prevents multicast (more than one destination) data packets on the network that are not destined for Sonos devices from clogging up your speakers’ network input buffer with data it doesn’t want. IGMP-capable network switches can also be bought cheaply, but will only help a Sonos system using SonosNet, and should be fitted between the router and any Sonos devices wired to it.

 

Controllers

It may be that you cannot connect to Sonos not because your Sonos system is having trouble connecting to the network, but because the device you’re running the Sonos app on is unable to communicate with the System (or parts of it).

Although this can be caused by a few things, the most likely are the following:

  • Multiple Access Points - WiFi boosters and Extenders tend not to work very well. Often, you can only connect to rooms that also connect to the same extender your phone is on, or can’t connect to them because your phone is on the main router’s WiFi. We don’t support the use of these products for this reason. Mesh systems are not affected by this. In the UK, Sky Q boxes repeat WiFi from Sky routers in this way.
  • Guest WiFi - You cannot run Sonos on a Guest WiFi, nor can the Sonos app connect to a Sonos system if the controller is connected to a Guest WiFi.
  • On iOS devices - make sure you give the Sonos app permission to access devices on the Local Network (more info on our Sonos app permissions help page)
  • On iOS devices - make to to disable Private Address in the iOS connection options for your WiFi network.

 

Help

Sometimes, no matter how much you know, the speakers themselves have to be ‘consulted’ as to what is going wrong before you will find a resolution. In such situations, the only solution is to get in touch with our technical support team who can receive your Sonos system diagnostics which will tell the agent all about what your system has experienced. If you’re going to call/chat with our tech agents, please try to recreate the issue you are experiencing just before getting in touch, if you can, and try not to reboot any players - reboots clear the system logs and as a result the diagnostics contain less information. 

 

I hope this helps you to understand a bit of what’s going on when no steps taken seem to be working for you. As always, we’re more than happy to assist with getting your Sonos system stable, so please either get in touch with our tech support if nothing works, or write here on the community if you need more guidance.

 

 

Edit: Updated to include additional mesh options, Roam and some other details.

Edit: Updated to include iPhone Local Network and Private Addresses options as they can affect connecting to Sonos

21/4/23 Edit: Changed some advice regarding WiFi bands to reflect software improvements, added Network Configuration and Home Theatre advice


87 replies

Userlevel 1
Badge

Thanks for prompt response.  Mine is a Plusnet2 - effectively a recycled BT router!!  I will investigate your suggestions.  Thank you.

Thanks for prompt response.  Mine is a Plusnet2 - effectively a recycled BT router!!  I will investigate your suggestions.  Thank you.

Maybe one way to find out if it is the router, is to put all on the 2.4Ghz band and switch off the routers 5Ghz band (just temporarily, whilst testing) and see what happens in that case.

Just ensure the 2.4Ghz SSID name is shown as listed in your Sonos App “Settings/System/Network/Manage Networks” and that your mobile controller is using that same band too for connection to the LAN.

What might also help is setting the bands channel-width to 20Mhz only, as that will reduce interference. Set the wifi to use either channel 1, 6 or 11 as those channels are non-overlapping.

My guess is it should resolve your issue and then you can maybe move forward from there to resolve things more permanently. As I mentioned, using SonosNet and reserving the device IP addresses may also prove to be helpful.

For what it’s worth: I am using in multiple sites Netgear routers with DD-WRT firmware which are programmed to reboot once a week and very seldom had any connection problems with my SONOS gear, a mixture of ONEs, Play:5, Move, Roam, Beam and Symfonisks.

Userlevel 1
Badge

Thank you ‘Ken_Griffiths’ - the SonosNet solution was quite the best and easiest to set up - fortunately, one of the Sonos Ones was within an Ethernet cable length and took minutes to setup and resolved all issues. Thanks again.

Userlevel 7
Badge +15

It's a shame that Sonos seem to be moving away from Sonosnet as a preferred setup as I find it a far more reliable setup than relying on router/mesh/AP setups…

It's a shame that Sonos seem to be moving away from Sonosnet as a preferred setup as I find it a far more reliable setup than relying on router/mesh/AP setups…

I assume there will be a period of transition, but at least WiFi 6 AX/E, or 7, will be much quicker than SonosNet v2 and hopefully the ‘device discovery’ issues will become a thing of the past across a WiFi mesh system - I don’t see any reason to not have everything operating on 5Ghz/6Ghz connections in the longer term. Home WiFi has greatly improved, but the cost of a multiple-hub mesh setup does need to come down in price. It’s not a cheap upgrade at the moment.

Userlevel 7
Badge +15

I agree but we're not there yet - nowhere near.

I see no reason at all that the new Eras couldn't have also used Sonosnet like every other non-portable speaker.  There may be one of course but I'm not seeing it..

I don’t understand the reasons why it doesn’t, but I’d assume there was substantial discussion around the issue at Sonos, before that choice was made. 

Userlevel 7
Badge +17

Which is why an explanation would be nice……

And give away their ‘company secrets’? There is a reason why we don’t get told everything. Sonos has competitors. Much as we’d love to know, I can I understand a certain amount of reticence on many subjects. 

Userlevel 7
Badge +15

Who knows but I doubt it was a big technical reason as they could have added that function without too much effort as they're Sonos speakers running Sonos software.  I think it was more strategic..

As for bandwidth etc., even ‘lowly’ 2.4GHz networks can transmit data huge magnitudes greater than even an Atmos stream requires - especially if there's multiple routes for that data to travel - called Sonosnet 😏..

I'm sure people could do tests on how much data is streamed at a time from different services but I recall doing some tests a few years back where I played a song for a few seconds and then disconnected my NAS shortly after startup and the song finished without issue so the cache is fairly large (moreso on newer S2 devices) if used correctly.  Obviously filetypes and sizes come in to play of course but people seem to have gotten into a mindset of 2.4GHz being so archaic -  yet I can Speedtest on my (2.4 SSID) WiFi and be in the hundreds of Mbps from t'internet.  Again, not everyone has those speeds incoming but it doesn't need a fraction of that to serve high quality audio - without worrying if you're connected to a different hub/disc/AP/channel….

 

Userlevel 6
Badge +11

@Corry P Can you advise how the portable Sonos devices handle roaming between 2.4GHz and 5GHz?

I have setup as per recommendations (single SSID), I am finding that when I ‘roam’ with the Roam outdoors, it seamlessly moves from 5GHz to 2.4GHz, as per you description above, uninterrupted music stream, so works well.

But I find once its on 2.4GHz, it doesn’t ‘roam’ back to 5GHz, even when idle/paused/woken up. Seems its stuck on 2.4GHz, even though there is less utilised higher bandwidth 5GHz available.

My other portable devices (mainly Apple) do roam back to 5GHz when indoors, so it seems specific to Sonos.

I don’t have band steering enabled, as the client should decide what is best connection.

Are you experiencing any issues because ROAM will not switch back to 5GHz?

Userlevel 7
Badge +18

Hi @craigski 

Firstly, I’m kind of with @buzz here - if there are no playback problems, don’t worry about it. Roam is unlikely to saturate the 2.4GHz bandwidth unless it’s the Group Coordinator for a large group of speakers.

I would recommend enabling band steering, however. Today, Sonos devices are better prepared to switch to 5GHz than they used to be a few years ago.

2.4GHz has a higher range than 5GHz, and it’s because of this fact that the Roam is switching to 2.4GHz once you are out of range of 5GHz. When the Roam comes back inside, it would need to struggle with it’s received 2.4GHz signal strength before it would think about switching to anything else, and if that was the case, 5GHz would definitely be out of range too. With band steering enabled, the switch should happen without the signal strength being too low, the router and client deciding together which band should be used.

I hope this helps.

Userlevel 6
Badge +11

No playback issues. Its really an academic/understanding question, I have observed other portable devices such as iPhone and iPad will re connect to 5GHz when available, even with band steering disabled.

My 5GHz is half as congested as the 2.4GHz, so I wanted to understand if the Sonos portable devices should roam back to the 5GHz if its available, as the original FAQ states:

Sonos will perform best on 5GHz as it is faster, has lower latency and has less congestion. 

 

If we are saying it’s not broken, ie working as designed, then I wont attempt to fix it. 😀

No playback issues. Its really an academic/understanding question, I have observed other portable devices such as iPhone and iPad will re connect to 5GHz when available, even with band steering disabled.

My 5GHz is half as congested as the 2.4GHz, so I wanted to understand if the Sonos portable devices should roam back to the 5GHz if its available, as the original FAQ states:

Sonos will perform best on 5GHz as it is faster, has lower latency and has less congestion. 

 

If we are saying it’s not broken, ie working as designed, then I wont attempt to fix it. 😀

As a suggestion, if you powered the Roam off ‘fully’ for a short while (5+ sec. power button press) and then brought it back online in the house where you previously had it working on the 5Ghz signal, my thoughts are it will then use that faster signal until you step outside and it becomes weak again. So that might be worth trying, rather than putting the Roam into standby/waking it up again.

Userlevel 7
Badge +18

Hi @craigski 

I am unsure of the exact operating logic behind the behaviour, and your quoted statement is correct, but yes, as the saying goes, “if it ain’t broke, don’t fix it”. However, I do think enabling band steering should ease the transition for Roam.

Incidentally, a reboot of the Roam would likely push it onto 5GHz if within range, though that isn’t exactly automatic.

 

Edit: Ken beat me to it!

Userlevel 6
Badge +11

Yes, rebooting Roam always gets it back on 5GHz inside. As does forcing a reconnection in the management interface on the AP.

 

 

I’m trying to set up my Play:1 to use WiFi but had zero luck. It connects fine with an Ethernet cable but no matter what I try, I just cannot get it to connect to my WiFi. I’ve tried a factory reset and added it as a new device, followed all the prompts in the app, pressing buttons when told to, get as far as connecting to temporary network SONOS but nothing, just a message saying mobile device couldn’t connect, move closer and make sure it’s powered on!

 

I’ve never had so much bother setting any other wireless device up. Why can’t I just tell it the SSID and password of my network and let it connect? 

I’ve never had so much bother setting any other wireless device up. Why can’t I just tell it the SSID and password of my network and let it connect? 

That would be what the “SONOS” temporary SSID is for. But since you’ve already tried wiring it once, just wire it again then go to Settings>System>Network>Manage Networks and add the SSID/password there. You can then remove the Ethernet.

I’ve never had so much bother setting any other wireless device up. Why can’t I just tell it the SSID and password of my network and let it connect? 

That would be what the “SONOS” temporary SSID is for. But since you’ve already tried wiring it once, just wire it again then go to Settings>System>Network>Manage Networks and add the SSID/password there. You can then remove the Ethernet.

I tried all that and just nothing worked. However I do now have it working!

I was using my phone, a Google Pixel 6 Pro to try setting up, I’d been through the force stop, clear cache, clear data to no avail so I though I’d try on a different device. I installed the Sonos 2 app on my Lenovo tablet, did a factory reset of the Play:1 and voila, the tablet worked perfectly, didn’t even need to plug a cable in.

I started the app on my phone and told it to connect to an existing setup which it did and so now it works from both phone and tablet.

I still think it shouldn’t be this hard.

I was using my phone, a Google Pixel 6 Pro to try setting up, I’d been through the force stop, clear cache, clear data to no avail so I though I’d try on a different device. I installed the Sonos 2 app on my Lenovo tablet, did a factory reset of the Play:1 and voila, the tablet worked perfectly, didn’t even need to plug a cable in.

I started the app on my phone and told it to connect to an existing setup which it did and so now it works from both phone and tablet.

I still think it shouldn’t be this hard.

In my experience it’s often down to the way the phone behaves. The temporary “SONOS” SSID is open and obviously not connected to the internet. A phone might try and start a VPN on an open SSID. It might baulk at a non-internet connection. Sometimes the “auto join/connect” settings can also get in the way.

Later Sonos units have gone over to using Bluetooth LE for this kind of configuration process.

This has been my experience. Sometimes the phone/pad will not notice the SONOS connection, claim that this is some sort of rogue connection, or simply time out.

Userlevel 7
Badge +15

Getting your speaker to a blinking green stage to fix almost any issue is something that should rarely, if ever, be needed (especially in systems where it's the only speaker you make have).  This is a factory reset and will cause one to lose ALL of the settings on that speaker and possibly your whole system.  It may have worked for you but it's wrong to post/suggest it as a general fix for the issue.  I have no idea of the switching or the relevance of the mic settings either.

This is ridiculously complicated for a system that costs what Sonos does and purports to do easily.

I just spent 2 hours trying to change the network my 4 sonos speakers connect to.   Error after error for something that should be easy enough.  Im done with it.  Piece of trash 

Reply