Sonos Play:1 won't connect after Wifi change

  • 17 March 2023
  • 4 replies

I setup a new router with a changed WiFi Id. I tried to update the network using Sonos 2 app but it couldn't find my speaker. I tried connecting the speaker directly to the router using ethernet and it still can't find the speaker. In the settings menu the System option is greyed out so I can't change the network settings manually! Why is sonos so bad at handling routine changes to the network!! How can I get my speaker connected?


Best answer by Airgetlam 17 March 2023, 19:29

View original

4 replies

If you’ve tried wiring it to your router already, then something’s odd going on, assuming that you were using the S2 app before hand.

If the PLAY:1 had been using the S1 app before, it will need the S1 app to connect to it now, and then you can upgrade it to S2. Then the S2 app will connect to it, and you should be able to change the network settings, and disconnect the temporary ethernet cable. 

I've used it for some time with the S2 app. 

Seems odd, then. Although extremely rare, it’s not impossible for electronic devices such as the PLAY:1 to fail. Have you tried to call Sonos Support directly to discuss it?

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 

No I haven't tried calling support, frankly I'm at the end of my patience! Perhaps later…

Thanks for your help.